webentwicklung-frage-antwort-db.com.de

xcode 8-Fehler vom Servicedelegierten abgelehnt (SBMainWorkspace)

Beim Versuch, einen Build-on-Simulator auszuführen, wird die folgende Fehlermeldung angezeigt:

Die Anforderung zum Öffnen von "com.companyname.appname" ist fehlgeschlagen.

Die Anforderung wurde vom Servicevertreter (SBMainWorkspace) aus folgendem Grund abgelehnt: Sicherheit ("Berechtigung" com.Apple.frontboard.debugapplications "zum Starten von Debugging-Anwendungen erforderlich").

Dies war nicht da, wenn die GM von Xcode 8, wurde aber sofort gestartet, als ich es erneut aus dem Mac App Store heruntergeladen habe. Google ist keine Hilfe und das Apple Entwicklerforum) auch nicht.

Hilfe oder Anregungen?

140
RyanTCB

Das Beenden des Simulators und das Neustarten haben dies für mich behoben.

328
Confused Vorlon

Empty setting causing error

Für den Fall, dass sich jemand fragt, was unter "leeren Einstellungen" zu verstehen ist, sollte dieses Kontrollkästchen deaktiviert werden, wie in der Antwort von maricle und im Kommentar von Vinayak GH erwähnt. Zumindest hat dies das Problem für mich verursacht.

82
clauswey

Stellen Sie sicher, dass Sie unter "Produkt"> "Schema"> "Schema bearbeiten"> "Ausführen"> "Umgebungsvariablen" keine "leeren Einstellungen" aktiviert haben. Dies verursacht das oben genannte Problem.

14
Anas

überprüfen Sie Ihre Schemaeinstellungen und stellen Sie sicher, dass alle leeren Einstellungen deaktiviert sind.

13
maricle

Das einzige, was für mich funktioniert hat, war:

Simulator> Inhalt und Einstellungen zurücksetzen

Bereinigen Sie dann Ihr Projekt und führen Sie es aus

12
Chris Edwards

Ich habe seit ein paar Tagen unter diesem Problem gelitten. Grundsätzlich habe ich alle Möglichkeiten ausprobiert, die im Internet zu finden sind, aber keine davon war in der Tat hilfreich. Ich habe Xcode sogar zweimal neu installiert (Xcode 8.3.2 8E2002, Simulator iOS 10.3 14E269). Und natürlich war an meinem Projekt, meinem Schema und den leeren Einstellungen nichts auszusetzen. Alles scheint normal zu sein. Schließlich stellte ich fest, dass der beste Weg dies zu lösen ist, bevor Sie Ihre App für den Simulator bereitstellen. Sie sollten Ihr Projekt bereinigen (Umschalttaste + Befehlstaste + K) und dann erneut ausführen (Befehlstaste + R). Dies wird Ihr Problem lösen.

3
Frank Wang

Build-Einstellung> Kombiniert> Verknüpfen> Mach-o-Typ zu ausführbar ändern

Das hat bei mir funktioniert, weil ich das vorher auf statisch geändert hatte.

2
bhagyash ingale

Für mich hängt das Problem damit zusammen, dass ich ein bisschen zu voreilig bin, um einige rot leuchtende Pod-Frameworks zu entfernen. Ich dachte, sie fehlen, aber der Berechtigungsfehler begann sofort, nachdem ich sie entfernt hatte. Der Fehler blieb bestehen, bis ich pod install, um die gelöschten Pod-Frameworks wiederherzustellen.

2
christopherpow

simulator neu starten ...

Das hat bei mir geklappt

1
theswed

Deinstallieren (Löschen) Sie die App vom Simulator und führen Sie sie erneut aus. funktioniert bei mir.

1
Sandeep Sonale

Ich folgte allen anderen Vorschlägen hier, und für mich würde es reparieren, wenn ich Xcode und Simulator neu starte, dann würde es einmal funktionieren. Danach würde das Problem erneut auftreten, bis ich einen weiteren Neustart durchführte.

Was es für mich reparierte, war das Schema zu löschen und neu zu erstellen.

0
Felix Dumit

Ich habe diesen Fehler erhalten, wenn ich das Zeichen "/" im Zielnamen verwende. Nach dem Löschen behoben.

0
ali6p