webentwicklung-frage-antwort-db.com.de

DKMS: Installation fehlgeschlagen

Jedes Mal, wenn ich das System aktualisiere und der Kernel aktualisiert wird, wird in den Protokollen von APT der folgende Fehler angezeigt:

run-parts: executing /etc/kernel/postinst.d/dkms 3.13.0-55-generic /boot/vmlinuz-3.13.0-55-generic
Error! Problems with depmod detected.  Automatically uninstalling this module.
DKMS: Install Failed (depmod problems).  Module rolled back to built state.

Wodurch wird das verursacht? Was bedeutet das? Muss ich das beheben? Wie behebe ich das?

Edit:

Hier ist die Ausgabe von dkms status:

$ dkms status
bbswitch, 0.7, 3.13.0-51-generic, x86_64: installed
bbswitch, 0.7, 3.13.0-52-generic, x86_64: installed
bbswitch, 0.7, 3.13.0-53-generic, x86_64: installed
bbswitch, 0.7, 3.13.0-54-generic, x86_64: installed
bbswitch, 0.7, 3.13.0-55-generic, x86_64: installed
bbswitch, 0.7, 3.16.0-34-generic, x86_64: installed
bbswitch, 0.7, 3.16.0-36-generic, x86_64: installed
bbswitch, 0.7, 3.16.0-37-generic, x86_64: installed
bbswitch, 0.7, 3.16.0-38-generic, x86_64: installed
bbswitch, 0.7, 3.16.0-39-generic, x86_64: installed
bbswitch, 0.7, 3.16.0-41-generic, x86_64: installed
nvidia-349, 349.16, 3.13.0-51-generic, x86_64: installed
nvidia-349, 349.16, 3.13.0-52-generic, x86_64: installed
nvidia-349, 349.16, 3.13.0-53-generic, x86_64: installed
nvidia-349, 349.16, 3.13.0-54-generic, x86_64: installed
nvidia-349, 349.16, 3.13.0-55-generic, x86_64: installed
nvidia-349, 349.16, 3.16.0-34-generic, x86_64: installed
nvidia-349, 349.16, 3.16.0-36-generic, x86_64: installed
nvidia-349, 349.16, 3.16.0-37-generic, x86_64: installed
nvidia-349, 349.16, 3.16.0-38-generic, x86_64: installed
nvidia-349, 349.16, 3.16.0-39-generic, x86_64: installed
nvidia-349, 349.16, 3.16.0-41-generic, x86_64: installed
virtualbox, 4.3.10, 3.13.0-54-generic, x86_64: installed
virtualbox, 4.3.10, 3.13.0-55-generic, x86_64: installed
virtualbox, 4.3.10, 3.16.0-34-generic, x86_64: installed
virtualbox, 4.3.10, 3.16.0-39-generic, x86_64: built
virtualbox, 4.3.10, 3.16.0-41-generic, x86_64: installed
2
SnakE

Es sieht so aus, als ob Sie Ubuntu 14.04 mit dem Kernel 3.16 verwenden.

Sie haben jedoch noch 3.13 Kernel-Metapakete, die diese Kernel herunterladen und installieren.

Einige DKMS-Module können nicht mit diesen Kerneln erstellt werden. Genauer gesagt bauen sie, aber installieren sie nicht richtig.

Ich schlage vor, 3.13 meta packages von zu entfernen

 Sudo apt-get remove linux-generic linux-headers-generic linux-image-generic

Außerdem können Sie Synaptic installieren und nicht benötigte 3.13-Linux-Images und -Header entfernen.

2
Pilot6