webentwicklung-frage-antwort-db.com.de

FEHLER: Fehler beim Installieren des Capybara-Webkits:

Irgendwelche Vorschläge zur Behebung?

gem install capybara-webkit -v '0.11.0'
Building native extensions.  This could take a while...
ERROR:  Error installing capybara-webkit:
        ERROR: Failed to build gem native extension.

        /home/durrantm/.rvm/rubies/Ruby-1.9.3-p194/bin/Ruby extconf.rb
sh: qmake: not found


Gem files will remain installed in /home/durrantm/.rvm/gems/Ruby-1.9.3-p194/gems/capybara-webkit-0.11.0 for inspection.
Results logged to /home/durrantm/.rvm/gems/Ruby-1.9.3-p194/gems/capybara-webkit-0.11.0/./gem_make.out
115
Michael Durrant

Wenn Sie in Ubuntu sind, tun

Sudo apt-get install qt4-dev-tools libqt4-dev libqt4-core libqt4-gui

Wenn Sie mit einem Mac arbeiten

brew install qt

und dann

gem install capybara-webkit -v '0.11.0'
218
juanpastas

Für Ubuntu 16.04

Sudo apt-get install qt-sdk

Gefolgt von

gem install capybara-webkit -v '1.11.0' oder ersetzen Sie sie durch die Version, die Sie installieren möchten.

21
ujjayini dutta

Vermutlich fehlen Ihnen die qt-Bibliotheken. Anweisungen zur Installation für Ihre Plattform finden Sie im capybara-webkit wiki .

15
Tanzeeb Khalili

brew install qt wird nur installiert (ab 4. August 2015) 4.8.6, das gibt Ihnen diese Nachricht.

WARNING: The next major version of capybara-webkit will require at least version 5.0 of Qt. You're using version 4.8.6.

Stattdessen, wenn Sie das tun

brew install qt5
brew link --force qt5

sie werden diesen Fehler nicht bekommen.

5
Waynn Lue

Auf El Capitan oder Yosemite müssen Sie möglicherweise brew install qt55 nach dem doc hier .

4
Yuxuan Chen