webentwicklung-frage-antwort-db.com.de

React Native "Das Expo-SDK erfordert die Ausführung der Expo. Dieser Code wird nicht auf der Expo ausgeführt."

Ich codiere mit React Native. Ich sehe das nicht, wenn ich zum ersten Mal eine reaktiöse App für das Ausführen von Prüfungen erstelle. Wenn ich meinen Code implementiert, sehen Sie das. Mein Zweck ist es, apk zu erzeugen.

 enter image description here


Gelöst

Ergebnis: Ich habe mein Problem mit npm install gelöst. Ich würde gerne viele Monate danach sagen.

5
Mert Ekinci

Laut offiziellem Tutorial: https://facebook.github.io/react-native/blog/2017/03/13/introducing-create-react-native-app.html

Wenn Sie expo in Ihrer Anwendung verwenden möchten, müssen Sie es auf folgende Weise erstellen

npm i -g create-react-native-appcreate-react-native-app my-projectcd my-projectnpm start

Dadurch wird der React Native-Packager gestartet und ein QR-Code gedruckt. Öffnen Sie ihn in der Expo-App, um Ihr JavaScript zu laden. 

wie ich sehe, enthält Ihr Code nicht benötigte Dateien wie build.gradle und index.js. Die Struktur, die create -rea-native-app erstellt, ist jedoch anders und einfacher zu verwenden

1
jerson

Hier ist meine Erfahrung, wenn jemand, der expo verwendet, diese Fehlermeldung sieht. 

Ich habe versehentlich expo manuell in meinem Projekt installiert, das Version 29.0.0 war.

Ich habe Version 28.0.0 von expo sdk verwendet, daher könnte es innen abgestürzt sein.

Was ich getan habe: 

  1. aktualisieren Sie die sdkVersion von app.json manuell auf 29.0.0.
  2. Ändern Sie die SDK-Version auf 29.0.0 für React-Native.
3
이준형

Wenn dieser Fehler nach dem Upgrade von Expo auftritt, starten Sie Ihren Simulator neu - das hat ihn für mich behoben.

2
yndolok

Hatte genau den gleichen Fehler - frische Maschine, frische npm, nur eine Version von expo installiert.

Es stellt sich heraus, dass es für expo erforderlich ist, die App als App zu erstellen, bevor sie ordnungsgemäß an die Expo-App gesendet werden kann (zumindest bei Android). Dies geschieht am einfachsten durch:

  • Hinzufügen eines "Android" -Abschnitts zu app.json mit dem Inhalt "package": "uk.co.yourcompany.yourpackagename" (wird von Android-Paketen benötigt. Dies kann ein kompletter Müll sein, sollte aber diesem Format folgen - ein rückwärts gerichteter Domainname).
  • expo build:Android ausführen und den Anweisungen folgen, um sich bei den Expo-Servern zu registrieren und die App zu erstellen 
  • dann expo start neu starten

Nicht sicher, ob dies irgendwo dokumentiert ist, kann es also eine neue Sache sein?

Eine andere Sache, die Sie versuchen können, ist, Ihren node_modules-Ordner wegzuschieben (oder ihn möglicherweise bis zu Ihnen zu löschen) und npm install erneut auszuführen.

2
user208769

Nach dem Aktualisieren von expo-cli Auf Version 3.0.6 Wurde derselbe Fehler angezeigt.

Beim Betrachten meines package.json Ist mir aufgefallen, dass die auf meinem Computer installierte expo-cli - Version nicht mit package.json Identisch ist. also habe ich es in "expo-cli": "^3.0.6" geändert und npm install || yarn ausgeführt, dann ist der Fehler verschwunden!

0
Blue Turtle