webentwicklung-frage-antwort-db.com.de

Probleme mit dem Babel Loader in der react-create-app

Das Problem

create-react-app initialisiert ein Repository, in dem babel-loader als ältere Version installiert ist als benötigt.

LOG:

There might be a problem with the project dependency tree.
It is likely not a bug in Create React App,
but something you need to fix locally.

The react-scripts package provided by Create React App requires a dependency:

  "babel-loader": "8.0.4"

Don't try to install it manually: your package manager does it automatically.
However, a different version of babel-loader was detected higher up in the tree:

  C:\Users\user\node_modules\babel-loader (version: 8.0.2)

Manually installing incompatible versions is known to cause hard-to-debug issues.

If prefer to ignore this check, add SKIP_PREFLIGHT_CHECK=true to an .env file in your project.
That will permanently disable this message but you might encounter other issues.
    To fix the dependency tree, try following the steps below in the exact order:

      1. Delete package-lock.json (not package.json!) and/or yarn.lock in your project folder.
      2. Delete node_modules in your project folder.
      3. Remove "babel-loader" from dependencies and/or devDependencies in the package.json
    file in your project folder.
      4. Run npm install or yarn, depending on the package manager you use.

    In most cases, this should be enough to fix
    the problem.
    If this has not helped, there are a few other things you can try:

      5. If you used npm, install yarn (http://yarnpkg.com/) and repeat the above steps with it instead.
         This may help because npm has known issues with package hoisting which may get resolved in future versions.

      6. Check if C:\Users\User\node_modules\babel-loader is outside your project directory.
         For example, you might have accidentally installed something in your home folder.

      7. Try running npm ls babel-loader in your project folder.
         This will tell you which other package
    (apart from the expected react-scripts) installed babel-loader.

    If nothing else helps, add SKIP_PREFLIGHT_CHECK=true to an .env file in your project.
    That would permanently disable this preflight check in case you want to proceed anyway.

    P.S. We know this message is long but please read the steps above :-) We hope you find them helpful!

    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! [email protected] start: `react-scripts start`
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the [email protected] start script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

    npm ERR! A complete log of this run can be found in:
    npm ERR!     C:\Users\User\AppData\Roaming\npm-cache\_logs\2018-12-13T18_22_47_802Z-debug.log

Nach dem, was passiert ist

$ npx create-react-app reg && cd reg && npm start

Was ich versucht habe

Ich habe versucht, den node_modules-Ordner und package-lock.json zu entfernen und dann npm install auszuführen.

Auch Garn installiert und lief yarn && yarn start.

Ich habe die App 3 Mal neu erstellt und das gleiche Ergebnis erhalten.

Info, die hilfreich sein kann

Knotenversion: 10.8.0  
NPM-Version: 6.5.0  
create -reade-app/reag-scripts: 2.1.1  
babel-loader: 8.0.4  
Globale Paketliste (npm ls --depth=0 -g):

+-- [email protected]
+-- [email protected]
+-- [email protected]
+-- [email protected]

package.json Datei:

{
  "name": "reg",
  "version": "0.1.0",
  "private": true,
  "dependencies": {
    "react": "^16.6.3",
    "react-dom": "^16.6.3",
    "react-scripts": "2.1.1"
  },
  "scripts": {
    "start": "react-scripts start",
    "build": "react-scripts build",
    "test": "react-scripts test",
    "eject": "react-scripts eject"
  },
  "eslintConfig": {
    "extends": "react-app"
  },
  "browserslist": [
    ">0.2%",
    "not dead",
    "not ie <= 11",
    "not op_mini all"
  ]
}
2
Paul Losev

Wenn Sie dasselbe Problem erhalten, aber nach einer Stunde eine Lösung erhalten, erhalten Sie die Lösung Wenn Sie npm start ausführen, haben Sie diese Art von Fehler erhalten, bei dem es sich um versionsbezogene Probleme für dieses Problem handelt. __ Gehen Sie in den Ordner node_modules:

Project->node_modules->react-scripts->package.json

Überprüfen Sie die package.json-Datei 

dort haben Sie: "babel-loader": "8.0.4" Entfernen Sie zunächst: babel-loader Ordner für Project->node_modules->babel-loader und führen Sie dann npm i [email protected] aus (abhängig von Ihrer Version können Sie diese wie folgt ändern: npm i [email protected]) Wenn Sie ein Webpack-Problem haben, befolgen Sie dasselbe Remvoe-Webpack von "Project->node_modules->webpack" und installieren Sie npm i [email protected] erneut.

4.19.1 * Version des Webpacks kann sich ändern.

5
Rawan-25

Eine andere Version von Babel-Loader wurde jedoch weiter oben im Baum gefunden:

Sie sollten das babel-loader-Paket löschen, das höher in der Baumstruktur gefunden wurde. Die Ausgabe besagt, dass es einen node_modules-Ordner mit dem Babel-Loader at gibt.

C:\Users\user\node_modules\babel-loader (Version: 8.0.2)

Sie können möglicherweise auch das Verzeichnis C:\Users\user\node_modules vollständig löschen, es sei denn, Sie haben aus irgendeinem Grund ein Projekt in/Users/{user}.

1
alteredtastes

Erstellen Sie eine .env-Datei in Ihrem Projektverzeichnis und fügen Sie SKIP_PREFLIGHT_CHECK=true in die Datei ein.

1
An'Apluss

das heißt, Sie installieren einen Schlepptau-Lader

rm yarn.lock
run npm uninstall [email protected]
0
leaez

Ich hatte genau das gleiche Problem. Für alle, die diesen Thread über Google finden und Anfänger wie ich sind. Hier ist genau das, was Sie in Ihr Terminal eingeben müssen (Mac-Benutzer).

Angenommen, Sie erhalten denselben Fehler wie Paul:

"Das von Create React App bereitgestellte React-Script-Paket erfordert eine Abhängigkeit:" babel-loader ":" 8.0.6 "

Folgendes habe ich in das Terminal eingegeben. Ich könnte mich irren, aber das hat bei mir funktioniert (ich bin auch ein Anfänger):

Schritt 1: Löschen Sie den Ordner node_modules sowie die Datei package_lock.json Dateien.

Schritt 2: Geben Sie in Ihr Terminal cd - ein (wir verlassen nur unseren Projektordner und wechseln in Ihren Home-Ordner)

Schritt 3: Geben Sie in Ihrem Terminal npm i "Abhängigkeitsname @ Nummer" ein. Für das obige Beispiel wäre dies also der Fall : npm i [email protected]

Schritt 4: Navigieren Sie nun in Ihrem Terminal zu Ihrem Projektordner und geben Sie Folgendes ein: npm install oder Garn einbauen

Schritt 5: Versuchen Sie, npm start auszuführen . Wenn alle Probleme behoben sind, sollte der Entwicklungsserver gestartet werden.

Hinweis: Ich musste den obigen Vorgang zweimal ausführen, sowohl für [email protected] als auch für Webpack .

0
Javed Khan

Auf dem Mac:  

Entfernen Sie das in Konflikt stehende Paket aus /Users/<yourusername>/node_modules.

0
Ibrahim Benzer

Ich hatte dieses Problem und fügte gerade hinzu

"babel-loader": "8.0.4",

zu meinem package.json in den Abhängigkeiten und es schien das Problem zu beheben

0
alittlebird

Sie können react-scripts in der 1.1.5-Datei vorübergehend auf package.json herabstufen, dann den node_modules-Ordner entfernen und im Fall der Verwendung von NPM die package-lock.json-Datei löschen, und falls Yarn die Datei yarn.lock..__ löscht Server mit dem Befehl yarn start oder npm run start.

0
Cosme Lorim

Ich habe das gleiche Problem. Ich habe es gelöst, indem ich den Ordner node_modules in User/und die Datei package-lock.json (falls vorhanden) entfernt habe. Dann sollte es perfekt funktionieren.

0
Phung Nguyen