webentwicklung-frage-antwort-db.com.de

dplyr error rlang 0.3.0. Fehler in filter_impl (.data, quo)

Ich habe ggplot2, tidyverse und rlang aktualisiert und jetzt funktioniert die Funktion filter nicht mehr.

Ich bekomme diese Fehlermeldung: 

Error in filter_impl(.data, quo) : 
  Evaluation error: `as_dictionary()` is defunct as of rlang 0.3.0.
Please use `as_data_pronoun()` instead.

Irgendeine Idee, was zu tun ist?

ausführung _
Plattform x86_64-Apple-darwin13.4.0
Bogen x86_64
os darwin13.4.0
System x86_64, Darwin13.4.0
Status
major 3
geringfügig 3.2
Jahr 2016
Monat 10
Tag 31
svn rev 71607
Sprache R
version.string R version 3.3.2 (2016-10-31) Spitzname Sincere Pumpkin Patch 

2
giacomo

Aktualisieren Sie nur Ihre R -Pakete, Sie müssen nicht auf eine neue R-Version aktualisieren.

Das Ausgeben des nächsten Befehls R version 3.2.3 (2015-12-10) löste das Problem für mich:

install.packages(c("BH", "bindr", "bindrcpp", "curl", "data.table", "dplyr", "evaluate", "highr", "Hotelling", "mime", "pkgconfig", "plogr", "quantmod", "R6", "Rcpp", "RgoogleMaps", "rjson", "rmarkdown", "stringi", "stringr", "tibble", "tidyxl", "TTR", "xts", "Zoo"))

(Die Paketliste wurde von RStudio erstellt (ich habe alle Pakete aktualisiert), aber ich denke, install.packages("dplyr") sollte ausreichen.

0
oszkar