webentwicklung-frage-antwort-db.com.de

Konnte keine Version finden, die die Anforderung numpy == 1.9.3 erfüllt

Ich versuche quandl zu installieren und brauche Pandas, also versuche ich pip zu installieren und bekomme:

Es konnte keine Version gefunden werden, die die Anforderung numpy == 1.9.3 erfüllt (von den Versionen: 1.10.4, 1.11.0, 1.11.1rc1, 1.11.1, 1.11.2rc1, 1.11.2, 1.11.3, 1.12.0b1) 1,12,0rc1, 1,12,0rc2, 1,12,0, 1,12,1rc1, 1,12,1, 1,13,0rc1, 1,13,0rc2, 1,13,0, 1,13,1, 1,13,3, 1,14,0rc1, 1,14,0, 1,14 .1, 1.14.2) Keine passende Verteilung für numpy gefunden == 1.9.3.

Ich verwende Python 3.4, win32

Ich bin sehr neu dabei, danke für Ihre Hilfe

3
Jony

Verwenden Sie einfach diesen Befehl:

pip install pandas==0.19.0.

Eine ältere Version, die mit diesem Fehler nicht weinen wird !!

2
Nikhil Sharma

Die aktuelle quandl ist großzügiger in ihren Anforderungen:

https://pypi.python.org/pypi/Quandl

Requires Distributions
pandas (>=0.14)
numpy (>=1.8)

Es ist githubsetup dasselbe: https://github.com/quandl/quandl-python/blob/master/setup.py

1
hpaulj

Ich habe die LASTEST VERSION in requirements.txt um pandas == 0.23.1 geändert - damals war die letzte Version von release - Sie können pandas

1
Alex Montoya

Installieren Sie einfach Python 3.5 oder höher.

1
Ashish S

Ich hatte das gleiche Problem bei der Installation von Pandas aus dem Quellcode 0.22.x. Ich folgte diesen Schritten und erhielt diesen Fehler:

$ python -m pip install -e .
Obtaining file:///Users/mmorin/Software/pandas
  Could not find a version that satisfies the requirement numpy==1.9.3 (from versions: 1.11.3, 1.12.0rc2, 1.12.0, 1.12.1rc1, 1.12.1, 1.13.0rc1, 1.13.0rc2, 1.13.0, 1.13.1, 1.13.3, 1.14.0rc1, 1.14.0, 1.14.1, 1.14.2, 1.14.3)
No matching distribution found for numpy==1.9.3

Ich habe dieses Problem auf GitHub gefunden, wo @djhoese die Verwendung der Version 9.0.3 von pip anstelle der Version 10.0.1 vorschlug. Ich habe diese Zeile in ci/environment-dev.yaml hinzugefügt:

 - pip==9.0.3

Ich habe der Umgebung zur Verdeutlichung einen neuen Namen gegeben, daher ist die gesamte Datei:

name: pandas-dev-pip9
channels:
  - defaults
  - conda-forge
dependencies:
  - Cython
  - NumPy
  - moto
  - pytest
  - python-dateutil
  - python=3
  - pytz
  - setuptools
  - sphinx
  - pip==9.0.3
0
mmorin

Ich hatte ein ähnliches Problem und mir wurde gesagt, dass Pandas Python 3.4 nicht mehr unterstützt []. Sie müssen daher eine ältere Version von Pandas (und möglicherweise eine ältere Version von Numpy) installieren, um mit Python 3.4 zu arbeiten. 

Nicht sehr befriedigend, ich weiß es, aber da ist es.

0
nickdmax