webentwicklung-frage-antwort-db.com.de

"InvalidRequirement: Ungültige Anforderung, Fehler analysieren" Fehler nach Aktualisierung eines python - Pakets

Nach dem Aktualisieren eines Pakets (in meinem Fall IPython) mit pip install -U ipython Das Ausführen eines Python - Skripts, das Einstiegspunkte verwendet, schlägt mit folgendem Fehler fehl:

Traceback (most recent call last):
  File "/home/adrian/dev/indico/env/bin/indico", line 5, in <module>
    from pkg_resources import load_entry_point
  ...
  File "/home/adrian/dev/indico/env/lib/python2.7/site-packages/pkg_resources/_vendor/packaging/requirements.py", line 94, in __init__
    requirement_string[e.loc:e.loc + 8], requirement_string))
pkg_resources._vendor.packaging.requirements.InvalidRequirement: Invalid requirement, parse error at "'< 2.0'"

Ansonsten hat sich nichts geändert, ich habe keine anderen Bibliotheken aktualisiert.

21
ThiefMaster

Dies wird durch ein Problem in setuptools==20.2.1 Verursacht, das von IPython (setuptools>..) Abgerufen wird. Daher wurde es durch pip install -U Aktualisiert.

Bis eine feste Version veröffentlicht oder die fehlerhafte Version von PyPI abgerufen wird, gibt es eine einfache Problemumgehung (beachten Sie jedoch, dass sie erneut unterbrochen wird, wenn setuptools aktualisiert wird):

  • pip install -U pip
  • pip uninstall setuptools
  • pip install 'setuptools<20.2'

Das pip Update wird benötigt, da ältere Versionen von pip ohne die Installation von setuptools nicht funktionieren


Weitere Informationen finden Sie in den folgenden IRC Protokollen und im BitBucket-Problem:

23
ThiefMaster

Versuchen Sie, Ihren Pip auf 8.1.1 Herunterzustufen:

pip install pip==8.1.1

Das hat es für mich gelöst.

11
juanpaolo