webentwicklung-frage-antwort-db.com.de

Mein benutzerdefiniertes Plugin hat "eine neue Version verfügbar", die auf nicht verwandte Plugins verweist

In meinem benutzerdefinierten Plugin ist "eine neue Version verfügbar", und der Link "Details anzeigen" verweist auf ein völlig unabhängiges Plugin.

Die Plugin-Dateien beginnen mit:

<?php
/*
Plugin Name: Simple Contact Form 
Plugin URI: http://www.wilcoverhoeven.com
Description: Simple contact form
Version: 1
Author: Wilco Verhoeven
Author URI: http://www.wilcoverhoeven.com
*/

Wie kann ich das verhindern?

7

Ich glaube, Sie haben dort einen Namenskonflikt - vorausgesetzt, Ihr Plugin verlinkt auf dieses Simple Contact Form - und versuchen Sie, den Namen in "Wilcos Simple Contact Form" zu ändern.

Sie müssen den Plugin-Ordnernamen und den Namen der Haupt-Plugin-Datei ebenfalls aktualisieren.

Update

Wie Aniket feststellt, müssen Sie möglicherweise eine Update-Überprüfung auf Ihrer Site erzwingen, um die Benachrichtigung zu entfernen. Sie können dies tun, indem Sie zu http://yourwebsite.com/wp-admin/update-core.php?force-c‌​heck=1 gehen.

13
FaCE

Wie ich sehen kann, haben Sie Ihr benutzerdefiniertes Formular als "Einfaches Kontaktformular" bezeichnet, was mit diesem Plug-in-Namen in Konflikt steht Einfaches Kontaktformular . Versuchen Sie, den Namen zu ändern.
Edit1: Sie können auch die Version ändern, wenn Sie den Namen des Plugins nicht ändern möchten. Zum Beispiel: wenn Sie dazu aufgefordert werden

Es gibt eine neue Version des einfachen Kontaktformulars. Version 14.13 Details anzeigen oder Jetzt aktualisieren .

benenne dann einfach die Version deines Plugins in 14.13 oder höher um

6
Aniket Sahrawat