webentwicklung-frage-antwort-db.com.de

Ausgewähltes Bild wird im Admin nicht angezeigt

Derzeit mache ich ein neues Thema und hatte die Idee, ein Bild auf der Admin-Seite von WordPress hinzuzufügen. Leider funktioniert es nicht. Das habe ich ausprobiert

Ich habe diesen Code in functions.php hinzugefügt

add_theme_support( 'post-thumbnails');

ich habe auch versucht, es zu ändern

add_theme_support( 'post-thumbnails', array( 'post' ) ); // Add it for posts
add_theme_support( 'post-thumbnails', array( 'page' ) ); // Add it for pages

nach dem Aktualisieren und Anmelden in meinem Admin-Bereich und dem Versuch, einen neuen Beitrag oder eine neue Seite zu erstellen, wird das vorgestellte Bild nicht angezeigt und angezeigt

nach meiner Setup-Funktion, die ja_theme_setup ist, ist dies mein Code

add_action('after-setup_theme','ja_theme_setup' );

und auch ich habe versucht, BILDSCHIRM-OPTIONEN zu betrachten, aber ich habe kein verfügbares Ankreuzfeld, das mit gekennzeichnetem Bild zusammenhängt. Bitte helfen Sie mir Kerle

ANMERKUNG: Die Debug-Optionen für meine wp-config.php-Datei sind auf true gesetzt

define('WP_DEBUG', true); 

und doch habe ich keine fehler

1

Sie haben den Aktions-Hook-Namen falsch geschrieben.

Diese:

add_action( 'after-setup_theme', 'ja_theme_setup' );

Sollte sein:

add_action( 'after_setup_theme', 'ja_theme_setup' );

Der vollständige Code:

add_action( 'after_setup_theme', 'ja_theme_setup' );
function ja_theme_setup() {
    add_theme_support( 'post-thumbnails');
}
6
cybmeta