webentwicklung-frage-antwort-db.com.de

PHP7 CLI versucht zweimal Xdebug zu laden - "Xdebug kann nicht geladen werden - es wurde bereits geladen"

Nach dem Upgrade von Ubuntu von 14.04 auf 16.04 begann PHP CLI, sich über xdebug zu beschweren:

$ php -v
Cannot load Xdebug - it was already loaded
PHP 7.0.13-0ubuntu0.16.04.1 (cli) ( NTS )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.13-0ubuntu0.16.04.1, Copyright (c) 1999-2016, by Zend Technologies
    with Xdebug v2.4.0, Copyright (c) 2002-2016, by Derick Rethans

Es gibt nur eine .ini-Datei:

$ ls -la /etc/php/7.0/cli/conf.d/ | grep xdebug
lrwxrwxrwx 1 root root   38 Jan 19 11:41 20-xdebug.ini -> /etc/php/7.0/mods-available/xdebug.ini

Und es wird nur einmal in dieser Ausgabe von php -i referenziert:

$ php -i | grep -i configuration
Cannot load Xdebug - it was already loaded
Configuration File (php.ini) Path => /etc/php/7.0/cli
Loaded Configuration File => /etc/php/7.0/cli/php.ini
Configuration

Im gesamten Verzeichnis gibt es nur einen Verweis auf xdebug (es wird also nicht zweimal eingefügt):

/etc/php/7.0$ grep -r xdebug *
mods-available/xdebug.ini:zend_extension=xdebug.so
mods-available/xdebug.ini:[xdebug]
mods-available/xdebug.ini:xdebug.remote_enable=1
mods-available/xdebug.ini:xdebug.remote_autostart=1
mods-available/xdebug.ini:xdebug.remote_port=9000
mods-available/xdebug.ini:xdebug.idekey=PHPSTORM

Wenn ich $ phpdismod xdebug mache, erhalte ich die folgende Ausgabe, die darauf hinweist, dass Xdebug noch geladen ist:

$ php -v
PHP 7.0.13-0ubuntu0.16.04.1 (cli) ( NTS )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.13-0ubuntu0.16.04.1, Copyright (c) 1999-2016, by Zend Technologies
    with Xdebug v2.4.0, Copyright (c) 2002-2016, by Derick Rethans

Danach ist es nicht mehr in der Apache-Konfiguration vorhanden, wie in phpinfo() gezeigt. 

Wie kann ich das beheben?


Edit: Zusätzliche Ausgabe wie gewünscht:

$ php --ini
Cannot load Xdebug - it was already loaded
Configuration File (php.ini) Path: /etc/php/7.0/cli
Loaded Configuration File:         /etc/php/7.0/cli/php.ini
Scan for additional .ini files in: /etc/php/7.0/cli/conf.d
Additional .ini files parsed:      /etc/php/7.0/cli/conf.d/10-mysqlnd.ini,
/etc/php/7.0/cli/conf.d/10-opcache.ini,
/etc/php/7.0/cli/conf.d/10-pdo.ini,
/etc/php/7.0/cli/conf.d/15-xml.ini,
/etc/php/7.0/cli/conf.d/20-bcmath.ini,
/etc/php/7.0/cli/conf.d/20-calendar.ini,
/etc/php/7.0/cli/conf.d/20-ctype.ini,
/etc/php/7.0/cli/conf.d/20-curl.ini,
/etc/php/7.0/cli/conf.d/20-dom.ini,
/etc/php/7.0/cli/conf.d/20-exif.ini,
/etc/php/7.0/cli/conf.d/20-fileinfo.ini,
/etc/php/7.0/cli/conf.d/20-ftp.ini,
/etc/php/7.0/cli/conf.d/20-Gd.ini,
/etc/php/7.0/cli/conf.d/20-gettext.ini,
/etc/php/7.0/cli/conf.d/20-iconv.ini,
/etc/php/7.0/cli/conf.d/20-json.ini,
/etc/php/7.0/cli/conf.d/20-mbstring.ini,
/etc/php/7.0/cli/conf.d/20-mcrypt.ini,
/etc/php/7.0/cli/conf.d/20-mysqli.ini,
/etc/php/7.0/cli/conf.d/20-pdo_mysql.ini,
/etc/php/7.0/cli/conf.d/20-pdo_sqlite.ini,
/etc/php/7.0/cli/conf.d/20-phar.ini,
/etc/php/7.0/cli/conf.d/20-posix.ini,
/etc/php/7.0/cli/conf.d/20-readline.ini,
/etc/php/7.0/cli/conf.d/20-shmop.ini,
/etc/php/7.0/cli/conf.d/20-simplexml.ini,
/etc/php/7.0/cli/conf.d/20-sockets.ini,
/etc/php/7.0/cli/conf.d/20-sqlite3.ini,
/etc/php/7.0/cli/conf.d/20-sysvmsg.ini,
/etc/php/7.0/cli/conf.d/20-sysvsem.ini,
/etc/php/7.0/cli/conf.d/20-sysvshm.ini,
/etc/php/7.0/cli/conf.d/20-tokenizer.ini,
/etc/php/7.0/cli/conf.d/20-wddx.ini,
/etc/php/7.0/cli/conf.d/20-xdebug.ini,
/etc/php/7.0/cli/conf.d/20-xmlreader.ini,
/etc/php/7.0/cli/conf.d/20-xmlwriter.ini,
/etc/php/7.0/cli/conf.d/20-xsl.ini

$ cat /etc/php/7.0/mods-available/xdebug.ini 
zend_extension=xdebug.so
[xdebug]
xdebug.remote_enable=1
xdebug.remote_autostart=1
xdebug.remote_port=9000
xdebug.idekey=PHPSTORM

Da dies immer noch ein Problem ist, habe ich einige weitere Details gefunden:

Pfade:

$ ls -la /usr/bin/php
lrwxrwxrwx 1 root root 21 Apr 18  2017 /usr/bin/php -> /etc/alternatives/php
$ ls -la /etc/alternatives/php
lrwxrwxrwx 1 root root 15 Feb 12 15:43 /etc/alternatives/php -> /usr/bin/php7.1

php:

$ php -v
Cannot load Xdebug - it was already loaded
PHP 7.1.15-1+ubuntu16.04.1+deb.sury.org+2 (cli) (built: Mar  6 2018 11:10:13) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.1.15-1+ubuntu16.04.1+deb.sury.org+2, Copyright (c) 1999-2018, by Zend Technologies
    with Xdebug v2.6.0, Copyright (c) 2002-2018, by Derick Rethans

php 7.1:

$ php7.1 -v
PHP 7.1.15-1+ubuntu16.04.1+deb.sury.org+2 (cli) (built: Mar  6 2018 11:10:13) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.1.15-1+ubuntu16.04.1+deb.sury.org+2, Copyright (c) 1999-2018, by Zend Technologies
    with Xdebug v2.6.0, Copyright (c) 2002-2018, by Derick Rethans

Das interessante daran ist, dass die PHP-Binärdatei identisch mit PHP7.1 ist, aber wenn sie als spezifisch aufgerufen wird, wird die bereits geladene Nachricht nicht angezeigt.


Bearbeiten, 20181006:

Ich habe immer noch diese Ausgabe. Das Bild unten ist ein Unterschied der Ausgabe der beiden php --ini-Aufrufe. Wie Sie sehen, sind die geladenen Ini-Dateien gleich.

 enter image description here

Sie sind auch die gleichen symbolischen Binärdateien:

[email protected]:~$ which php
/usr/bin/php
[email protected]:~$ ls -la /usr/bin/php
lrwxrwxrwx 1 root root 21 May 15 16:07 /usr/bin/php -> /etc/alternatives/php
[email protected]:~$ ls -la /etc/alternatives/php
lrwxrwxrwx 1 root root 15 May 30 10:13 /etc/alternatives/php -> /usr/bin/php7.1
[email protected]:~$ which php7.1 
/usr/bin/php7.1
16
bcmcfc

Ich habe dies behoben, indem zend_extension=xdebug.so entfernt wurde, da ich es bereits in meinem Docker-Container mit docker-php-ext-enable xdebug aktiviert habe. Möglicherweise ist es auch für Sie aktiviert.

9
Magarusu

Debian und Derivat:

Ich habe es korrigiert, indem ich meine php.ini lokalisierte und den zend_extension=xdebug.so in den alten verwandelte (also denke ich, dass das gleiche die Zeile kommentieren würde) zend_extension_ts=zdebug.so.

Dann mit: php -i | grep xdebug sollte es nur ein conf.d mit dem zend_extension=xdebug.so geben. Wenn mehrere vorhanden waren, löschen Sie den Rest der Einträge.

2
vivoconunxino

In Arch Linux generiert das Paket xdebug die folgende Konfiguration:

/etc/php/conf.d/xdebug.ini
----------
zend_extension=xdebug.so
xdebug.remote_enable=on
xdebug.remote_Host=127.0.0.1
xdebug.remote_port=9000
xdebug.remote_handler=dbgp
#xdebug.max_nesting_level=300

Dadurch wird zweimal derselbe zend_extension=xdebug.so in /etc/php/php.ini geladen.

1
dnloop

Für Benutzer, die das gleiche Problem haben.

In meinem Szenario gab es ein Problem mitphp cliSo dass ich jedes Mal, wenn ich versuchte, in der Konsole zu PHP zu gelangen, eine Nachricht bekam:Cannot load the ionCube PHP Loader - extension already loaded

Ich denke, es wird anderen Erweiterungen ähnlich sein.

Was ich schließlich getan habe, ist:

cd /opt/cpanel/ea-php56/root/etc
grep -r "cube" .
# now I saw two files loading the .so files:
# ./php.d/01-ioncube.ini:zend_extension="/opt/cpanel/ea-php56/root/usr/lib64/php/modules/ioncube_loader_lin_5.6.so"
# ./php.d/pecl.ini:zend_extension="/opt/cpanel/ea-php56/root/usr/lib64/php/modules/ioncube_loader_lin_5.6.so"
mv php.d/pecl.ini .

Das war's.

1
JonnieJS

Ich hatte das gleiche Problem und löste es, indem ich eine zusätzliche Codezeile zend_extension="xdebug.so" in der php.ini-Datei im php-Ordner entfernte, die die php -version zeigt, normalerweise in /usr/local/etc/php/ für Mac-Benutzer.

1
farnoosh