webentwicklung-frage-antwort-db.com.de

Howto: Installieren Sie Imagick (für PHP) auf Ubuntu 11.10

Ich versuche, ImagicK als eine Yii-Erweiterung zu installieren, die ich für mein Projekt verwenden möchte. 

Ich habe mich umgesehen und ein paar andere Vorschläge befolgt, aber nichts, was bisher funktioniert hat. Letztendlich wirft die Framework-Erweiterung immer noch einen Fehler ab (muss ImagicK installieren). 

Ich habe Dinge ausprobiert wie:

Sudo apt-get update
Sudo apt-get install imagick-php5 .. etc

sowie die PECL-Installation, die mir den folgenden Fehler auslöst:

Checking ImageMagick MagickWand API configuration program... configure: error: 
not found. Please provide a path to MagickWand-config or Wand-config program. 

Jede Hilfe, wie Sie ImagicK auf Ubuntu 11.10 installieren und in PHP integrieren können, wäre großartig.

Danke im Voraus!

61
csjohn

Das Paket hat in Ubuntu einen anderen Namen.

 Sudo apt-get install php5-imagick

Der Fehler beim Erstellen über PECL bedeutet, dass Sie wahrscheinlich libmagickwand-dev, libmagickcore3, libmagickwand3 installieren müssen (es gibt Alternativen: graphicsmagick-imagemagick-compat, siehe Synaptic).

113
mario

Installationsschritte für Ubuntu 12.04:

  1. installiere imagemagick

    Sudo apt-get install imagemagick

  2. Installieren Sie die imagemagick PECL-Erweiterung

    Sudo apt-get install php5-imagick

  3. Webserver neu starten

60
Sumoanand

Installationsschritte für Ubuntu <16.04:

Sudo apt-get install imagemagick php5-imagick; Sudo service Apache2 restart

Installationsschritte für Ubuntu> 16.04:

Sudo apt-get install imagemagick php-imagick; Sudo service Apache2 restart
9
bdombro

Für Ubuntu 16 oder höher:

Sudo apt-get install php-imagick

(Beachten Sie die Verwendung von php- anstelle von php5-)

1
Karl Wolf

Mit Ubuntu 16.04 (Xenial) mit PHP 5.6 nicht 7. PHP wurde 7 deaktiviert.

  1. Sudo apt-get Update
  2. Sudo apt-get installiert imagemagick php5.6-imagick
0
AZinkey

Installieren Sie Imagemagick Sudo apt-get install imagemagick Installiere die imagemagick PECL-Erweiterung Sudo apt-get install php5-imagick Webserver neu starten

0
Ravi Sharma