webentwicklung-frage-antwort-db.com.de

npm - veraltete Paketdaten verwenden

Immer wenn ich eine npm-Installation durchführe, bekomme ich eine Menge Nachrichten über veraltete Paketdaten. Was bedeutet das und muss ich mir Sorgen machen?

Hier ist ein kleines Beispiel für die Warnmeldungen, die ich bei einer npm-Installation bekomme. In diesem Beispiel habe ich gerade "npm install @ angle/animations @ latest --save" hinzugefügt:

WARN registry Unexpected warning for https://registry.npmjs.org/: Miscellaneous Warning EINTEGRITY: sha512-Mp+FXEI+FrwY/XYV45b2YD3E8i3HwnEAoFcM0qlZzq/RZ9RwWitt2Y/c7cqRAz70U7hfekqx6qNYthuKFO6K0
g== integrity checksum failed when using sha512: wanted sha512-Mp+FXEI+FrwY/XYV45b2YD3E8i3HwnEAoFcM0qlZzq/RZ9RwWitt2Y/c7cqRAz70U7hfekqx6qNYthuKFO6K0g== but got sha1-2+xJQ20q4V9TYRTnbRRlbNvA9E0
=. (8538 bytes)
WARN registry Using stale package data from https://registry.npmjs.org/ due to a request error during revalidation.
WARN registry Unexpected warning for https://registry.npmjs.org/: Miscellaneous Warning EINTEGRITY: sha512-NnSOmMEYtVR2JVMIGTzynRkkaxtiq1xnFBcdQD/DnNCYPoEPsVJhM98BDyaoNOQIi7p4okdi3E27eN7GQbsUu
g== integrity checksum failed when using sha512: wanted sha512-NnSOmMEYtVR2JVMIGTzynRkkaxtiq1xnFBcdQD/DnNCYPoEPsVJhM98BDyaoNOQIi7p4okdi3E27eN7GQbsUug== but got sha1-wVm41b4PnlpvNG2rlPFs4CIWG4g
=. (3618 bytes)
WARN registry Using stale package data from https://registry.npmjs.org/ due to a request error during revalidation.
WARN registry Unexpected warning for https://registry.npmjs.org/: Miscellaneous Warning EINTEGRITY: sha512-Mp+FXEI+FrwY/XYV45b2YD3E8i3HwnEAoFcM0qlZzq/RZ9RwWitt2Y/c7cqRAz70U7hfekqx6qNYthuKFO6K0
g== integrity checksum failed when using sha512: wanted sha512-Mp+FXEI+FrwY/XYV45b2YD3E8i3HwnEAoFcM0qlZzq/RZ9RwWitt2Y/c7cqRAz70U7hfekqx6qNYthuKFO6K0g== but got sha1-2+xJQ20q4V9TYRTnbRRlbNvA9E0
=. (8538 bytes)
WARN registry Using stale package data from https://registry.npmjs.org/ due to a request error during revalidation.
WARN registry Unexpected warning for https://registry.npmjs.org/: Miscellaneous Warning EINTEGRITY: sha512-NnSOmMEYtVR2JVMIGTzynRkkaxtiq1xnFBcdQD/DnNCYPoEPsVJhM98BDyaoNOQIi7p4okdi3E27eN7GQbsUu
g== integrity checksum failed when using sha512: wanted sha512-NnSOmMEYtVR2JVMIGTzynRkkaxtiq1xnFBcdQD/DnNCYPoEPsVJhM98BDyaoNOQIi7p4okdi3E27eN7GQbsUug== but got sha1-wVm41b4PnlpvNG2rlPFs4CIWG4g
=. (3618 bytes)
WARN registry Using stale package data from https://registry.npmjs.org/ due to a request error during revalidation.

Hier ist die aktuelle package.json-Datei, die ich für mein Projekt habe:

{
  "name": "myproject",
  "version": "0.0.1",
  "license": "me",
  "scripts": {
    "ng": "ng",
    "start": "ng serve",
    "build": "ng build --extract-css true",
    "build-prod": "ng build -prod",
    "test": "ng test",
    "lint": "ng lint",
    "e2e": "ng e2e",
    "update:packages": "node wipe-dependencies.js && rm -rf node_modules && npm update --save-dev && npm update --save",
    "prestyleguide": "ng build --extract-css true",
    "styleguide": "rimraf dist/styleguide/ && kss --config kss/kss-config.json --custom hidemarkup --custom hideexample --custom hidedefault --custom fakeexample --placeholder .modifier-class",
    "//": "Build just the styleguide without building the entire app (requires that the app has already been built to the dist/ folder)",
    "build-styleguide": "rimraf dist/styleguide/ && kss --config kss/kss-config.json --custom hidemarkup --custom hideexample --custom hidedefault --custom fakeexample --placeholder .modifier-class"
  },
  "private": true,
  "dependencies": {
    "@angular/animations": "^4.3.3",
    "@angular/common": "^4.3.2",
    "@angular/compiler": "^4.3.2",
    "@angular/core": "^4.3.2",
    "@angular/forms": "^4.3.2",
    "@angular/http": "^4.3.2",
    "@angular/platform-browser": "^4.3.2",
    "@angular/platform-browser-dynamic": "^4.3.2",
    "@angular/router": "^4.3.2",
    "@ng-bootstrap/ng-bootstrap": "^1.0.0-alpha.28",
    "bootstrap": "^4.0.0-alpha.6",
    "classlist.js": "^1.1.20150312",
    "core-js": "^2.4.1",
    "font-awesome": "^4.7.0",
    "ngx-mydatepicker": "^2.0.12",
    "rxjs": "^5.4.2",
    "web-animations-js": "^2.3.1",
    "zone.js": "^0.8.16"
  },
  "devDependencies": {
    "@angular/cli": "^1.2.3",
    "@angular/compiler-cli": "^4.3.2",
    "@types/jasmine": "^2.5.53",
    "@types/node": "^8.0.15",
    "codelyzer": "^3.1.2",
    "fs-extra": "^4.0.0",
    "jasmine-core": "^2.6.4",
    "jasmine-spec-reporter": "^4.1.1",
    "karma": "^1.7.0",
    "karma-chrome-launcher": "^2.2.0",
    "karma-cli": "^1.0.1",
    "karma-coverage-istanbul-reporter": "^1.3.0",
    "karma-jasmine": "^1.1.0",
    "karma-jasmine-html-reporter": "^0.2.2",
    "kss": "^3.0.0-beta.18",
    "protractor": "^5.1.2",
    "random-ext": "^2.5.1",
    "ts-node": "^3.2.1",
    "tslint": "^5.5.0",
    "typedoc": "^0.7.1",
    "TypeScript": "^2.4.2"
  }
}
47
BlueCaret

probieren Sie das aus und installieren Sie anschließend alle Abhängigkeiten Ihres Projekts erneut

rm ./package-lock.json
rm -r ./node_modules
npm cache clear --force

Es gibt einen vollständigen Thread auf Github darüber, seit Juni denke ich

86
sheplu

Seit npm 5 haben Sie nicht die volle Kontrolle über den Cache, also können Sie es für npm 5 versuchen

npm cache verify

Das hat mir geholfen. Ich denke nicht, dass Sie package-lock und node_modules als ersten Schritt entfernen müssen. 

15
s-f

Sollte die Cache-Löschmethode nicht funktionieren ...

Ich habe festgestellt, dass dieses Problem während eines OS X-Updates aufgetreten ist. Die Installation des Updates für die Befehlszeilentools und der Neustart von iTerm haben dieses Problem behoben.

 unexpected causes

Sicher nicht, dass dies eine "richtige" Lösung ist, war aber definitiv ein Problem mit meinem Setup (wtf apple?). Wurde in dem Fall veröffentlicht, dass sich jemand anderes in derselben Position befindet ????????

2
Ralph Cowling

Diese Fehlermeldung wurde bei der Verwendung einer benutzerdefinierten Registrierung (nicht npmjs.org) angezeigt. Das Problem war, dass meine Registry untergegangen war.

0
AJ Richardson

Sie können versuchen, den npm-Cache mit Npm cache clear --force zu löschen

Installieren Sie anschließend die Knotenmodule erneut

Ich hoffe das hilft.

0
Treasure