webentwicklung-frage-antwort-db.com.de

Versuchen Sie, `node-sass` auf Knoten 0.12 neu zu installieren?

Ich möchte das Google Web Starter Kit verwenden. Ich habe node.js v0.12.0, node-sass & gulp installiert.

Und dann lief:

$ Sudo npm install

Wenn ich gulp serve eintippte, bekam ich diesen Fehler:

Using gulpfile ~/web-starter-kit/gulpfile.js Starting 'styles'... 'styles' errored after 93 ms 
Error: `libsass` bindings not found. Try reinstalling `node-sass`? at getBinding

Ich habe node and gulp neu installiert, aber das hilft nicht.

Was soll ich als nächstes tun?

258
Takagi Akihiro

Wenn Ihre Knotenversion 4 ist und Sie gulp-sass verwenden, versuchen Sie es

npm uninstall --save-dev gulp-sass

npm install --save-dev [email protected]
385
Roma Rush

Ich fand diesen nützlichen Befehl:

npm rebuild node-sass

Aus dem rebuildDokumentation :

Dies ist nützlich, wenn Sie eine neue Version von node (oder Switch Node-Versionen) installieren und alle Ihre C++ - Addons mit der neuen node.js-Binärdatei neu kompilieren müssen.

http://laravel.io/forum/10-29-2014-laravel-elixir-sass-error

340

Ich bin auf diesen Fehler mit dem Knoten 0.12.0 gestoßen und er wurde behoben, indem das vorhandene /node_modules -Verzeichnis gelöscht und npm update ausgeführt wurde.

233
createbang

npm rebuild node-sass gab mir Fehler (Ubuntu) und npm install gulp-sass hat den Fehler nicht behoben.

Habe auf GitHub eine Lösung gesehen, die für mich funktioniert hat:

npm uninstall --save-dev gulp-sass

npm install --save-dev gulp-sass

84
Pupper

Ich hatte das gleiche Problem:

  • installieren von Node-Sass
  • am Ende der Installation wird mitgeteilt, dass die Installation erfolgreich abgeschlossen wurde
  • dann werden sie gebeten, node-sass neu zu installieren.

Die Lösung besteht darin, node-sass Version 2 zu installieren , das die aktuellen Versionen von node unterstützt. Siehe https://github.com/sass/node-sass/issues/490#issuecomment-70388754

Lauf:

npm install [email protected]

Dann erneut testen:

$ npm ls node-sass
[email protected] /var/www/myapp
└── [email protected]

$ gulp sass
[09:48:42] Using gulpfile /var/www/myapp/gulpfile.js
[09:48:42] Starting 'sass'...
[09:48:42] Finished 'sass' after 15 ms
22
mikemaccana

Wenn Sie Gulp verwenden, versuchen Sie Folgendes:

npm install gulp-sass

Ich hatte das gleiche Problem und das Paket gulp-sass war das Problem.

19
georger

ich hatte heute das gleiche Problem bei der Arbeit.

npm rebuild node-sass

erledigte den Job für mich

11
bin2hex

Ein Downgrade von Node auf 0.10.36 sollte gemäß diesem Thread auf der Node-Sass-Github-Seite erfolgen: https://github.com/sass/node-sass/issues/490#issuecomment-) 70388754

Wenn Sie NVM haben, können Sie einfach:

nvm install 0.10

Andernfalls finden Sie NVM und Anweisungen hier: https://www.npmjs.com/package/nvm

9
natepers

Diese Antwort ist ein bisschen orthogonal zum OP, aber -

libsass-Bindungen werden mit dem Node-sass-Wrapper unter Node v4.0.0 nicht ordnungsgemäß installiert. Ich habe die gleiche Fehlermeldung wie in der Frage (Error: 'libsass' bindings not found. Try reinstalling 'node-sass')) erhalten, aber am Ende habe ich Node v4.0.0 deinstalliert und v0.12.7 mit nvm über dieses Skript installiert:

https://Gist.github.com/brock/5b1b70590e1171c4ab54

und jetzt verhalten sich libsass und node-sass richtig.

3
ericsoco

Ich habe das gleiche Problem, wenn gulp-sass Version 1.3.0 ist, und behebe es nach dem Upgrade auf 2.1.0.

2
Kos

möglicherweise möchten Sie auch npm remove gulp-sass und gulp-sass erneut installieren, wenn Sie die Knotenversion gewechselt haben.

2
4m1r

Ich habe den gesamten Ordner /node_modules entfernt und dann npm install ausgeführt, und es hat funktioniert.

Ich habe Knoten v5.5.0, npm 3.3.12

1
Florin Dobre

Wenn Sie hierher gekommen sind, weil Sie nodejs systemweit aufgerüstet haben, und Ihre emberjs ^ 1.13-App plötzlich mit dieser Meldung nicht mehr funktioniert, stellen Sie sicher, dass Sie keine veraltete Version von ember-cli-sass verwenden. Sie müssen rm -rf node_modules bower_components dist tmp in der Ember App, dann aktualisieren Sie Ihre package.json mit der entsprechenden ember-cli-sass Version und schließlich npm install --save-dev. Dies hat es für mich behoben, ohne dass andere Abhängigkeiten neu erstellt oder geändert werden mussten.

1
handwovensole

Ich hatte das gleiche Problem wie @Kos, nur aus irgendeinem Grund musste ich das gulp-sass-Paket aus der alten package.json -Datei ändern, die ich hatte. Es hat dann die Abhängigkeiten aktuell installiert und jetzt funktioniert es endlich!

0
Shay

Für mich wurde dieses Problem in meinem Build-System (Travis CI) dadurch verursacht, dass ich in meiner .travis.yml -Datei etwas Dummes getan habe. Tatsächlich habe ich npm installvornvm use 0.12 aufgerufen, und dies hat dazu geführt, dass node-sass für 0.10 anstelle von 0.12 erstellt wurde. . Meine Lösung bestand einfach darin, nvm use aus dem Abschnitt .travis.yml der Datei before_script vor den Befehl npm install zu verschieben, der sich im Abschnitt before_install befand.

In Ihrem Fall wird wahrscheinlich für jeden Prozess, mit dem Sie beginnen, gulp eine andere Version von node verwendet (als erwartet).

0
Alan H.

Sie müssen die richtige Version verwenden. Versuchen:

nvm use 0.12
0
alexfigtree

Mein Problem war, dass ich auf einer Maschine mit node version 0.12.2 war, aber diese hatte eine alte 1.x.x -Version von npm. Stellen Sie sicher, dass Sie Ihre Version von npm aktualisieren: Sudo npm install -g npm Entfernen Sie anschließend alle vorhandenen node-sass und installieren Sie sie über npm neu.

0
k00k