webentwicklung-frage-antwort-db.com.de

npm-Installation: Fehler beim Postinstall-Skript [email protected]

Ich habe eine angular Anwendung: https://github.com/XBITSwitzerland/ngx-admin/tree/ng2-admin

Und jetzt versuche ich zu tun: npm install

Aber ich bekomme diesen Fehler (Die konkurrierende Ausgabe des Befehls war viel zu lang, deshalb teile ich hier nur den letzten Teil):

gyp ERR! build error
gyp ERR! stack Error: `C:\Program Files (x86)\MSBuild\14.0\bin\msbuild.exe` failed with exit code: 1
gyp ERR! stack     at ChildProcess.onExit (C:\github\ngx-admin\node_modules\node-gyp\lib\build.js:258:23)
gyp ERR! stack     at ChildProcess.emit (events.js:182:13)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:240:12)
gyp ERR! System Windows_NT 10.0.17134
gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\github\\ngx-admin\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild" "--verbose" "--libsass_ext=" "--libsass_cflags=" "--libsass_ldflags=" "--libsass_library="
gyp ERR! cwd C:\github\ngx-admin\node_modules\wintersmith-sassy\node_modules\node-sass
gyp ERR! node -v v10.15.0
gyp ERR! node-gyp -v v3.6.2
gyp ERR! not ok
Build failed with error code: 1
npm WARN [email protected] requires a peer of @angular/[email protected]^2.2.0 but none is installed. You must install peer dependencies yourself.
npm WARN [email protected] requires a peer of @angular/[email protected]^2.2.0 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules\webpack-dev-server\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","Arch":"any"} (current: {"os":"win32","Arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules\watchpack\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","Arch":"any"} (current: {"os":"win32","Arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","Arch":"any"} (current: {"os":"win32","Arch":"x64"})

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! [email protected] postinstall: `node scripts/build.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the [email protected] postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\danyb\AppData\Roaming\npm-cache\_logs\2019-01-29T18_25_12_699Z-debug.log

Hat jemand eine Idee, warum dieser Fehler auftritt und wie er behoben werden kann?

Wenn Sie auf dieses Problem stoßen, lesen Sie diese Seite: https: //www.bramvandenbulcke.be/en/kb/failed-node-sass3131-postinstall-script

Die Lösung in meinem Fall:

1) Löschen Sie das package-lock.json Datei

2) npm install gulp-sass --save-dev

3) npm install [email protected]

Versionsspezifische Hinweise:

[email protected] läuft nur auf Versionen von Node.js bis v7 wie in den Versionshinweisen angegeben:

13

Ich denke, das passiert, weil Ihnen das Node-Sass-Modul fehlt. Versuchen Sie Folgendes und führen Sie Ihr Build-Skript erneut aus, um festzustellen, ob Ihr Problem dadurch behoben wird:

npm install [email protected]

Außerdem wird fsevents auf einer Windows-Plattform verwendet. Dies ist nur eine Warnung, dass dieses Modul nur für den nativen Zugriff auf OS X FSEvents unterstützt wird

5
Nathan

Ich hatte Fehler [email protected] postinstall: node scripts/build.js Bei der npm-Installation nach dieser Nachricht

> node scripts/install.js

Downloading binary from https://github.com/sass/node-sass/releases/download/v3.13.1/linux-x64-72_binding.node
Cannot download "https://github.com/sass/node-sass/releases/download/v3.13.1/linux-x64-72_binding.node": 

HTTP error 404 Not Found

Hint: If github.com is not accessible in your location
      try setting a proxy via HTTP_PROXY, e.g. 

      export HTTP_PROXY=http://example.com:1234

or configure npm proxy via

      npm config set proxy http://example.com:8080

> [email protected] postinstall /var/www/my/armat/www/node_modules/core-js
> node scripts/postinstall || echo "ignore"

und Stunden damit verbracht, eine Lösung zu finden. Ich habe versucht, es auf laravel 5.2 Zu installieren, das ältere Versionen von Node und npm verwendet. Dies hat mir geholfen

$ npm install -g n
$ n 6.10.2    // selecting version you need in my case 6.10.2
$ npm install -g [email protected] // same for npm

hoffe das hilft jemand anderem ^ _ ^

5

Führen Sie die folgenden Befehle Schritt für Schritt aus

  • Löschen Sie die Datei package-lock.json
  • npm installiere gulp-sass --save-dev
  • npm install node-sass @ spätestens

Wenn Sie package.json nicht löschen möchten, führen Sie npm rebuild node-sass --force aus

Ich habe auch den gleichen Fehler erhalten

"npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! [email protected] postinstall: node scripts/build.js npm ERR! Ausgangsstatus 1 npm ERR! npm ERR! Fehler beim Postinstall-Skript [email protected] npm ERR! Dies ist wahrscheinlich kein Problem mit npm. Es gibt wahrscheinlich eine zusätzliche Protokollausgabe oben. "

Lösung :

Ich habe die Versionen von Node-Sass und Gulp-Sass auf den neuesten Stand in der Datei package.json erhöht, dann wurde das Problem behoben.