webentwicklung-frage-antwort-db.com.de

Modul node_modules\@ionic\app-scripts IONIC 3 kann nicht gefunden werden

Ich habe npm 3.10.10 installiert, dann habe ich installed ionic 3.9.2 und cordova 7.0.1.

ich habe folgende Schritte ausprobiert:

  1. ionic start newProject

    (ein Tabs-Projekt ausgewählt)

 enter image description here

 enter image description here

 enter image description here

 enter image description here

 enter image description here

  1. ionic serve

dieser Befehl wird throw die error

Fehler: Modul kann nicht gefunden werden 'E:\firstProject\node_modules\@ionic\app-scripts'

ich fand nur diesen Thread Fehler: Modul '@ ionic/app-scripts' kann nicht gefunden werden.

Ich möchte meine nodejs-Version nicht herunterstufen, da ich die neueste Funktion verwenden möchte.

aber ich habe es versucht,

npm i @ionic/app-scripts (SAG-Antwort)

ich bekomme dasselbe error nach der Ausführung oben command

bitte hilf mir ohne Abwertung nodejsversion

EDIT 1 (gemäß Sampath-Vorschlag): unten ist meine package.json-Datei

{
  "name": "firstProject",
  "version": "0.0.1",
  "author": "Ionic Framework",
  "homepage": "http://ionicframework.com/",
  "private": true,
  "scripts": {
    "clean": "ionic-app-scripts clean",
    "build": "ionic-app-scripts build",
    "lint": "ionic-app-scripts lint",
    "ionic:build": "ionic-app-scripts build",
    "ionic:serve": "ionic-app-scripts serve"
  },
  "dependencies": {
    "@angular/common": "4.1.3",
    "@angular/compiler": "4.1.3",
    "@angular/compiler-cli": "4.1.3",
    "@angular/core": "4.1.3",
    "@angular/forms": "4.1.3",
    "@angular/http": "4.1.3",
    "@angular/platform-browser": "4.1.3",
    "@angular/platform-browser-dynamic": "4.1.3",
    "@ionic-native/core": "3.12.1",
    "@ionic-native/splash-screen": "3.12.1",
    "@ionic-native/status-bar": "3.12.1",
    "@ionic/storage": "2.0.1",
    "ionic-angular": "3.6.0",
    "ionicons": "3.0.0",
    "rxjs": "5.4.0",
    "sw-toolbox": "3.6.0",
    "zone.js": "0.8.12"
  },
  "devDependencies": {
    "@ionic/app-scripts": "2.1.4",
    "TypeScript": "2.3.4"
  },
  "description": "An Ionic project"
}

wenn ich ionic info starte, gibt es eine Art Fehler 

$ ionische Informationen

 enter image description here

EDIT 2: (Nach der Antwort von sampath)

  1. ich habe folgende Änderungen vorgenommen
i removed `"@ionic/app-scripts": "2.1.4"`
  1. $ npm install @ ionic/app-scripts @ latest --save-dev

 enter image description here

 enter image description here

 enter image description here

post $ npm install @ ionic/app-scripts @ latest --save-dev, package.json Die Datei sieht wie folgt aus

 enter image description here

bitte helft mir danke im voraus !!!!

5
user5405873

Jungs, ich habe dieses Problem gelöst. Ich möchte nur mit Ihnen teilen, um mindestens Ihre Zeit zu sparen. Folge den Schritten.

  1. node_modules entfernen.
  2. Downgrade Node auf Version 6 (Ausführen von npm install [email protected] oder brew install [email protected])
  3. Fügen Sie "@ionic/app-scripts": "3.1.9" unter Abhängigkeiten in project.json hinzu.
  4. npm i 

Entfernen Sie zuerst "@ionic/app-scripts": "2.1.4" aus Ihrer package.json-Datei.

Entsprechend Ihrem ionic info haben Sie ein Problem mit app-scripts.So können Sie latest wie unten gezeigt installieren.

und danach kompilieren: 

npm install @ionic/[email protected] --save-dev

Entfernen Sie zuerst "@ionic/app-scripts": "2.1.4" aus Ihrer package.json-Datei.

Updatevon Git

Unter Windows können Sie Folgendes versuchen:

  1. Legen Sie die Umgebung im lokalen Befehlsfenster fest und überprüfen Sie das Problem:

    set OPENSSL_CONF=c:\dummy
    npm -v

=> Sie sehen jetzt wahrscheinlich diese SSL-Fehlermeldung

  1. Entfernen Sie die Umgebung und vergewissern Sie sich, dass das Problem nicht mehr besteht:

    set OPENSSL_CONF=npm -v

=> keine SSL-Fehlermeldung

5
Sampath

Installieren Sie nur die neueste Version von @ ionic/app-scripts

npm install @ionic/[email protected] --save-dev

4
L Ananta Prasad

Lauf:

npm install @ionic/[email protected] --save-

app-script installieren.

Dann:

npm install

So installieren Sie node_modules, um einen TypeScript-Fehler zu vermeiden 

Und es hat für mich funktioniert.

3
Adham Amiin

löschen Sie den node_modules-Ordner und führen Sie npm install erneut aus

0
ganesh

Ich hatte den gleichen Fehler. Ich habe das Update npm ausprobiert und das App-Skript neu installiert. Ich habe node und npm deinstalliert und dann erneut installiert und funktioniert. Ich denke, dieser Fehler lag darin, dass sich die Version von npm von der ursprünglichen Installation des Knotens unterschied

0
wilfredo daza