webentwicklung-frage-antwort-db.com.de

Create-React-App schlägt mit Fehler fehl: Knoten ist mit css-loader nicht kompatibel

Ich versuche einfach, eine Reakt-App mit dem Befehl npx create-react-app my-app Zu erstellen, erhalte jedoch folgende Fehlermeldung:

[email protected]: The engine "node" is incompatible with this module. Expected version ">= 6.9.0 <7.0.0 || >= 8.9.0". Got "8.5.0"

Ich habe versucht, den Knoten zu aktualisieren, aber es scheint nicht zu funktionieren. Ich überprüfe die Version 8.5.0 wie in der Fehlermeldung. Sogar meinen Computer als letzte Option neu gestartet, was aber auch nicht geholfen hat.

Gibt es noch etwas, was ich versuchen könnte? Anregungen sind willkommen.

3
katjass

Schließlich wurde mir klar, dass das Problem meine alte Version des Knotens war, ich hatte nvm installiert und musste die Knoteversion aktualisieren, die ich mit nvm use node verwende.

Update:

Ich musste diesen Befehl jedes Mal verwenden, wenn ich eine neue Terminalsitzung startete. Hatte auch Probleme, wenn andere Pakete aus irgendeinem Grund die falsche Knotenversion aufnahmen.

Das kann mit dem Befehl nvm alias default 10.11.0 behoben werden, oder welche Version Sie verwenden möchten.

3
katjass

Ich hatte das gleiche und verbrachte einige Stunden damit, es herauszufinden. Ich denke es war das Webpack. Schließlich beendete ich die Aktualisierung des Knotens.

Sudo npm cache clean -f
Sudo npm install -g n
Sudo n stable
4
Tarek

Ich hatte das gleiche Problem, als ich ein paar Sachen ausprobierte und nachdem ich die letzte Version des Knotens mit NVM aktualisiert hatte, funktionierte es. Ich habe es von dieser Website erhalten: https://bytearcher.com/articles/ways-to-get-the-latest-node.js-version-on-a-mac/

nvm install node --reinstall-packages-from=node
0
codeGirl

Das kann ich bestätigen 

nvm install node --reinstall-packages-from=node

hat für mich gut funktioniert.

0
user3057358