webentwicklung-frage-antwort-db.com.de

OpenWRT: Grundlegende Netzwerkkonfiguration

Ich habe gerade OpenWRT 12.09 auf meinem Router installiert, war aber ein wenig verwirrt über Interfaces/Bridges/Vlans. My router

Nach meinem ersten Start habe ich mich angemeldet und mein Root-Passwort festgelegt. Ich habe Luci verwendet, um mein WLAN zu aktivieren, und ein wenig Zeit gebraucht, um herauszufinden, dass ich WLAN mit LAN verbinden kann, um Zugang zum Internet zu erhalten. Am Ende hatte ich zwei Probleme:

  1. Die DHCP-Adressen wurden von meinem ISP bereitgestellt (was schlecht ist, da ich für jede IP eine zusätzliche Gebühr zahlen muss)
  2. Ich kann den SHH-Zugriff über das Internet/WAN nicht blockieren, daher ist mein Router etwas anfällig.

Wie muss ich - vorzugsweise von Luci - konfigurieren, um Folgendes zu tun:

  • Von diesem Router bereitgestelltes DHCP für meine internen Geräte mit DNS-Auflösung
  • Meine vom ISP-Modem bereitgestellte externe Adresse (LAN/eth0) (daher kann ich Port 68 in dieser Schnittstelle nicht einfach blockieren)
  • Konfigurieren Sie meine Schnittstellen richtig, damit ich SSH nur auf der internen (WAN/radio0) Schnittstelle zulassen kann

Welches und warum sollte ich mich für Bridge oder VLAN entscheiden? Dieser Artikel erklärt ihn weder, noch gibt er Hinweise.


Einige Anmerkungen: - Ich bin ein Gentoo Linux-Benutzer und sehe mich als guter Anfänger, habe aber noch keine guten Referenzen für OpenWRT gefunden. - Mein Gerät ist TP-Link TL-MR3020 , es hat übrigens nur eine LAN/eth0-Schnittstelle und eine drahtlose/radio0-Schnittstelle.

Update: Hier sind einige meiner Konfigurationsdateien zum Überprüfen; tl; dr

Dies ist meine '/ etc/config/dhcp'-Datei

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option leasetime '12h'
        option limit '15'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

Dies ist meine '/ etc/config/network'-Datei

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option gateway '192.168.100.1'
        option dns '192.168.100.1'
        option ipaddr '192.168.100.2'
        option netmask '255.255.255.0'

Dies ist meine/etc/config/wireless-Datei

config wifi-device 'radio0'
        option type 'mac80211'
        option macaddr '64:66:b3:4d:8b:ce'
        option hwmode '11ng'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option txpower '27'
        option country 'US'
        option channel 'auto'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'EDITED'
        option encryption 'psk-mixed'
        option key 'EDITED'
6
Rafareino

Es scheint, dass Sie alle Konfigurationen in der Befehlszeile vornehmen.

Ich habe bereits OpenWRT ausprobiert und die WebGUI installiert, um zu helfen. Informationen zum Einrichten der Webbenutzeroberfläche durch LuCI finden Sie unter LuCI Essentials. Der Zugriff über einen Webbrowser zur Konfiguration Ihres Routers, z. B. zum Aktivieren von SSH und zum Festlegen einiger anderer Konfigurationen, ist über die Web-Benutzeroberfläche einfacher.

Edit 1.

Sie haben also 3 Fragen, ich trenne sie und versuche, die Lösung einzeln zu finden, um das Verständnis zu erleichtern. Eines muss man deklarieren, da mein Router von OpenWRT auf DDWRT und dann auf Tomato umgestellt wird. Also habe ich VM (Virtual Machine) für die Bildschirmaufnahme und das Schreiben von Lösungen verwendet. Bitte verzeihen Sie, wenn es 1 oder 2 geringfügige Punktunterschiede gibt. Ich denke, es ist meistens dasselbe, da ich VM verwendet habe, um OpenWRT zu testen, bevor ich auf meinen Router flashe.

Vorbereitungen: (falls Sie dies noch nicht getan haben) Auf das LuCi wird später zugegriffen, wenn Ihr Router so konfiguriert ist, dass lokale Netzwerkcomputer darauf zugreifen können. Extrahiert aus LuCI Essentials

Installieren Sie LuCi mit den folgenden Befehlen

opkg update
opkg install luci # without https OR
opkg install luci-ssl # with https support
/etc/init.d/uhttpd start # Start the web server (uHTTPd) manually
/etc/init.d/uhttpd enable # if you wish to start automatically on reboot

1. Meine externe Adresse (lan/eth0), die vom ISP-Modem bereitgestellt wurde (daher kann ich Port 68 in dieser Schnittstelle nicht einfach sperren) Ich nehme an, Sie möchten die externe Adresse abrufen, oder? Tatsächlich wird Ihre externe Adresse später in LuCi angezeigt, wenn Sie den Router so einrichten, dass er das DHCP von Ihrem ISP (Modem) erhält.

Diese Einstellung sollte die Arbeit erledigen:

vim /etc/config/network # edit network settings
save

#add the following lines to config
config 'interface' 'wan' # config the interface wan
        option 'proto' 'dhcp' # use protocol DHCP
        option 'ifname' 'eth1' # Physical interface name to assign to, this should be the network port connected to the your ISP modem, may vary eth1 or eth0 or whatever in your case

>>>command
ifup wan # bring WAN interface up

Wenn Sie bis zu diesem Zeitpunkt Ihren Client-Computer wie Windows 7 öffnen, einen Browser öffnen, 192.168.100.1 (Ihren Fall) eingeben, sollte die OpenWRT-Oberfläche im Browser angezeigt werden. Passwort ist standardmäßig nichts.

So etwas wie dieser Bildschirm:

enter image description here

2. Von diesem Router für meine internen Geräte bereitgestelltes DHCP mit Auflösung von Gerätenamen (DNS)

Wenn Sie über den Browser des Client-Computers eine Verbindung zu Ihrem Router herstellen können, können Sie Network -> Hostnames aufrufen, um bestimmten Geräten manuell einen Hostnamen zuzuweisen, wenn diese Geräte keinen Hostnamen haben oder sich nicht automatisch auflösen lassen. (in meinem Fall haben Standard kein Problem)

3. Konfigurieren Sie meine Schnittstellen richtig, damit ich ssh nur auf der internen (wan/radio0) Schnittstelle zulassen kann.

gemäß Secure Access-Dokument in OpenWRT

"indem der SSH-Server Dropbear und der Web-Server UHTTPD nicht auf den externen/WAN-Port lauschen"

So geht's:

vim /etc/config/dropbear
save

# add the following line to your dropbear
option Interface 'lan' # only listen to lan

>>>command
/etc/init.d/dropbear restart # or reboot if it doesn't work

Ich denke, dies sollte das Lösungsbild für Ihre Fragen veranschaulichen.

1
simongcc