webentwicklung-frage-antwort-db.com.de

Bootstrap 4 Installation mit Laravel 5.7

Ich versuche, meine app.scss-Datei, die mit meinem neuen Projekt von Laravel geliefert wird, zu kompilieren, aber ich möchte Bootstrap 4 installieren. Zum Zeitpunkt meiner npm run dev-Installation wird Bootstrap 4 nicht installiert, aber es hat immer noch den Bootstrap, den Laravel mitbringt Standard.

Irgendwelche Empfehlungen oder Unterlagen dazu?

 enter image description here

3
Pablo Curumaco

In der Tat wird Laravel standardmäßig mit Bootstrap 4 ausgeliefert. Wenn Sie einen Blick auf die Datei https://github.com/laravel/laravel/blob/master/package.json werfen (Sie sollten package.json auch in Ihrem Projekt haben), sehen Sie die Zeile:

"bootstrap": "^4.0.0"

was bedeutet, dass Bootstrap 4 installiert wird.

Du solltest rennen

npm install

um alle Pakete zu installieren, wird standardmäßig Bootstrap 4 installiert.

Dieses ~-Zeichen bedeutet hier node_modules-Verzeichnis, also in der Zeile 

@import "~bootstrap/scss/bootstrap"

meint

@import "node_modules/bootstrap/scss/bootstrap"
1

Wenn Sie in die Laravel-Datei welcome.blade.php schauen, sehen Sie CSS und ein Link-Tag, das eine Google-Schriftart importiert. Dies sollte nicht mit dem tatsächlichen Import von Bootstrap 4 verwechselt werden.

Hier sind die Schritte zum Implementieren von Bootstrap 4 und alle anderen coolen Dinge, die standardmäßig mit Laravel geliefert werden. Es scheint bereits, als hätten Sie npm run watch ausgeführt, also gehe ich davon aus, dass Sie diesen Befehl ausgeführt haben.

Einfache Schritte

Fügen Sie Ihrem Kopfelement ein Link-Tag hinzu:

<link rel="stylesheet" href="css/app.css">

Fügen Sie am unteren Rand Ihres Körperelements Folgendes hinzu:

<script src="js/app.js" charset="utf-8"></script>

Das sollte es für dich tun. Stellen Sie jedoch sicher, dass Sie die SCSS-Dateien und die Javascript-Dateien mit dem Befehl npm run watch kompiliert haben, sonst funktioniert es nicht!

Prost!

0
J. Robinson