webentwicklung-frage-antwort-db.com.de

ionischer Aufschlag des IONIC 1-Projekts, der nicht in ionischen 4 Cli arbeitet

Nach dem Start von IONIC 4 Beta habe ich heute meine IONIC CLI auf 4.0.1 aktualisiert. Danach versuchte ich, eines meiner IONIC v1-Projekte mit zu bedienen 

ionic dienen befehl es zeigte mir Fehler und Warnungen an

ionic serve

ionic-v1 dient --Host 0.0.0.0 --port 8100 - lr-port 35729 --dev-port 53703 [v1] 'ionic-v1' wird nicht als interner oder externer Befehl erkannt, [v1] Programm oder Stapelverarbeitungsdatei.

[INFO] Sieht so aus, als ob @ ionic/v1-toolkit nicht in diesem Projekt installiert ist.

   This package is required for ionic serve. For more details, please see the CHANGELOG:
   https://github.com/ionic-team/ionic-cli/blob/master/packages/ionic/CHANGELOG.md#4.0.0

[ERROR] Eine Utility-CLI wurde unerwartet geschlossen.

    The Ionic CLI will exit. Please check any output above for error details.

BITTE HILFE

4

Wie in warning vorgeschlagen [INFO] Sieht so aus, als wäre @ ionic/v1-toolkit in diesem Projekt nicht installiert.

Ich habe versucht, @ ionic/V1-Toolkit mit dem folgenden Befehl zu installieren, und ich konnte für mein IONIC V1-Projekt von IONIC V4.0.1 CLI ein ionisches Serving verwenden.

npm install @ionic/v1-toolkit -g
10

Installieren Sie ein ionisches Labor 

npm install @ionic/lab

Dadurch wird das Problem behoben 

Ionic Lab funktioniert nicht mit ionischer CLI 4.0.0

0
Moh Alaraabi