webentwicklung-frage-antwort-db.com.de

eckig 4 ​​bis eckig 5 Modul '@ eckig/Router' kann nicht gefunden werden

  • Ich verbessere von Winkel 2 auf Winkel 5.
  • nach dem Upgrade sehe ich die folgenden Fehler in der TS-Datei.
  • in angle5 muss ich @ angle/core und @ angle/router entfernen
  • nach dem Upgrade wird das package.json ebenfalls bereitgestellt
  • geben Sie unten meinen Fehler- und Code-Ausschnitt ein.
  • kannst du mir sagen, wie ich es reparieren kann?.

error

[ts] Das Modul '@ angle/core' kann nicht gefunden werden.
[ts] Das Modul '@ angle/router' kann nicht gefunden werden.

code

import {Component, ElementRef, Input,Output,EventEmitter,Inject, OnInit,ViewChild} from '@angular/core';
import {KendoGridComponent} from '../grid/grid.component'
import { Router} from '@angular/router';

package.json

{
  "name": "SPORTS",
  "version": "1.0.0",
  "description": "SPORTS player - v0.2.37.1",
  "engines": {
    "node": "7.10.1"
  },
  "license": "ISC",
  "dependencies": {
    "@angular/animations": "^5.2.2",
    "@angular/common": "^5.2.2",
    "@angular/compiler": "^5.2.2",
    "@angular/compiler-cli": "^5.2.2",
    "@angular/core": "^5.2.2",
    "@angular/forms": "^5.2.2",
    "@angular/http": "^5.2.2",
    "@angular/platform-browser": "^5.2.2",
    "@angular/platform-browser-dynamic": "^5.2.2",
    "@angular/platform-server": "^5.2.2",
    "@angular/router": "^5.2.2",
    "@angular/upgrade": "2.0.0",
    "@ng-idle/core": "2.0.0-beta.2",
    "@ng-idle/keepalive": "2.0.0-beta.2",
    "@types/jquery": "^3.2.10",
    "@types/node": "^8.0.18",
    "@types/underscore": "^1.8.1",
    "@types/webpack": "^3.0.5",
    "angular2-in-memory-web-api": "0.0.21",
    "angular2-router-loader": "^0.3.5",
    "angular2-template-loader": "^0.6.2",
    "awesome-TypeScript-loader": "^3.2.1",
    "babel-minify-webpack-plugin": "0.2.0",
    "bootstrap": "^3.3.6",
    "commander": "^2.6.0",
    "compression-webpack-plugin": "1.0.1",
    "core-js": "^2.4.1",
    "css-loader": "^0.28.7",
    "del": "^3.0.0",
    "express": "^4.14.1",
    "extract-text-webpack-plugin": "^3.0.0",
    "file-loader": "^0.11.2",
    "file-saver": "^1.3.3",
    "html-webpack-plugin": "^2.30.1",
    "http-post": "^0.1.1",
    "http-proxy": "^1.8.1",
    "jquery": "2.2.3",
    "pako": "^1.0.5",
    "path": "^0.12.7",
    "raw-loader": "^0.5.1",
    "reflect-metadata": "^0.1.3",
    "require": "^2.4.20",
    "rxjs": "^5.5.6",
    "style-loader": "^0.18.2",
    "text-encoding-shim": "^1.0.0",
    "to-string-loader": "^1.1.5",
    "ts": "0.0.0",
    "TypeScript": "^2.4.2",
    "uglifyjs-webpack-plugin": "^0.4.6",
    "underscore": "^1.8.3",
    "webpack": "^3.5.6",
    "webpack-dev-server": "^2.7.1",
    "webpack-merge": "^4.1.0",
    "zone.js": "^0.6.23"
  },
  "devDependencies": {
    "gulp": "^3.9.1",
    "gulp-clean-css": "^3.8.0",
    "gulp-concat": "^2.6.1",
    "gulp-util": "^3.0.8",
    "jasmine-core": "~2.4.1",
    "jasmine-expect": "^3.0.1",
    "jasmine-jquery": "^2.1.1",
    "karma": "^1.2.0",
    "karma-chrome-launcher": "^0.2.3",
    "karma-cli": "^0.1.2",
    "karma-coverage": "^1.1.1",
    "karma-htmlfile-reporter": "^0.2.2",
    "karma-jasmine": "^0.3.8",
    "karma-jquery": "^0.1.0",
    "karma-sourcemap-loader": "^0.3.7",
    "karma-TypeScript": "^2.1.4",
    "karma-TypeScript-preprocessor": "^0.3.0"
  },
  "main": "server.js",
  "scripts": {
    "dev": "webpack-dev-server --config  ./webpack.dev.js --inline --progress --color ",
    "postinstall": "webpack -p --config ./webpack.prod.js --progress --profile --bail",
    "start": "node server.js"
  },
  "repository": {
    "type": "git",
    "url": "https://github.iSPORTS.com/player-Replatform/webcomponent.git"
  }
}
4
user9201591

Sie müssen diese Abhängigkeiten manuell installieren.

$ npm i @angular/core -s
$ npm i @angular/router -s

Das gleiche Problem hatte ich beim Upgrade wegen npm. Ich schlage vor, dass Sie stattdessen Garn verwenden.

10
Melchia

Stellen Sie sicher, dass Sie RouterModule in jedes Routermodul exportieren, das über untergeordnete Elemente verfügt. In der Winkeldokumentation wird dies nicht explizit als notwendig bezeichnet - es ist lediglich in den Beispielen enthalten -, aber es ist notwendig, wie man nach den üblichen mehrstündigen Edit-Run-Seufz, Edit-Run-Shout, Editieren herausfindet -run-google-editWithHope-scream-considerSmashingKeyboard, Edit-Run-Cry, Edit-Run-SolveByAccident-feelMomentaryPride (Wiederholung).

Das Ergebnis: include RouterModule . Das Meta-Fazit: Achten Sie auf den kleinen, scheinbar unnötigen Code in der offiziellen Dokumentation.

1
Jai Preston
  1. Kommt dieser Fehler vom Compiler oder einem IDE - Tool wie Intellisense? Ich finde manchmal beim Installieren/Verzweigen von Switches IDE, dass Werkzeuge wie diese verwirrt werden können und einen Neustart der IDE erfordern.

  2. Wenn es nicht kompiliert wird, befinden sich die Module tatsächlich in Ihrem node_modules? Wenn nicht, löschen Sie Ihren package-lock.json oder shrinkwrap.json und installieren Sie ihn erneut. NPM fügt die Paketsperre standardmäßig ab 5.0 hinzu, und ich finde bei komplizierten Abhängigkeiten manchmal Unordnung.

  3. Wenn sie vorhanden sind, führen Sie npm Prune und npm install erneut aus.

  4. Wenn dies nicht funktioniert, nuke node_modules neben einer Sperrdatei installieren und erneut installieren.

  5. Benötigen Bibliotheken von Drittanbietern ein Update? Angular 5 hatte einige brechende API-Änderungen. Überprüfen Sie ihre Dokumente, wenn dies der Fall ist.

  6. Betrachten Sie Garn.

Ich bin mir ziemlich sicher, dass es die erste ist, aber ich lasse alle Schritte, die ich normalerweise mache, nur zur Vollendung.

1
joh04667