webentwicklung-frage-antwort-db.com.de

BrowserslistError: Unbekannter Browser-Major

Ich versuche, Bootstrap 4 mit meiner Winkelinstallation zu verwenden. Ich habe ausgeführt npm install --save bootstrap @ next, aber ich habe eine Pause zur Laufzeit:

./node_modules/css-loader?{"sourceMap":false,"importLoaders":1}!./node_modules/postcss-loader/lib?{"ident":"postcss","plugins":[null,null,null],"sourceMap":false}!./node_modules/bootstrap/dist/css/bootstrap.min.css
Module build failed: BrowserslistError: Unknown browser major
    at error (C:\xampp\htdocs\tick_master_angular\web\node_modules\browserslist\index.js:37:11)
    at Function.browserslist.checkName (C:\xampp\htdocs\tick_master_angular\web\node_modules\browserslist\index.js:320:18)
    at Function.select (C:\xampp\htdocs\tick_master_angular\web\node_modules\browserslist\index.js:438:37)
    at C:\xampp\htdocs\tick_master_angular\web\node_modules\browserslist\index.js:207:41
    at Array.forEach (native)
    at browserslist (C:\xampp\htdocs\tick_master_angular\web\node_modules\browserslist\index.js:196:13)
    at Browsers.parse (C:\xampp\htdocs\tick_master_angular\web\node_modules\autoprefixer\lib\browsers.js:44:14)
    at new Browsers (C:\xampp\htdocs\tick_master_angular\web\node_modules\autoprefixer\lib\browsers.js:39:28)
    at loadPrefixes (C:\xampp\htdocs\tick_master_angular\web\node_modules\autoprefixer\lib\autoprefixer.js:56:18)
    at plugin (C:\xampp\htdocs\tick_master_angular\web\node_modules\autoprefixer\lib\autoprefixer.js:62:18)
    at LazyResult.run (C:\xampp\htdocs\tick_master_angular\web\node_modules\postcss-loader\node_modules\postcss\lib\lazy-result.js:270:20)
    at LazyResult.asyncTick (C:\xampp\htdocs\tick_master_angular\web\node_modules\postcss-loader\node_modules\postcss\lib\lazy-result.js:185:32)
    at LazyResult.asyncTick (C:\xampp\htdocs\tick_master_angular\web\node_modules\postcss-loader\node_modules\postcss\lib\lazy-result.js:197:22)
    at processing.Promise.then._this2.processed (C:\xampp\htdocs\tick_master_angular\web\node_modules\postcss-loader\node_modules\postcss\lib\lazy-result.js:224:20)
    at LazyResult.async (C:\xampp\htdocs\tick_master_angular\web\node_modules\postcss-loader\node_modules\postcss\lib\lazy-result.js:221:27)
    at LazyResult.then (C:\xampp\htdocs\tick_master_angular\web\node_modules\postcss-loader\node_modules\postcss\lib\lazy-result.js:127:21)
 @ ./node_modules/css-loader?{"sourceMap":false,"importLoaders":1}!./node_modules/postcss-loader/lib?{"ident":"postcss","sourceMap":false}!./src/styles.css 3:10-190
 @ ./src/styles.css
 @ multi ./src/styles.css

Kann jemand bitte helfen?

15
Tiny Skillz

Das Problem könnte sein, dass Sie den neuesten Build mit einem Fehler erhalten haben. Ich habe festgestellt, dass [email protected] dieses Problem verursacht, aber nicht [email protected] Prüfen Sie, ob es Ihnen gleich geht. Deinstallieren Sie das Programm und führen Sie etwas mit einer bestimmten Version aus.

npm install [email protected]

Das hat mein Problem gelöst.

14
Jay

Die neue Bootstrap-Version ist v4.0.0-beta.2. Ihr package.json hat ^ bootstrap4.0.0-alpha.6. Die neue Bootstrap-Version möchte also eine Abhängigkeit der Browserliste.

Um Ihre App auszuführen, entfernen Sie das letzte Version-Tag (^) und führen Sie den Befehl npm install aus

12
Sagar Jadhav

Für Bootstrap 4.0.0 (Release) muss ich die CLI auf 1.6.5 aktualisieren - und es funktioniert!

  "dependencies": {
    "@angular/animations": "^5.0.0",
    "@angular/common": "^5.0.0",
    "@angular/compiler": "^5.0.0",
    "@angular/core": "^5.0.0",
    "@angular/forms": "^5.0.0",
    "@angular/http": "^5.0.0",
    "@angular/platform-browser": "^5.0.0",
    "@angular/platform-browser-dynamic": "^5.0.0",
    "@angular/router": "^5.0.0",
    "@ng-bootstrap/ng-bootstrap": "1.0.0-beta.9",
    "bootstrap": "4.0.0",
    "core-js": "^2.4.1",
    "font-awesome": "^4.7.0",
    "jquery": "^3.2.1",
    "popper.js": "^1.12.9",
    "rxjs": "^5.5.2",
    "zone.js": "^0.8.14"
  },
  "devDependencies": {
    "@angular/cli": "^1.6.5",
    "@angular/compiler-cli": "^5.0.0",
    "@angular/language-service": "^5.0.0",
    "@types/jasmine": "~2.5.53",
    "@types/jasminewd2": "~2.0.2",
    "@types/node": "~6.0.60",
    "codelyzer": "^4.0.1",
    "jasmine-core": "~2.6.2",
    "jasmine-spec-reporter": "~4.1.0",
    "karma": "~1.7.0",
    "karma-chrome-launcher": "~2.1.1",
    "karma-cli": "~1.0.1",
    "karma-coverage-istanbul-reporter": "^1.2.1",
    "karma-jasmine": "~1.1.0",
    "karma-jasmine-html-reporter": "^0.2.2",
    "protractor": "~5.1.2",
    "ts-node": "~3.2.0",
    "tslint": "~5.7.0",
    "TypeScript": "~2.4.2"
  }
7
Pax Beach

Ich habe ein Upgrade auf Angular CLI 1.7.x durchgeführt und es hat gut funktioniert. Ich empfehle diese Lösung. Ich meine das Upgrade der Angular CLI und es sollte für Sie funktionieren!

Eine andere Problemumgehung besteht darin, die folgenden Zeilen aus node_modules/bootstrap/package.json zu löschen.

"browserslist": [
"last 1 major version", <----- delete this line
">= 1%", <----- delete this line
"Chrome >= 45",
"Firefox >= 38",
"Edge >= 12",
"Explorer >= 10",
"iOS >= 9",
"Safari >= 9",
"Android >= 4.4",
"Opera >= 30"
],
5
Roopesh Reddy

Hat das gleiche Problem meine Abhängigkeit in package.json geändert

"dependencies": {
    "@angular/animations": "^5.0.0",
    "@angular/common": "^5.0.0",
    "@angular/compiler": "^5.0.0",
    "@angular/core": "^5.0.0",
    "@angular/forms": "^5.0.0",
    "@angular/http": "^5.0.0",
    "@angular/platform-browser": "^5.0.0",
    "@angular/platform-browser-dynamic": "^5.0.0",
    "@angular/router": "^5.0.0",
    "@ng-bootstrap/ng-bootstrap": "^1.0.0-beta.9",
    "bootstrap": "^4.0.0-beta.3",
    "core-js": "^2.4.1",
    "font-awesome": "^4.7.0",
    "zone.js": "^0.8.14"
  }

zu (Änderung von "bootstrap": "4.0.0-beta.2" in eine stabile Version)

"dependencies": {
    "@angular/animations": "^5.0.0",
    "@angular/common": "^5.0.0",
    "@angular/compiler": "^5.0.0",
    "@angular/core": "^5.0.0",
    "@angular/forms": "^5.0.0",
    "@angular/http": "^5.0.0",
    "@angular/platform-browser": "^5.0.0",
    "@angular/platform-browser-dynamic": "^5.0.0",
    "@angular/router": "^5.0.0",
    "@ng-bootstrap/ng-bootstrap": "^1.0.0-beta.9",
    "bootstrap": "4.0.0-beta.2",
    "core-js": "^2.4.1",
    "font-awesome": "^4.7.0",
    "zone.js": "^0.8.14"
  },

führen Sie dann Folgendes aus: npm installng serv

problem gelöst.!!

2
Saurav

Ich hatte das gleiche Problem mit Bootstrap 4.1.1. Die Lösung besteht darin, die Bootstrap-Version in package.json auf 4.0.0-beta.2 (ohne Caret-Zeichen) zu ändern und anschließend auszuführen 

npm install 
ng serve

Fügen Sie auch import "~bootstrap/dist/css.bootstrap.css" in Ihre style.css-Datei ein.

Bootstrap 4 verwendet kein CSS mehr. In dieser Version wird der SCSS verwendet. Statt '~bootstrap/scss/bootstrap.css' zu importieren, sollten Sie '~bootstrap/scss/bootstrap.scss' importieren.

0