webentwicklung-frage-antwort-db.com.de

Babel 7 - ReferenceError: regeneratorRuntime ist nicht definiert

Ich habe eine Anwendung, die ein Knoten-Backend und ein Reakt-Frontend ist.

Ich erhalte die folgende Fehlermeldung, wenn ich versuche, meine Knotenanwendung zu erstellen/auszuführen.

Knoten: v10.13.0

Error:

dist/index.js: 314 regeneratorRuntime.mark (Funktion _callee (productId) { ^

ReferenceError: regeneratorRuntime ist nicht definiert

.babelrc

{
    "presets": [    [
        "@babel/preset-env", {
          "targets": {
            "node": "current"
          },
        }
      ], "@babel/preset-react"],
    "plugins": [
        "@babel/plugin-proposal-class-properties"
    ]
}

webpack.config.js

{
        mode: "development",
        entry: "./src/index.js",
        target: "node",
        externals: [nodeExternals()], // in order to ignore all modules in node_modules folder
        stats: {
            colors: true
        },
        devtool: "source-map",

        output: {
            path: path.resolve(__dirname, "dist"),
            filename: "index.js",
            sourceMapFilename: "index.js.map"
        },
        module: {
            rules: [
                {
                    enforce: "pre",
                    test: /\.js$/,
                    exclude: /node_modules/,
                    loader: "eslint-loader",
                },
                {
                    test: /\.m?js$/,
                    exclude: /(node_modules|bower_components)/,
                    use: {
                        loader: "babel-loader",
                        options: {
                            presets: ["@babel/preset-env"]
                        }
                    }
                }
            ],
        },
        node: {
            __dirname: false,
            __filename: false,
        },

        "plugins": [
            new CleanWebpackPlugin(),
            new WebpackShellPlugin({
                onBuildStart: [],
                onBuildEnd: ["nodemon dist/index.js"]
            }),

        ]

    },

package.json

 "dependencies": {
    "connect": "^3.6.6",
    "cors": "^2.8.5",
    "dotenv": "^6.1.0",
    "express": "^4.16.4",
    "hellojs": "^1.17.1",
    "i18n-iso-countries": "^3.7.8",
    "morgan": "^1.9.1",
    "react": "^16.6.3",
    "react-dom": "^16.6.3",
    "request": "^2.88.0",
    "request-promise-native": "^1.0.5",
    "serve-static": "^1.13.2",
    "vhost": "^3.0.2"
  },
  "devDependencies": {
    "@babel/cli": "^7.1.5",
    "@babel/core": "^7.1.6",
    "@babel/plugin-proposal-class-properties": "^7.1.0",
    "@babel/preset-env": "^7.1.6",
    "@babel/preset-react": "^7.0.0",
    "babel-eslint": "^10.0.1",
    "babel-loader": "^8.0.4",
    "clean-webpack-plugin": "^1.0.0",
    "copy-webpack-plugin": "^4.6.0",
    "css-loader": "^1.0.1",
    "eslint": "^5.9.0",
    "eslint-config-google": "^0.10.0",
    "eslint-loader": "^2.1.1",
    "eslint-plugin-react": "^7.11.1",
    "extract-loader": "^3.0.0",
    "file-loader": "^2.0.0",
    "node-sass": "^4.10.0",
    "sass-loader": "^7.1.0",
    "style-loader": "^0.23.1",
    "webpack": "^4.26.0",
    "webpack-cli": "^3.1.2",
    "webpack-node-externals": "^1.7.2",
    "webpack-Shell-plugin": "^0.5.0"
  }
4
Kay

Es gibt bereits eine sehr gute Antwort (ursprünglich in der Babel6-Frage veröffentlicht), die ich gerade in Yarn übersetzen werde. Grundsätzlich benötigen Sie die Babel-Laufzeit (NICHT als dev-Abhängigkeit) und das Plug-in-Transformationslaufwerk

yarn add @babel/runtime 
yarn add -D @babel/plugin-transform-runtime

Und in .babelrc Folgendes hinzufügen:

{
    "presets": ["@babel/preset-env"],
    "plugins": [
        ["@babel/transform-runtime"]
    ]
}
3

Sie benötigen die regeneratorRuntime .

Installieren Sie diese beiden Pakete - babel-plugin-transform-regenerator und babel-polyfill

Fügen Sie die folgende Babel-Konfiguration über .babelrc hinzu.

{
  "plugins": ["transform-regenerator"]
}
0
ksharifbd

Ich bin gerade auf dieses Problem gestoßen und habe die folgende Lösung gefunden:

In package.json hatte ich @babel/polyfill als Abhängigkeit. In meiner index.js (Meine Haupt-js-Datei) hatte ich jedoch versäumt, die folgende Zeile oben zu platzieren:

import '@babel/polyfill'

Nachdem ich es importiert hatte, funktionierte alles gut.

Babel-runtime musste nicht installiert werden, da andere Antworten nahelegen.

0
kojow7