webentwicklung-frage-antwort-db.com.de

Wie kann ich Netbeans mit JDK 10 installieren?

Ich versuche die Kommandozeile mit JavaHome:

netbeans-trunk-nightly-201803230002-javase-windows.exe --javahome "C:\Program Files\Java\jdk-10"

Es sollte funktionieren, aber ich erhalte eine Nachricht:

Am angegebenen Speicherort C:\Programme\Java\jdk-10 befindet sich keine JRE

enter image description here

Vielen Dank!

19

Aktualisiert am 31. Juli 2018, um veraltete Informationen durchzustreichen und Details zur offiziellen Version von NetBeans 9 hinzuzufügen.

Wenn Sie NetBeans von der Oracle-Site herunterladen, sollten Sie nicht damit rechnen, dass auch der nächtliche Entwickler-Build mit Java 10 funktioniert.

NetBeans wird derzeit von Oracle an Apache übergeben, und es gibt eine Entwicklungsversion, die von Apache in Form einer Zip-Datei heruntergeladen werden kann:

https://builds.Apache.org/job/incubator-netbeans-linux/

Sie können diese Datei unter Linux, Mac oder Windows entpacken und sie funktioniert mit Java 10. Beachten Sie nur, dass sie noch nicht offiziell freigegeben wurde. Das ist ein paar Wochen entfernt.

Sie können hier nach Fehlern suchen und/oder diese melden:

https://issues.Apache.org/jira/projects/NETBEANS


UPDATE 4. Juni 2018

Apache NetBeans 9.0 RC1 wurde am 28. Mai veröffentlicht. Die Quelle und die Binärdatei können hier als Zip-Dateien heruntergeladen werden:

https://netbeans.Apache.org/download/nb90/nb90-rc1.html

UPDATE 31. Juli 2018

Apache NetBeans 9.0 wurde am 29. Juli veröffentlicht. Der Quellcode und die Binärdatei können hier als Zip-Dateien heruntergeladen werden:

https://netbeans.Apache.org/download/nb90/nb90.html#_downloading

!!! WICHTIGER HINWEIS !!!

NetBeans 9 offiziell unterstützt nur Java SE, was bedeutet:

  • Das Projekt Wizard ist im Vergleich zu NetBeans 8.2 begrenzt. Beispielsweise können Sie nicht einmal eine Java Webanwendung erstellen.
  • Die meisten Plugins sind nicht verfügbar. Der entpackte Download von NetBeans erlaubt nicht einmal die Installation von Plugins für Java EE, C/C++, Fortran, Grails, Groovy, PHP usw.

Es ist jedoch ein einfacher Vorgang, diese Funktionalität zu aktivieren (auf eigenes Risiko). Weitere Informationen finden Sie in der Antwort auf So stellen Sie mit Netbeans 9 eine gültige Webanwendung auf Tomcat bereit .

Eine Erklärung, warum die Plugins nicht standardmäßig verfügbar sind, finden Sie unter Was ist mit meinen bevorzugten NetBeans-Plugins passiert? .

29
skomisa

Für Windows können Sie mit NetBeans Extracted-Bundle installieren:

Öffne cmd als Admin User

netbeans-XXX-windows.exe --extract

dann renne

Java -jar bundle.jar

5
Imran Khan

Netbeans funktionieren mit jdk Version 10 nicht richtig. Installieren Sie jdk 8u/17l und alles sollte gut gehen.

2
ravikiran