webentwicklung-frage-antwort-db.com.de

Project Facet Java Version 1.7 wird nicht unterstützt

Als ich mein Java aktualisiere, fand ich das Problem "Project Facet Java Version 1.7 wird nicht unterstützt" Um dieses Problem zu beheben, befolgen Sie die Schritte.

  1. Gehen Sie zu Ecllipse und klicken Sie mit der rechten Maustaste auf Ihren Projektordner 
  2. wählen Sie die Eigenschaften aus 
  3. wählen Sie nun Projektfacetten aus. Hier sehen Sie Java, klicken Sie auf die Version und ändern Sie die höhere Version in eine niedrigere oder nach Bedarf.

enter image description here

33
Imran khan

Sie müssen prüfen, welcher JRE-Typ in Ihrer IDE installiert ist.

JRE

5
Boopathi

Beim Upgrade von Java Version 1.6 auf 1.7 war ich vor einiger Zeit auf das gleiche Problem gestoßen. Um dies zu beheben, habe ich die folgenden Schritte befolgt.

  1. Klicken Sie mit der rechten Maustaste auf das Projekt im Projektexplorer und klicken Sie auf Eigenschaften.
  2. Navigieren Sie zu Java Build Path> "Libraries".
  3. Löschen Sie alle miteinander in Konflikt stehenden Bibliotheken, die ein rotes Kreuz auf den Symbolen haben.
  4. Prüfen und bearbeiten Sie ggf. die JRE-Systembibliothek.
  5. Navigieren Sie zu Project Facets und wählen Sie die gewünschte Java-Version aus.

Quelle: https://tipandtech.wordpress.com/2013/09/13/error-project-facet-Java-version-1-7-is-not-supported-in-Eclipse/

Probieren Sie sie aus, wenn Sie die Lösung noch nicht gefunden haben.

Shishir

4
Shishir Kumar

Ich hatte gerade das Gleiche. Meine Lösung bestand darin, die 1.6 JRE in Installed JREs zu entfernen und die Java 1.7-Version anzukreuzen.

Diese finden Sie in Window -> Preferences -> Java -> Installierte JREs

So wie Boopathi sagt.

3
Allan D

Doppelklicken Sie auf den Tomcat-Server-> Laufzeitumgebung-> installierte jre-> wählen Sie jdk 1.7 aus

2
user2369634

Überprüfen Sie die Version des JDK in Window -> Preferences -> Java-Compiler, und legen Sie das gleiche JDK in Window -> Preferences -> Project Facets -> Java fest

0
Anand Kumar

1.Windows-Menü -> Voreinstellungen 2.Wählen Sie links Server -> Laufzeitumgebungen 3.Highlight Den gewünschten Server für Ihr Projekt und klicken Sie auf die Schaltfläche "Bearbeiten" 4. Ändern Sie im Dialogfeld "Server-Laufzeitumgebung bearbeiten" die JRE in Java 7 JDK oder JRE . 5.Rebuild Ihr Projekt, und der Fehler sollte verschwinden.

0
Akshay Salvi

Ändern Sie die JRE, auf die Ihr Server verweist (Tomcat oder irgendetwas)

0
Vivek