webentwicklung-frage-antwort-db.com.de

Netbeans 8.0.2 Das Modul wurde nicht bereitgestellt

Ich habe gerade netbeans installiert und habe Probleme mit der Bereitstellung einer neuen Java Web App. Ich erstelle einfach das Projekt, ohne irgendetwas zu bearbeiten.

index.html

<!DOCTYPE html>
<!--
To change this license header, choose License Headers in Project Properties.
To change this template file, choose Tools | Templates
and open the template in the editor.
-->
<html>
<head>
    <title>TODO supply a title</title>
    <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
</head>
<body>
    <div>TODO write content</div>
</body>
</html>

Die Fehler:

init:
deps-module-jar:
deps-ear-jar:
deps-jar:
library-inclusion-in-archive:
library-inclusion-in-manifest:
compile:
compile-jsps:
In-place deployment at C:\Users\2kGamer\Dropbox\Projects\Java\NetBeans\DAW 2\WebApplication1\build\web
Deployment is in progress...
deploy?config=file%3A%2FC%3A%2FUsers%2F2kGamer%2FAppData%2FLocal%2FTemp%2Fcontext4402830100786872488.xml&path=/WebApplication1
 http://localhost:8084/manager/text/deploy?config=file%3A%2FC%3A%2FUsers%2F2kGamer%2FAppData%2FLocal%2FTemp%2Fcontext4402830100786872488.xml&path=/WebApplication1
C:\Users\2kGamer\Dropbox\Projects\Java\NetBeans\DAW 2\WebApplication1\nbproject\build-impl.xml:1045: The module has not been deployed.
See the server log for details.
BUILD FAILED (total time: 51 seconds)



build-impl.xml:1045 
<target if="netbeans.home" name="-run-deploy-nb">
    <nbdeploy clientUrlPart="${client.urlPart}" debugmode="false" forceRedeploy="${forceRedeploy}"/>
</target>
3
Alpha2k

UPDATE: Dies wurde durch einen Neustart behoben, aber beim Ausführen der App ist ein anderer Fehler aufgetreten. Dieses Mal wurde Tomcat gestartet. Um dies zu beheben (Fehler mit der neuesten Apache- und Netbeans-Version), folgen Sie diesen Anweisungen: Fehler beim Starten von Tomcat über NetBeans - '127.0.0.1 *' wird nicht als interner oder externer Befehl erkannt

0
Alpha2k

Ich hatte ab und zu das gleiche Problem. So löse ich das Problem, es wirkt für mich wie ein Zauber! 

  1. Gehe zu 'Task Manager'
  2. Wählen Sie die Registerkarte "Prozesse"
  3. Klicken Sie auf "Java (TM) Platform SE Binary". 
  4. Klicken Sie auf die Schaltfläche "Prozess beenden"
  5. Gehen Sie zu Ihrem NetBeans-Projekt
  6. Reinigen und bauen Sie das Projekt
20
justrandom

Manchmal geschieht dies, weil einige Bibliotheken, die Sie in Ihren Code einfügen, nicht hinzugefügt werden. Überprüfen Sie alle von Ihnen verwendeten Bibliotheken.

So fügen Sie eine neue Bibliothek in netbean hinzu:

  • Klicken Sie mit der rechten Maustaste in den Bibliotheksordner.
  • Klicken Sie auf Bibliothek hinzufügen.
  • Wählen Sie die gewünschte Bibliothek in Verfügbare Bibliotheken aus, oder importieren Sie sie aus Globalen Bibliotheken (klicken Sie auf die Schaltfläche Importieren).
  • Klicken Sie abschließend auf Bibliothek hinzufügen, um sicherzustellen, dass Ihre Bibliothek hinzugefügt wird.
0
jomitame

Ich hatte den gleichen Fehler hier aber mit Glassfish Server. Vielleicht kann es helfen. Ich musste die Datei glassfish-web.xml mit dem Inhalt im <resources> von glassfish-resources.xml konfigurieren. Als ich einen weiteren Fehler erhielt, konnte ich diese Anmerkung im Serverprotokoll finden:

Ursache: Java.lang.RuntimeException: Fehler beim Analysieren von WEB-INF/glassfish-web.xml für Archiv [Datei:/C:/Users/Win/Documents/NetBeansProjects/svad/build/web /]: Das xml-Element sollte angezeigt werden sei [glassfish-web-app] und nicht [Ressourcen]

Ich habe dann nur das <resources>-Tag geändert und <glassfish-web-app> in der Datei glassfish-web.xml angewendet.

0

In meinem Fall hatte ich eine neue Version von Netbeans installiert und ein Upgrade von Java 7 auf 8 vorgenommen. Die neuen Netbeans hatten eine andere Version von Glassfish. Daher habe ich die Eigenschaften meines Projekts geöffnet, auf die richtige Glassfish-Version verwiesen und den Jdk-Wert auf Jdk gesetzt Version 8.

0
Fred