webentwicklung-frage-antwort-db.com.de

ändern des Eclipse-Java-Compilers in jdk 7

Ich versuche, ein Upgrade von jre6 und jdk6 auf jre7 und jdk7 durchzuführen. Ich programmiere Eclipse. Ich habe jre7 und jdk7 heruntergeladen und installiert: C:\Programme\Java\ jetzt, wenn ich Eclipse eingebe, möchte ich den verwendeten Compiler ändern, also gehe ich zu: Fenster> Voreinstellungen> Java> Compiler , aber es erscheinen nur 1.3.1.4.1.5 und 1.6 Ich habe auch Folgendes eingegeben: Fenster> Einstellungen> Java> Installierte JREs Und fügte die jre7-Version hinzu. Aber den Compiler kann ich nicht ändern. Wie ändere ich meinen Eclipse-Compiler?

9
tomermes

Sie müssen ein Upgrade auf mindestens Eclipse Indigo SR1 durchführen, das seit über einem Monat ausfällt. Siehe auch Eclipse kündigt volle Unterstützung für Java 7 an .

Als Beweis ist hier ein Bildschirm mit meinen Vorlieben für Indigo SR1:

enter image description here

Und hier ist ein Beispiel eines ausführbaren Code-Snippets mit Diamond Operator und ARM:

enter image description here

14
BalusC

Sie benötigen eine neuere Version von Eclipse. Mindestens 3.7SR1.

3
bmargulies

3.6 Die Eclipse-Version reicht aus. Ich verwende dasselbe mit JDK1.7

0
Shruthi S