webentwicklung-frage-antwort-db.com.de

dyld: dyld_sim nicht kompatibel mach-o

Ich habe Xcode 9 installiert und versucht, meine App auf ios simulator 11.0 auszuführen. Sobald die App gestartet wird, stürzt sie ab und gibt diesen Fehler aus. Was bedeutet dieser Fehler? Wie kann ich die Kompatibilität überprüfen, wenn meine App nicht mit ios11.0 kompatibel ist?

[~ # ~] edit [~ # ~] - Meine gültigen Architekturen wurden hochgeladen

enter image description here

enter image description here

32
nOOb iOS

Sie müssen diese Änderungen in build setting Vornehmen ... es funktioniert für mich enter image description here

53
Abhishek Mishra

Ich hatte das gleiche Problem und stellte fest, dass die Architekturen und gültigen Architektureinstellungen für meine Ziele (und Pods) falsch eingestellt waren. iOS 11 unterstützt keine 32-Bit-Anwendungen mehr. Ich schätze, das hat an meinem Problem mitgewirkt.

Ich habe meine Architekturen + gültige Architektureinstellungen gelöscht (als Standard festgelegt) und jetzt wird es sowohl im Simulator als auch auf dem iOS 11-Gerät ordnungsgemäß kompiliert und ausgeführt. hoffe es hilft dir auch;).

6
DaTa