webentwicklung-frage-antwort-db.com.de

Cocoapods: Es wurde keine Spezifikation für `Firebase/Core` gefunden

Ich habe das in podfile:

pod 'Firebase/Core'
pod 'Firebase/Messaging'

aber diesen Fehler bekommen:

[!] Spezifikation für Firebase/Core konnte nicht gefunden werden

ich versuchte es mit pod 'Firebase' noch immer nicht.

Poddatei:

# Uncomment this line to define a global platform for your project
# platform :ios, '8.0'
# Uncomment this line if you're using Swift
use_frameworks!

target 'caffetouch manager' do
    pod 'Firebase/Core'
    pod 'Firebase/Messaging'
    pod 'Alamofire', '~> 4.0.0'
    pod 'AlamofireNetworkActivityIndicator', '~> 2.0.1'
    pod 'IQKeyboardManagerSwift', '~> 4.0.6'
    pod 'MZFormSheetPresentationController', '~> 2.4.2'
    pod 'Kingfisher', '~> 3.1.3'
    pod "GMStepper"
    pod 'DKImagePickerController', '~> 3.4.0'
    pod 'Siren', '~> 1.0.2'
    pod 'Eureka', '~> 2.0.0-beta.1'
    pod 'SwiftyJSON'
    pod 'ObjectMapper', '~> 2.1'
    pod 'NVActivityIndicatorView'
    pod 'SwiftDate', '~> 4.0.5'
    pod 'SimpleAlert' '~> 2.0.1'

    pod 'BTNavigationDropdownMenu', :git => 'https://github.com/PhamBaTho/BTNavigationDropdownMenu.git', :branch => 'Swift-3.0'
    pod 'ENSwiftSideMenu', :git => 'https://github.com/evnaz/ENSwiftSideMenu.git', :branch => 'master'
    pod 'SkyFloatingLabelTextField', git: "https://github.com/MLSDev/SkyFloatingLabelTextField.git", branch: "Swift3"
end


post_install do |installer|
  installer.pods_project.targets.each do |target|
    target.build_configurations.each do |config|
      config.build_settings['Swift_VERSION'] = '3.0'
    end
  end
end
23
Mirza Delic

Versuchen Sie, das Pod-Repository zu aktualisieren 

pod repo update

Wenn das Protokoll nicht angezeigt wird

pod install --verbose

Bearbeiten:

versuchen Sie hinzuzufügen

source 'https://github.com/CocoaPods/Specs.git'

in dein Podfile. Wenn es nicht hilft, gibt es wahrscheinlich ein Problem mit Ihrem lokalen Repo. Sie können dies beheben mit: 

pod repo remove master
pod setup
pod install
56
Piotr Labunski

versuchen Sie die folgenden Befehle:

pod repo remove master
pod repo update
pod install --verbose
2
Rajesh.k

Prüfen Sie, ob Ihre Poddatei so aussieht, und führen Sie dann pod install aus:

platform :ios, '10.0'
use_frameworks!

target '<YOUR APP TARGET>' do

  # Firebase
  pod 'Firebase'
  pod 'Firebase/Core'
  pod 'Firebase/Messaging'

end

post_install do |installer|
  installer.pods_project.targets.each do |target|
    target.build_configurations.each do |config|
      config.build_settings['Swift_VERSION'] = '3.0'
    end
  end
end
1
ronatory

versuchen Sie, die Datei podfile.lock zu löschen. 
es hilft bei der Ausgabe:

[!] CocoaPods konnte keine kompatiblen Versionen für den Pod .__ finden. "Firebase/Kern": 
In Momentaufnahme (Podfile.lock): 
Firebase/Kern (= 4.8.1)

0
Yoni Katz

hatte das gleiche problem. 

was für mich wirklich funktionierte, war gem uninstall cocoapods, wo ich 11 (!) Cocoapods-Versionen hatte. Ich habe mich entschieden, alles zu deinstallieren und dann gem install cocoapods:1.4.0

Alles gut jetzt.

0
Catarino

Wenn es immer noch nicht funktioniert, entfernen Sie das Cocoapods-Verzeichnis rm -rf ~/.cocoapods und richten Sie die Cocoapods mit pod setup erneut ein. 

Hoffentlich hilft das

0
Ajitpaulm

Dies funktionierte für mich durch die Aktualisierung von Cocoapoden und meines Pod-Repos:

Sudo gem install cocoapods
pod repo update
0
steve-o

Keiner der genannten Ansätze funktionierte für mich. Ich habe es jedoch so gemacht, dass es funktioniert:

  1. Kommentieren Sie alle Ihre Pods in Ihrer Podfile aus. 
  2. Kommentieren Sie sie nacheinander in Und führen Sie nach jedem pod install aus
  3. Reinige und renne

Ich hoffe es hilft jemandem. 

0
AbbasAngouti