webentwicklung-frage-antwort-db.com.de

Ionic-Fehler der niedrigeren Version von Cordova - Installieren Sie Ihre Cordova-CLI auf Version> = 4.2.0

Ionic erfolgreich installiert. Beim Ausführen von ionischen Informationen und anderen Befehlen wie dem ionischen Browser - List wird die Fehlermeldung angezeigt, dass Cordova niedriger ist als Version 4. 

Cordova wird ohne Sudo und im globalen Home-Verzeichnis installiert. 

> ionic info

Your system information:

Cordova CLI: 6.1.0 ([email protected])
Gulp version:  CLI version 3.9.1
Gulp local:   Local version 3.9.1
Ionic Version: 1.2.4
Ionic CLI Version: 1.7.14
Ionic App Lib Version: 0.7.0
OS: Distributor ID:     Ubuntu Description:     Ubuntu 15.10 
Node Version: v5.9.1


******************************************************
 Dependency warning - for the CLI to run correctly,      
 it is highly suggested to install/upgrade the following:     

 Please install your Cordova CLI to version  >=4.2.0 `npm install -g cordova`

******************************************************

Die Installation von Cordova erfolgt in:

> which cordova
  /home/user_1/.npm-global/bin/cordova

Ionische Installation ist an:

> which ionic
/home/user_1/.npm-global/bin/ionic
27
elpddev

Ich habe viele verschiedene Methoden ausprobiert, um dieses Problem zu beheben, z. B. mit und ohne die --unsafe-perm=true --allow-root-Flags neu zu installieren (andere rieten daher, andere Fragen/Orte online zu beheben), aber es scheint ein Problem mit Cordova in Version 6.1 zu sein .0 und ionic verwenden also 6.0.0, indem sie ausgeführt werden 

npm install -g [email protected]

Das sollte den Trick tun, da es scheint, dass 6.1.0 keine stabile Version ist.

32
garrettmac

Ich verwende auch [email protected] und [email protected] Nachdem ich diese Fehlermeldung erhalten hatte, öffnete ich ein neues Terminal und gab cordova -v ein, der Folgendes ausgab:

? May Cordova anonymously report usage statistics to improve the tool over time?

Sobald ich meine Antwort (No) eingegeben habe, wird die Versionsnummer ausgedruckt und dann ionic info in meinem Projektterminal erneut ausgeführt. Der Fehler war weg.

Vorsichtsmaßnahmen

  • Ich hatte gerade [email protected] von 1.7.15 aktualisiert. Es ist ein sehr kleiner Patch mit einer Reihe von Fehlerkorrekturen, die nicht damit zusammenhängen.
  • Das spezielle System, mit dem ich dieses Problem hatte, läuft unter Windows 10.
  • Beim ersten Ausführen von ionic info in meinem Projektverzeichnis erhielt ich zweimal den gleichen Fehler.

Ursprüngliche Fehlerausgabe:

******************************************************
 Dependency warning - for the CLI to run correctly,
 it is highly recommended to install/upgrade the following:

 Please install your Cordova CLI to version  >=4.2.0 `npm install -g cordova`

******************************************************

Your system information:

You have been opted out of telemetry. To change this, run: cordova telemetry on.
6.2.0

Gulp version:  CLI version 3.9.1
Gulp local:   Local version 3.9.1
Ionic CLI Version: 1.7.16
Ionic App Lib Version: 0.7.3
OS:
Node Version: v4.4.2


******************************************************
 Dependency warning - for the CLI to run correctly,
 it is highly recommended to install/upgrade the following:

 Please install your Cordova CLI to version  >=4.2.0 `npm install -g cordova`

******************************************************
54
Wayne Bloss
cordova telemetry off

Fehler beim Laufen verschwinden lassen 

ionic info

Ich habe mich für die Telemetrie entschieden, die während der Entwicklung Daten für die Analyse erfasst. Sie können sich auch anmelden, indem Sie stattdessen das Schlüsselwort "on" verwenden.

Hat Tipp an Wayne Bloss, dass er mich zu dieser Antwort geführt hat.

15
Martin Carstens

Ich hatte genau das gleiche Ergebnis wie Wayne Bloss unter Windows 10. Der Fehler "> = 4.2.0" beim ersten Versuch, und nachdem ich die Version "cordova -v" überprüft hatte, war der Fehler verschwunden (ich habe die Frage mit "Ja" beantwortet Statistiken).

9
Don_Diego

Wie von Wayne Bloss festgestellt, verschwindet diese Warnung bei Beantwortung der Frage, die durch den Befehl cordova -v ausgelöst wird. Dies funktionierte auch für meine Konfiguration mit Cordova 6.3.1. 

Dies funktioniert, weil der ursprüngliche Grund dafür ist, dass die Versionsinformationszeichenfolge für die Cordova-CLI nicht nur die Versionsnummer enthält, sondern auch diese Information "Sie wurden von der Telemetrie abgemeldet. was bedeutet, dass die interne Auswertung des Strings mit semver return immer falsch ist. Bei Beantwortung der Telemetrie-Frage mit "Nein" wurde der String aus der Version entfernt, wodurch die Warnmeldung ausgeblendet wurde.

4
fred_online

Ich bin gerade auf diese Seite gestoßen, also habe ich diese Seite gefunden und scheint keine richtige Antwort zu finden. Hier ist eine.

Um das cordova-cli deb-Paket zu installieren, müssen Sie Folgendes tun:

  • Fügen Sie das Ubuntu Cordova Personal Package-Archiv Ihrem Ubuntu-System hinzu
  • Installieren Sie das cordova-cli-Paket (und seine Abhängigkeiten).

Also für ubuntu

Sudo apt-add-repository ppa:cordova-ubuntu/ppa
Sudo apt-get update
Sudo apt-get install cordova-cli

Weitere Informationen erhalten Sie hier https://cordova.Apache.org/docs/de/latest/guide/platforms/ubuntu/index.html

3
Marko

Wie andere festgestellt haben , ist eine mögliche Ursache das Rauschen der Cordova-Telemetrie.

Das Problem ist in Cordova 6.5.0 und Ionic 2.2.2 noch vorhanden.

Als zusätzliche Information möchte ich hinzufügen, dass Folgendes ausgeführt werden muss für den aktuellen Benutzer, z. Wenn Sie über ein CI-System verfügen, das Cordova als Root installiert und dann als nicht-privilegierter Benutzer ionic ausführt, müssen Sie es ausführen

cordova telemetry off

nochmal.

1
ValarDohaeris

Es ist gut in die Einschränkung geschrieben, Sie müssen cordova in Ihrem npm installieren mit npm install -g cordova oder

npm install -g [email protected]

Problem gelöst!

0
Lucy Pham
D:\>ionic start myapp blank
******************************************************
 Dependency warning - for the CLI to run correctly,
 it is highly recommended to install/upgrade the following:

 Please install your Cordova CLI to version  >=4.2.0 `npm install -g cordova`

******************************************************
Creating an Ionic app in D:\myapp based on the blank template.

Downloading: https://github.com/driftyco/ionic-app-base/archive/master.Zip
Downloading: https://github.com/driftyco/ionic-starter-      blank/archive/master.Zip
Installing npm packages (may take a minute or two)...
/
? ♫ ? ♫  Your Ionic app is ready to go! ? ♫ ? ♫

Die Anwendung Ionic wird gestartet, ohne dass Cordova aktualisiert wird. Sie können jedoch folgenden Code zum Aktualisieren verwenden:

npm update -g cordova
0
Hirak JD