webentwicklung-frage-antwort-db.com.de

Paket in MELPA aufgeführt, aber nicht in der Paketinstallation enthalten

Ich versuche gerade, ENSIME für emacs 24.3.1 zu installieren, indem ich die Anweisungen unter https://github.com/ensime/ensime-emacs unter dem Schnellstart befolge. Ich habe hinzugefügt 

    (require 'package)
    (add-to-list 'package-archives
             '("melpa" . "http://melpa.milkbox.net/packages/") t)
    (package-initialize)

(when (not package-archive-contents)
  (package-refresh-contents))

in meine .emacs-Datei, wie angewiesen. Wenn ich jedoch das M-x-Paket installiere [RETURN] ensime [RETURN], starte ich [No Match] zurück, und ich kann es nicht finden, wenn ich die Pakete aufliste. Ich kann es jedoch leicht unter http://melpa.milkbox.net/# finden; Was würde die Diskrepanz zwischen dem, was über die Website verfügbar ist, und dem Zeitpunkt, an dem von emacs installiert werden kann, verursachen?

Jede Hilfe wird sehr geschätzt; Vielen Dank!

48
user2187656

In meiner .emacs-Datei habe ich

;; packages
(when (>= emacs-major-version 24)
  (require 'package)
  (package-initialize)
  (add-to-list 'package-archives '("melpa" . "http://melpa.milkbox.net/packages/") t)
  )

Dann M-x package-list-packages

C-s ensime

und los gehts:

ensime 20140718 .... verfügbar Enhanced Scala Interaction Mode für Emacs

Sind Sie sicher, dass Ihre Emacs tatsächlich Zugang zum Internet erhalten können?

36
Vic Nmkf

Ich musste M-x package-refresh-contents ausführen. Sobald ich das getan hatte, wurden die Dateien gefunden.

So sieht mein .emacs aus:

(cond
 ((>= 24 emacs-major-version)
  (require 'package)
  (package-initialize)
  (add-to-list 'package-archives
           '("melpa-stable" . "http://stable.melpa.org/packages/") t)
  (package-refresh-contents)
 )
)
82
Scott A

Nach der üblichen Bearbeitung von .emacs, um melpa verfügbar zu machen, und Emacs neu zu starten, durchsuchte ich die Liste der Pakete nach dem gewünschten Paket.

M-x package-list-packages
C-s <package_name>

Dann klickte ich auf den Namen des Pakets und drückte die Installationstaste. Ich bin nicht sicher, warum M-x package-install RET <package_name> fehlgeschlagen ist, aber das Klicken auf die Schaltfläche "Installieren" funktionierte für mich.

7
Kevin Tindall

In meinen Spacemacs, Paket herunterladen, Fehler !!! Also google ich meine Lösung Hier habe ich das Methodenformular gefunden Download Zip-Datei mit FTP-Browser (für mich Chrome-Browser)

http://ftp.gnu.org/gnu/emacs/windows/emacs-25-x86_64-deps.Zip

entpacke diese Datei und kopiere und füge sie in den bin-Ordner für emacs ein (siehe Bild) copy and paste wie folgt

Einen schönen Tag noch!!!

0
Jeongpyo Lee