webentwicklung-frage-antwort-db.com.de

In WordPress kann kein altes Datum ausgewählt werden

Ich kann das Jahr nicht unter 1899 für einen Posten festlegen. Wenn ich ein Jahr unter 1899 einstelle, wird es automatisch auf das aktuelle Jahr eingestellt.

screen shot

Ich habe das Timeline Theme gekauft und im Support-Forum nachgefragt. Sie antworteten:

Dies klingt wie eine Einschränkung, die von Ihrem Hosting-Anbieter erstellt wurde. Nichts in dem Thema verhindert das Datum, das Sie zuweisen - wie Sie sehen, hat die Demo Beiträge mit Datumsangaben in den 1400er Jahren. Wenden Sie sich an Ihren Hosting-Anbieter, und prüfen Sie, ob dieser weiß, wie er das angehen kann.

12
Spartans

Dies ist keine wirkliche Antwort, sondern nur ein Versuch, den spezifischen Kontext für dieses Problem zu finden. Bitte installieren Sie das folgende Plugin auf Ihrer Site, versuchen Sie, die drei Daten festzulegen und fügen Sie Ihr Ergebnis zum zweiten <pre> in der folgenden Tabelle hinzu.

/* Plugin Name: WPSE Sysinfo */
add_action( 'admin_footer', 'wpse_sysinfo' );
function wpse_sysinfo() {

    $bit         = 4 === PHP_INT_SIZE ? 32 : 64; // PHP version, not OS!
    $php_version = PHP_VERSION;
    $db_version  = $GLOBALS['wpdb']->db_version();

    print "<pre>$bit | $php_version | $db_version</pre>";
}

Der Kern des Plugins kann hier ausgecheckt werden .

 OS | OS-Bit | PHP | PHP Bit | MySQL | 999 | 1899 | 2020 | 2039 | Nutzer
 WIN7 | 64 | 5.4.4 | ?? | 5.5.25 | ✘ | ✘ | ✔ | ✘ | toscho 
 Linux | ?? | 5.3.18-nmm1 | ?? | 5.1.70 | ✔ | ✔ | ✔ | ✔ | toscho 
 CentOS 6 | 64 | 5.5.4 | ?? | 5.0.95 | ✔ | ✔ | ✔ | ✔ | toscho 
 WIN7 | 64 | 5.4.15 | 32 | 5.5.31 | ✘ | ✘ | ✔ | ✘ | rarst 
 Ubuntu 12.04 | 64 | 5.3.10-1 | 64 | 5.5.32 | ✔ | ✔ | ✔ | ✔ | Pille 
 CloudLinux | 64 | 5.2.17 | 64 | 5.0.96 | ✔ | ✔ | ✔ | ✔ | Pille 
 Ubuntu 12.10 | 64 | 5.4.6 | 64 | 5.5.32 | ✔ | ✔ | ✔ | ✔ | Michael Ecklund 
 CENTOS 5.9 | 32 | 5.3.27 | 32 | 5.5.32 | ✘ | ✘ | ✔ | ✘ | Michael Ecklund 
 WIN7 | 64 | 5.4.7 | 64 | 5.5.27 | ✘ | ✘ | ✔ | ✘ | kaiser 
 OSX 10.7.5 | 64 | 5.3.6 | 64 | 5.5.9 | ✔ | ✔ | ✔ | ✔ | GhostToast 
 Centos 6.4 | 64 | 5.4.17 | 32 | 5.1.59 | ✘ | ✘ | ✔ | ✘ | birgire 
 Debian 6 | 64 | 5.4.19 | 64 | 5.1.66 | ✘ | ✘ | ✔ | ✘ | birgire 
 WIN7 | 64 | 5.5.0 | 64 | 5.5.22 | ✘ | ✘ | ✔ | ✘ | G.M. 
 OSX 10.7.4 | 64 | 5.3.6 | 64 | 5.5.9 | ✔ | ✔ | ✔ | ✔ | brasofilo 
 CentOS 5 | 64 | 5.3.22 | 64 | 5.1.68 | ✔ | ✔ | ✔ | ✔ | brasofilo 
 Mac 10.8.5 | 64 | 5.3.26 | 64 | 5.5.25 | ✔ | ✔ | ✔ | ✔ | flentini 
 WIN7 | 64 | 5.3.27 | 64 | 5.5.31 | ✔ | ✔ | ✔ | ✔ | Sascha Krause 
 Win7SP1 | 64 | 5.3.8 | 64 | 5.5.28 | ✔ | ✔ | ✔ | ✔ | Manuel Sychold 
  1. Erstelle einen neuen Beitrag. Speichern Sie es.
  2. Setzen Sie das Datum auf den 1. Januar, 0999, klicken Sie auf Aktualisieren . Wird es gespeichert oder auf das aktuelle Datum geändert?
  3. Wiederholen Sie dies für die Datumseinstellungen für 1899, 2020 und 2039.
  4. Übernehmen Sie die Informationen aus der Plugin-Ausgabe in Ihrer Admin-Fußzeile und aktualisieren Sie die Tabelle.
10
fuxia