webentwicklung-frage-antwort-db.com.de

Visual Studio Code-Farbauswahl

Ich liebe Visual Studio Code, aber meiner Meinung nach fehlt etwas.
.__ Eine Farbauswahl. 
Weiß jemand, ob es eine Farbauswahl für visuellen Studio-Code gibt, genau wie im visuellen Studio?

13
Justin Breg

Die Erweiterung Color Picker funktioniert zwar, aber Sie müssen Node.Js von dieser Website installieren . Beachten Sie außerdem, dass beim ersten Versuch, das Plugin zu verwenden, eine Erstkonfiguration vorgenommen wird, die einige Minuten dauert.

9
Mia

In Version 1.15.1 wurde eine Farbauswahl hinzugefügt.

https://code.visualstudio.com/updates/v1_15#_color-picker

18
Modig

Ich weiß, dass es ein etwas altes Thema ist, aber es kann jemandem helfen. Um die Farbauswahl zum Laufen zu bringen, müssen Sie, wie von Mia erwähnt, Node.js installieren und zu $ ​​PATH hinzufügen. Während der Installation werden Sie gefragt, ob Sie sowohl Node.js als auch NPM (Node Package Manager) zu PATH hinzufügen möchten.

Wenn der Picker immer noch nicht funktioniert, gibt es 3 Einstellungen (Zitat aus der offiziellen Beschreibung):

  1. Wenn das Dialogfeld nicht korrekt angezeigt wird, setzen Sie colorHelper.disableGpu auf 1.
  2. Wenn das noch nicht gelöst ist, setzen Sie colorHelper.disableShadow auf true.
  3. Wenn das noch nicht gelöst ist, setzen Sie colorHelper.disableTransparent auf true.

Für mich Setzen von colorHelper.disableTransparent auf true hat das Problem behoben. colorHelper.disableGp und colorHelper.disableShadow haben die Standardeinstellung verlassen.

Um zu diesen Einstellungen zu gelangen, drücken Sie Strg +,

1
Padzonk

VSCode hat leider keine Farbauswahl.

Es hat eine Farbvorschau für CSS (siehe: https://code.visualstudio.com/Docs/languages/css ) und ein sehr robustes Erweiterungssystem.

Ein Feature wie dieses kann in der Zukunft hinzugefügt werden, oder jemand kann eine Erweiterung erstellen, aber im Moment müssen Sie Ihre Farben an anderer Stelle auswählen.

1
Tobiah Zarlez

Ja, das fehlt wirklich in VScode (unter anderem ...) ... Es gibt diese Erweiterung aber leider scheint es nicht zu funktionieren - ich habe es auch versucht ...

0
Gilad Barner