webentwicklung-frage-antwort-db.com.de

Windows Store-App kann nicht aktiviert werden. Die App wurde nicht gestartet

Zunächst möchte ich sagen, dass ich bereits alle Lösungen ausprobiert habe, die ich im Internet finden konnte, einschließlich Windows Store App kann nicht aktiviert werden

Ich habe kürzlich meinen Windows 7-Computer auf Windows 8.1 aktualisiert, um Windows Store-Apps mit Visual Studio 2013 entwickeln zu können. Wenn ich ein leeres Projekt (Windows Store -> Blank App) öffne und ausführen, erhalte ich diesen Fehler:

Die Windows Store-App 'Paketname' kann nicht aktiviert werden. Die App1.exe Der Prozess wurde gestartet, aber die Aktivierungsanforderung schlug fehl mit dem Fehler 'Die App hat nicht angefangen '.

In der Hilfe finden Sie Hinweise zur Fehlerbehebung.

Ich habe es schon versucht:

  • Neuinstallation von Windows (saubere Installation)
  • Neuinstallation von Visual Studio 2013
  • Installieren von Visual Studio 2012 (gleicher Fehler)
  • Ordner "bin" und "obj" löschen
  • Lösung reinigen
  • Deinstallation der App über das Startmenü
  • Ein neues Projekt erstellen
  • Mehrfacher Erwerb der Lizenz (die Lizenz ist gültig)
  • Stellen Sie sicher, dass app.config nicht vorhanden ist
  • Untersuchung des Windows-Ereignisprotokolls, das besagt

Die Aktivierung der App 'Paketname' für den Windows.Launch-Vertrag ist mit einem Fehler fehlgeschlagen: Die App wurde nicht gestartet.

fand aber nichts sinnvolles

  • Einen neuen Windows-Benutzer hinzufügen
  • Führen Sie alles als Administrator aus
  • und zuletzt den Desktop-Hintergrund ändern :)

Nichts davon brachte eine Lösung. Hat jemand eine Idee, was sonst der Grund für diesen Fehler sein könnte?

Vielen Dank.

24
msa

Ich habe eine Lösung gefunden. Das Problem war, dass das Laufwerk, an dem ich arbeitete, verschlüsselt war (TrueCrypt). Durch das Verschieben des Ausgabeordners auf ein unverschlüsseltes Laufwerk wurde das Problem behoben.

13
msa

Ich hatte den gleichen Fehler und habe nach dem Laden des SQLite-Pakets für WP 8.1 einige Dinge oben versucht:

funktioniert nicht:

  • Reinigen und neu aufbauen
  • Computer/Telefon neu starten

was hat der Deal (für mich)

  • Ich habe Platform Target unter Properties -> Build inARManstelle von x86

Hoffentlich kann dies jemand anderen helfen, der sich dieser lächerlich informativen Fehlermeldung stellt.

9
user3079834

Wenn Sie von x86 zu x64 wechseln, stellen Sie sicher, dass für Ihr Project Properties Platform-Ziel und die Configuration Platform beide auf X64 eingestellt sind. Sie müssen im Debugging-Menü Build/Configuration Manager in x64 debuggen, um die Configuration Platform in Project Properties zu aktualisieren.

Dadurch wurde das Aktivierungsfehlerproblem für mich gelöst

HTH

Robert

4
Robert

Ich hatte das gleiche Problem mit Visual Studio Community 2015, als ich versuchte, eine leere App (Universal Windows) mit Visual C # zu debuggen.

Visual Studio wurde auf Datenträger C: (SSD) installiert, und Projektdateien wurden auf D: (HDD) abgelegt. Ich habe einen Ordner auf C: Drive erstellt und mein Testprojekt dort abgelegt . Danach sind Fehlermeldungen verschwunden.

4
AlexBaker

Wenn Sie diese Fehlermeldung erhalten und für Microsoft Hololens entwickeln:

Sie versuchen, auf einem schlafenden Gerät zu bauen. Um Ihr Gerät zu wecken, tippen Sie auf die Schaltfläche auf der Rückseite (Ein/Aus-Taste).

Viel Glück!

3

Ich habe alle Lösungen aus dem Netz ausprobiert und keine für meinen Fall angewendet, auch nicht für diese.

Die einzige Möglichkeit, wie ich es schaffen konnte, bestand darin, den Paketnamen im appxmanifest zu ändern. Dies veranlasste mich zu der Meinung, dass irgendwo ein paar Reste mit dem alten Paketnamen vorhanden sein sollten, die entweder beschädigt sind oder aufgrund von Berechtigungsproblemen nicht zugänglich sind.

Es könnte nur ein Zufall sein, aber das Problem trat zweimal auf, nachdem ich es mit dem App Verifier (appverif.exe) versucht hatte.

Jetzt habe ich meine App einem Store-App-Paket zugeordnet und die Dinge scheinen weiterzuarbeiten ...

2
Maurizio Manca

Ich hatte das gleiche Problem in Visual Studio 2015 Update 3, Windows 10 Build 10586.494.

Beim Starten von any UWP-App, die ich ohne .NET Native Toolchain kompiliert habe, ist der Fehler aufgetreten. Wenn die native Toolchain aktiviert ist, werden die Apps gestartet.

Durch die manuelle Installation einer neuen (leeren) App wurde der Fehler für mich behoben:

  • Starten Sie VS 2015
  • Datei> Neu> Projekt.
  • Leere App (Universal Windows) Visual C #. OK.
  • Stellen Sie sicher, dass Sie sich in der Debug-Konfiguration befinden
  • Klicken Sie mit der rechten Maustaste auf Projekt> Store> App-Pakete erstellen
  • Nein. Weiter.
  • Wählen Sie für alle Architekturen Debug.
  • Erstellen
  • Wenn das Packen abgeschlossen ist, öffnen Sie den Explorer mit dem Projektpfad/AppPackages/[...] _ Debug_Test
  • Klicken Sie mit der rechten Maustaste auf Add-AppDevPackage.ps1> Mit PowerShell ausführen
  • Folge den Anweisungen
  • Starten Sie die installierte App über das Startmenü
1

In meiner Lösung habe ich ein Nicht-UWP-Projekt (Multiplatform-Entwicklung), das mit einer anderen Lösungsplattform erstellt wird. 

Ich habe versucht, das UWP-Projekt in Debug auszuführen, jedoch als falsche Lösungsplattform.

Edit: Ich bekomme dies auch, wenn ich mein Projekt für Any-CPU an Stelle von x64 baue.

1
Jarryd

Ich hatte das gleiche Problem mit einer Windows Store-App, nachdem ich einige Dateien verschoben hatte. Am Ende habe ich eine ältere Datei (als Admin) geöffnet, um zu sehen, ob sie ausgeführt werden würde, und habe festgestellt, dass sie es tat. Ich kehrte dann zu der Datei zurück, die dies nicht tun würde und lief auch. Ich glaube, das Öffnen der älteren Datei (als Admin) setzt die Pfade für die Entwicklung und die Berechtigungen zurück. Hoffe das hilft.

0
FRP

Ich hatte das gleiche Problem. Die Auswahl der richtigen Plattform hat mein Problem gelöst. Meine Anwendung wurde für die Ausführung unter x86-Plattform ausgewählt, während mein Betriebssystem und SDK x64 unterstützen. Die Auswahl von x64 hat mein Problem gelöst.

0
DSA

Stellen Sie sicher, dass ALL APPLICATION PACKAGES Berechtigungen für C:\Windows "gelesen" hat.

Die Gruppenrichtlinie meiner Organisation entfernt gerne alle Berechtigungen von C:\Windows, einschließlich der Gruppe ALL APPLICATION PACKAGES. Indem ich es wieder hinzufüge und Read & execute, List folder contents und Read setze, kann ich die App problemlos aus Visual Studio ausführen.

Weitere Informationen hierzu finden Sie unter Was tun, wenn die Windows 8 Modern App nicht startet.

0
Douglas Ludlow

Ich hatte ein ähnliches Problem, das durch die Wahl eines neuen Publisher-Zertifikats gelöst wurde. Und natürlich einen Neustart von Windows

0
Mina Samy

Ich hatte vor ein paar Wochen das gleiche Problem. Ein einfacher Neustart hat mir geholfen.

Auch versucht dieses ?: http://irisclasson.com/2012/11/04/problem-unable-to-activate-windows-store-app-the-app1-exe-process -startete-aber-die-Aktivierungsanfrage-schlug-mit-Fehler-fehl-die-App-startete-nicht/

Hoffe, es ist nützlich für Sie

0
Niels Verhoeven

Ich hatte das gleiche Problem mit einer UWP-App, als ich ein Paket für Testing erstellte, aber nicht, wenn es direkt von Visual Studio 2017 aus ausgeführt wurde.

 enter image description here

Die Lösung bestand darin, anstelle der Optionen (x86, x64, ARM) nur die Architektur auszuwählen, die ich zum Debuggen der App verwende.

 enter image description here

Hier ist die Option, die in Visual Studio ausgewählt wurde  enter image description here

0
DJM

Es gibt einige Dinge, die dieses Problem verursachen könnten ... Hier sind die Schritte zur Fehlersuche, die mir geholfen haben:

Schritt 1: Überprüfen Sie, ob Visual Studio im erhöhten Modus ausgeführt wird ( Als Administrator ausführen ), um das Problem zu lösen. (Manchmal werden Ihre Ordnerberechtigungen aufgrund verschiedener Software, die Sie möglicherweise installiert haben, beschädigt.)

Schritt 2: Löschen Sie alle Ordner bin und obj in Ihrem Projekt und erstellen Sie die Projekte in Ihrer Projektmappe manuell neu.

Schritt 3: Überprüfen Sie kurz Ihr System Type (x64 oder x86 etc) und prüfen Sie, ob Ihr Projekt für dasselbe Ziel bestimmt ist.

So erfahren Sie, wie Sie Ihren Systemtyp kennen: Win + R > cmd > systeminfo

Wenn x64 lautet, müssen Sie die Option Solution Platforms (In der oberen Aktionsleiste in Visual Studios) je nach Architektur als x64 auswählen.

Das ist alles, was ich getan habe, um mein Problem zu lösen.

0
Ozesh

Ich habe viele Lösungen ausprobiert und nichts hat funktioniert. Am Ende funktionierte es für mich, das Startprojekt auf Windows Phone 8.1 zu ändern. Nachdem es OK ausgeführt wurde, änderte ich es wieder in Windows 8.1 und es läuft OK. Es funktioniert für mich, da ich eine universelle App mache. Hoffe, es hilft allen anderen.

0
user3091593

Gleiches Problem - Mein Projekt wurde aus der TrueCrypt-Partition verschoben und alles war in Ordnung. 

0
Chris Williams

Ich habe es geschafft, das gleiche Problem zu beheben, indem ich die Lösung neu aufbaute. (In Vis Studio 2012)

0
Oli Haley