webentwicklung-frage-antwort-db.com.de

VirtualBox-Gastzusätze können unter Ubuntu 18.04.2 LTS mit HWE nicht installiert werden - warum?

Kürzlich habe ich HWE auf meinem Ubuntu 18.04.2 LTS installiert, das in VirtualBox ausgeführt wird. Es war eine saubere Installation ohne PPAs und ohne Repositorys von Drittanbietern. Einige Infos finden Sie unten:

$ head -n2 /etc/apt/sources.list
#deb cdrom:[Ubuntu-MATE 18.04 LTS _Bionic Beaver_ - Release AMD64 (20180426)]/ bionic main multiverse restricted universe

$ hwe-support-status
Your Hardware Enablement Stack (HWE) is supported until April 2023.

$ dpkg -l | grep hwe
ii  linux-generic-hwe-18.04                 4.18.0.15.65                            AMD64        Complete Generic Linux kernel and headers
ii  linux-headers-generic-hwe-18.04         4.18.0.15.65                            AMD64        Generic Linux kernel headers
ii  linux-image-generic-hwe-18.04           4.18.0.15.65                            AMD64        Generic Linux kernel image
ii  xserver-xorg-core-hwe-18.04             2:1.20.1-3ubuntu2.1~18.04.1             AMD64        Xorg X server - core server
ii  xserver-xorg-hwe-18.04                  1:7.7+19ubuntu8~18.04.2                 AMD64        X.Org X server
ii  xserver-xorg-input-all-hwe-18.04        1:7.7+19ubuntu8~18.04.2                 AMD64        X.Org X server -- input driver metapackage
ii  xserver-xorg-input-libinput-hwe-18.04   0.28.1-1~18.04.1                        AMD64        X.Org X server -- libinput input driver
ii  xserver-xorg-legacy-hwe-18.04           2:1.20.1-3ubuntu2.1~18.04.1             AMD64        setuid root Xorg server wrapper
ii  xserver-xorg-video-all-hwe-18.04        1:7.7+19ubuntu8~18.04.2                 AMD64        X.Org X server -- output driver metapackage
ii  xserver-xorg-video-amdgpu-hwe-18.04     18.1.0-1~18.04.1                        AMD64        X.Org X server -- AMDGPU display driver
ii  xserver-xorg-video-ATI-hwe-18.04        1:18.1.0-1~18.04.1                      AMD64        X.Org X server -- AMD/ATI display driver wrapper
ii  xserver-xorg-video-fbdev-hwe-18.04      1:0.5.0-1ubuntu1~18.04.1                AMD64        X.Org X server -- fbdev display driver
ii  xserver-xorg-video-intel-hwe-18.04      2:2.99.917+git20171229-1ubuntu1~18.04.1 AMD64        X.Org X server -- Intel i8xx, i9xx display driver
ii  xserver-xorg-video-nouveau-hwe-18.04    1:1.0.15-3~18.04.1                      AMD64        X.Org X server -- Nouveau display driver
ii  xserver-xorg-video-qxl-hwe-18.04        0.1.5-2build2~18.04.1                   AMD64        X.Org X server -- QXL display driver
ii  xserver-xorg-video-radeon-hwe-18.04     1:18.1.0-1~18.04.1                      AMD64        X.Org X server -- AMD/ATI Radeon display driver
ii  xserver-xorg-video-vesa-hwe-18.04       1:2.4.0-1~18.04.1                       AMD64        X.Org X server -- VESA display driver
ii  xserver-xorg-video-vmware-hwe-18.04     1:13.3.0-2build1~18.04.1                AMD64        X.Org X server -- VMware display driver

$ uname -r
4.18.0-15-generic

Vor der HWE-Installation habe ich virtualbox-guest-x11, aber jetzt wird es entfernt. Außerdem kann ich es nicht wieder installieren:

$ Sudo apt install virtualbox-guest-x11
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 virtualbox-guest-x11 : Depends: xorg-video-abi-23
                        Depends: xserver-xorg-core (>= 2:1.18.99.901)
E: Unable to correct problems, you have held broken packages.

und HWE-benannt auch:

$ Sudo apt install virtualbox-guest-x11-hwe 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 virtualbox-guest-x11-hwe : Depends: xorg-video-abi-23
                            Depends: xserver-xorg-core (>= 2:1.18.99.901)
E: Unable to correct problems, you have held broken packages.

Was sollte ich tun?

1
N0rbert

Update: Der Fehler wurde am 08.03.2019 mit der Version virtualbox-guest-x11-hwe 5.2.18-dfsg-3 ~ behoben ubuntu18.04.3.


Es war ein Abhängigkeitsproblem, daher habe ich zwei Fehler gemeldet:

  1. Fehler 1816383 - virtualbox-guest-x11 kann am 18.04.2 LTS mit HWE nicht installiert werden
  2. Fehler 1816386 - virtualbox-guest-x11-hwe kann am 18.04.2 LTS mit HWE nicht installiert werden

Die einfachste Lösung besteht also darin, einen normalen Kernel und Xorg zu installieren und dann HWE-Pakete zu entfernen

Sudo apt-get install xserver-xorg linux-image-generic
Sudo apt-get purge xserver-xorg-hwe-18.04 linux-image-generic-hwe-18.04 xserver-xorg-legacy-hwe-18.04 xserver-xorg-core-hwe-18.04 xserver-xorg-video-intel-hwe-18.04
Sudo apt-get autoremove

und installieren Sie dann virtualbox-guest-x11 mit neu

Sudo apt-get install virtualbox-guest-x11
1
N0rbert

Sie könnten versuchen, zu starten

apt-get install --reinstall virtualbox-guest-x11-hwe
0
Ubunter