webentwicklung-frage-antwort-db.com.de

Yeoman und Bower fügen kein Bootstrap-CSS (AngularJS-Generator) hinzu

Ich folge einem codelab auf der Yeoman-Webseite, und bis jetzt habe ich es geschafft, mitzumachen (mit ein paar großen Problemen, die meine Entwicklungsumgebung zum Laufen bringen, aber jetzt gibt es keine Fehler zurück).

Also habe ich mein Projektverzeichnis erstellt und yo ausgeführt, AngularJS ausgewählt und das Ding ausgeführt. Ziemlich bald in den Prozess bekam ich eine Aufforderung ? Overwrite package.json? Ich antwortete mit y und erhielt die folgenden Warnungen:

npm WARN package.json [email protected] No license field.
npm WARN peerDependencies The peer dependency [email protected]>=0.9 included from karma-jasmine will no
npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency 
npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly.
npm WARN peerDependencies The peer dependency [email protected]* included from karma-jasmine will no
npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency 
npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly.
npm WARN peerDependencies The peer dependency [email protected]>=0.9 included from karma-phantomjs-launcher will no
npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency 
npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly.
npm WARN peerDependencies The peer dependency [email protected]>=1.9 included from karma-phantomjs-launcher will no
npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency 
npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly.
npm WARN peerDependencies The peer dependency [email protected]~0.12.0 included from grunt-karma will no
npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency 
npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly.
npm WARN optional dep failed, continuing [email protected]

Danach beendete es, was es tat, also lief ich bower install noch einmal, nur um sicher zu gehen (wegen der package.json-Sache) und dann grunt serve. Nun sagt Grunt erledigt, ohne Fehler, aber meine Seite lädt nur main.css. Ich habe ein starkes Gefühl, dass die bootstrap.css-Datei fehlt. So So sieht es aus, wenn die Codelab-Anweisungen sagen, dass es so aussehen soll dies .

Wenn Sie weitere Informationen zu den generierten Informationen benötigen, finden Sie hier einen GitHub-Repository-Link .

Jede Einsicht in das, was ich falsch mache (wenn überhaupt) ist willkommen.

26

Nachdem ich das Codelab gemacht hatte, hatte ich genau das gleiche Problem mit dem gleichen Ergebnis, das Sie erhalten (Warnungen und alle). Ich musste das Problem einfach umgehen, indem ich zu Bootstrap 3.3.4 zurückging.

Bearbeiten Sie einfach bower.json und ändern Sie die Bootstrap-Zeile in:

    "bootstrap": "3.3.4",

Führen Sie dann folgendes aus und es sollte funktionieren:

    bower install
    grunt serve
56
chipzilla

Es hat auch nicht für mich funktioniert. Ich habe eine Lösung von hier: https://github.com/twbs/bootstrap/issues/16663

Dieses Problem wurde vorübergehend behoben, indem unser Projekt bower.json überschrieben wurde. Für uns funktioniert es gut, aber wir warten auf eine Lösung von Bootstrap.

"overrides":{
    "bootstrap" : {
         "main": [
            "less/bootstrap.less",
            "dist/css/bootstrap.css",
            "dist/js/bootstrap.js"
          ]
    }
  }
25
codesnooker

Wenn Sie sich an eine Shell halten, können Sie einfach Folgendes eingeben:

bower install --save bootstrap#3.3.4
grunt serve

Dadurch wird sichergestellt, dass Twitter Bootstrap auf eine Bower/Yo-Angle-Version heruntergestuft wird und diese als Entwicklungsabhängigkeit speichert. Grunt führt dann 'wiredep' während seiner 'Dien'-Aufgabe aus und fügt die bootstrap.css in die index.html Ihres Projekts ein.

10
Glenn Batuyong

In der Datei bower.json ist die Abhängigkeitsversion von Bootstrap wie folgt festgelegt:

"bootstrap": "^3.2.0",

In der Standardeinstellung bedeutet dies, dass die neueste Version höher als 3.2.0 installiert ist ..__ Die neueste Version 3.3.5 wird installiert und das bricht.

Entfernen Sie also das ^-Zeichen und ersetzen Sie:

"bootstrap": "^3.2.0",

mit:

"bootstrap": "3.3.4",
1
burakhan alkan

Es ist nicht ideal, aber ich habe zurück auf Bootstrap Version 3.3.4 gerollt und folgendes eingestellt:

bower install --save bootstrap#3.3.4

bower_concat: {
  all: {
    dest: {
      'js': 'path/to/file/_bower.js',
      'css': 'path/to/file/_bower.css'
    }
  }
}
0
CR Rollyson