webentwicklung-frage-antwort-db.com.de

Fehler: Für den Datenpfad ".builders ['app-Shell']" sollte die Eigenschaft 'class' erforderlich sein.

Ich erhalte diesen Fehler beim Ausführen meiner Anwendung. Hier sind die Details meiner Bewerbung.

Angular CLI: 7.3.3 
Node: 10.15.1 
Angular: 7.2.7 
@angular-devkit/architect -0.13.3 
@angular-devkit/build-angular- 0.800.1 
@angular-devkit/build-optimizer - 0.800.1 
@angular-devkit/build-webpack - 0.800.1 
@angular-devkit/core -7.3.3 
@angular-devkit/schematics -7.3.3 
@angular/cli -7.3.3 
@ngtools/webpack -8.0.1 
@schematics/angular -7.3.3 
@schematics/update 0.13.3 
rxjs 6.3.3 
TypeScript 3.2.4 
webpack 4.30.0

Ich habe bereits versucht, den Cache sauber zu halten.

143
Ekta Gandhi

Ändern Sie in Ihrer package.json den devkit-Builder.

"@angular-devkit/build-angular": "^0.800.1",

zu

"@angular-devkit/build-angular": "^0.10.0",

für mich geht das.
Viel Glück.

148
idirene youcef

Das Folgende hat bei mir funktioniert

npm uninstall @angular-devkit/build-angular
npm install @angular-devkit/[email protected]
85
abasar

Jeder hier konzentriert sich aus Kompatibilitätsgründen auf das Downgrade von @ angle-devkit/build-angle auf @angular 7.x-Versionen, aber was sie sollten tun, ist ein Upgrade von @angular/cli to angular 8 Versionen.

Das Problem ist, dass die System-CLI immer noch in einer alten Version steckt und nicht automatisch von ng update (da es sich außerhalb des angular Controlled Project) befindet, wird es beim Versuch, auf die angular Libraries) zuzugreifen, in einer inkompatiblen Version belassen.

Herabstufung @angular-devkit/build-angular verursacht nur mehr Inkompatibilitäten.

npm i --global @angular/[email protected]

wird das Problem beheben ohne Dinge woanders kaputt machen.

60
ovangle

Jeder konzentriert sich auf die Herabstufung @angular-devkit/build-angular Version auf X oder Upgrade von @angular/cli Version auf Y oder spätestens.

Bitte schlagen Sie jedoch nicht blind ein X or Y or latest als Antworten. (Obwohl normalerweise ein Downgrade des Devkits besser sein sollte, da das Upgrade der CLI eine bahnbrechende Änderung darstellt)

Die richtige Version hängt immer von Ihrer Angular (angle-cli) -Version ab.

Angular CLI v8.3.19 -> 0.803.19
Angular CLI v8.3.17 -> 0.803.17
Angular CLI v7.3.8 -> 0.13.8
Angular CLI v6-lts -> 0.8.9

Weitere spezifische Versionen finden Sie unter: https://github.com/angular/angular-cli/tags . Suchen Sie Ihre CLI-Version, und in einigen Tags werden die entsprechenden Versionen für @angular-devkit/** Pakete.

Hinweis: Wenn Sie Ihre CLI-Version aktualisieren möchten, sollten Sie zunächst ein Upgrade auf die neueste Version Ihrer Hauptversion in Betracht ziehen. Springen Sie nicht einfach zur nächsten Hauptversion.

36
zhuhang.jasper

Ihr @ angle-devkit ist nicht mit der @ angle/cli-Version kompatibel. Installieren Sie also einfach ein älteres wie das folgende:

npm install @angular-devkit/[email protected] @angular-devkit/[email protected]
28

Gleiches Problem nach dem Versuch, ein Upgrade auf Ng8 durchzuführen, das aufgrund von Abhängigkeitsproblemen fehlgeschlagen ist.

npm uninstall @ angle-devkit/build-angle

dann

npm install @ angle-devkit/build-angle @ 0.12.4

behoben...

14
Alfa Bravo

Ich hatte das gleiche Problem, aber ich habe es dank des Kommentars von Ekta Gandhi gelöst:

Endlich habe ich die Lösung gefunden.

1) Entfernen Sie zunächst alle Änderungen in der Datei package.json, indem Sie den einfachen Befehl git checkout package.json eingeben.

2) Dann nach Änderung in package.json in @ angle-devkit/build-angle-~ 0.800.1 (Schwanz statt Kappe hinzufügen)

3) Führen Sie dann den Befehl rm -rf node_modules/aus

4) Bereinigen Sie dann catch, indem Sie den Befehl npm clean cache -f eingeben

5) Führen Sie zuletzt den Befehl npm install aus. Das funktioniert bei mir.

.... zusammen mit der von Dimuthu vorgeschlagenen Änderung

Schaffte es an @ angle-devkit/build-angle ":" 0.13.4 "und es funktionierte.

12

Dies passierte mir bei der Installation von Angular 8, es gibt einige Inkompatibilitäten, die ich nicht lösen konnte. Ich musste ein Downgrade durchführen, weil ich mit jeder Version durch das Kaninchenloch jonglierte, bis ich eine fand, die diese fand hat funktioniert.

Erstens war TypeScript veraltet, die Standardinstallation fügte einen Verweis auf TypeScript 3.1.6 hinzu und erfordert 3.4 oder höher.

npm install [email protected]">=3.4 <3.5"

Zweitens führte die Verwendung des Devkits 0.800.1 oder 0.800.1 immer zu Inkompatibilitäten. Ich habe viele Kombinationen ausprobiert, bin mir aber noch nicht sicher, ob sie vollständig kompatibel sind, insbesondere weil ich eine bootstrap etwas älter) verwende und noch kein Upgrade durchführen kann.

Schließlich habe ich versucht, ein Downgrade durchzuführen (gehen Sie zu package.json und suchen Sie die devDependencies), bis einer von ihnen funktioniert hat.

@angular-devkit/build-angular": "0.13.4"

Ich bin sicher, Ihr Problem sind Abhängigkeitsversionen, aber ich kann Ihnen nicht sagen, welche. Probieren Sie es aus.

7

Ich bin auch auf dieses Problem gestoßen, und bei mehr Updates sind mehr Probleme aufgetreten.

Was am Ende für mich funktioniert hat, war mehr oder weniger, angular cli) zu entfernen und es mit den folgenden Schritten neu zu installieren:

npm uninstall -g @angular/cli
npm cache clean --force
npm install -g @angular/cli

dies hat mir geholfen, die Quelle herauszufinden: wie man angle/cli deinstalliert

6
tony2tones

Versuchen Sie, die Datei package.json von zu aktualisieren

  "@angular-devkit/build-angular": "^0.800.1" 

zu

  "@angular-devkit/build-angular": "^0.12.4"

Führen Sie dann npm install in der Befehlszeile aus.

6
Nadeem Qasmi

Ich habe diese Änderung in der Datei package.json vorgenommen, dann funktioniert es.

"@angular-devkit/build-angular": "^0.803.23"

zu

"@angular-devkit/build-angular": "^0.13.9"

2
Aditya patil

Ich habe mich verändert @angular-devkit/build-angular": "0.9.0.1" bis @angular-devkit/build-angular": "0.13.4" und es hat funktioniert.

Ich war auch mit diesem Problem konfrontiert und hatte Stunden Mühe, es zu lösen. Ich habe alle oben genannten Optionen ausprobiert, aber nichts hat mein Problem gelöst. Dieses Problem tritt aufgrund einer Versionsfehlanpassung von Angular/Cli und Angular-Devkit auf. Daher habe ich Folgendes getan:

  1. Manuell geänderte Version von Dateien:

    @ angle-devkit/build-angle ":" ^ 0.13.9 ",

    @angular/cli": "~7.0.3", // Dies ist für Angular7, für Angular8: 0.803.23

  2. Package-lock.json gelöscht

  3. Ausgeführt: npm install

Es hat mein Problem gelöst.

0
SanjaySahu44

Wenn Sie zu angular 8 oder 9) wechseln, reicht dies aus

ng update @angular/cli
0
Victor Osuyak

Auf meiner Seite war es Paket

@ Angular-Devkit/Build-Angular

und

@ angle-devkit/build-ng-packagr

war nicht die gleiche Version, Aktualisierung build-ng-packagr zur gleichen Version wie build-angular mein Problem behoben.

0
Bdwey