webentwicklung-frage-antwort-db.com.de

Wie kann ich mein ADT in Eclipse aktualisieren?

Ich habe versucht, meine Eclipse zu aktualisieren. Derzeit habe ich bis 2.2 Android SDK in meiner Eclipse. Gestern habe ich meine Eclipse folgendermaßen aktualisiert:

Eclipse -> Fenster -> Android SDK Manager -> Ich habe zwei Kontrollkästchen in der Liste aktiviert. Tools -> Android SDK Tools und Android SDK Platform Tools.

Ich habe hier einige letzte Zeilen der Nachricht gepostet, die ich beim Herunterladen und Installieren erhalte:

Vorbereiten der Installation von Archiven
Herunterladen Android SDK Platform-tools, Revision 12
Installieren von Android SDK Platform-tools, Revision 12
Das Stoppen des ADB-Servers war erfolgreich.
Installierte Android SDK Platform-tools, Revision 12
Herunterladen Android SDK Tools, Revision 20
Installieren von Android SDK Tools, Revision 20
[post_tools_install.bat] Aktualisieren von SDK Manager.exe
[post_tools_install.bat] 1 Datei (en) kopiert.
[post_tools_install.bat] Aktualisieren von AVD Manager.exe
[post_tools_install.bat] 1 Datei (en) kopiert.
Installiert Android SDK Tools, Revision 20
Das Stoppen des ADB-Servers war erfolgreich.
Starten des ADB-Servers erfolgreich.
Getan. 2 Pakete installiert.
URL wird abgerufen: https://dl-ssl.google.com/Android/repository/addon.xml
URL konnte nicht abgerufen werden https://dl-ssl.google.com/Android/repository/addon.xml , Grund: dl-ssl.google.com
URL wird abgerufen: http://software.intel.com/sites/landingpage/Android/addon.xml
URL konnte nicht abgerufen werden http://software.intel.com/sites/landingpage/Android/addon.xml , Grund: software.intel.com
Pakete fertig geladen.

Aber nach all dem nachdem ich Eclipse geschlossen habe und wieder starten wollte, wirft es den Fehler:

Für dieses Android SDK ist Android Developer Toolkit Version 20.0.0 oder höher erforderlich. Die aktuelle Version ist 16.0.0.v201203301601-306762. Bitte aktualisieren Sie ADT auf die neueste Version .

In den Einstellungen habe ich diesen Fehler erhalten:

Dieses Android SDK erfordert Android Entwickeln ... Bitte aktualisieren Sie ADT auf die neueste Version.

116
himAndroid

Sie haben das SDK Android aktualisiert, aber das ADT nicht entsprechend aktualisiert.

Sie können die Anzeige von hier aus aktualisieren

Möglicherweise müssen Sie die Software-Quelle für Ihr ADT-Update aktualisieren

Gehe zu Eclipse> Hilfe> Nach Updates suchen.

Es sollte das neueste Update von adt enthalten. Wenn es nicht funktioniert, versuchen Sie es auf die gleiche Weise * Gehen Sie zu Eclipse> Hilfe> Neue Software installieren *, aber gehen Sie jetzt wie folgt vor:

Es werden die verfügbaren Updates aufgelistet, die idealerweise um 20.xx Uhr hinzugefügt werden sollten

Eclipse wird neu gestartet und hoffentlich sollte alles gut für Sie funktionieren.

329
Murtuza Kabul

Ich hatte dieses Problem. Da ich bereits die Adresse ADT hatte, konnte ich dem vorgeschlagenen Fix nicht folgen. Der Grund, warum das Update in meinem Fall nicht funktionierte, ist, dass die ADT-Adresse in der Liste "Verfügbare Updates" nicht überprüft wurde.

1) Gehen Sie zu Eclipse> Hilfe> Neue Software installieren

2) Klicken Sie auf "Verfügbare Software".

3) Überprüfen Sie, ob Sie die ADT-Adresse haben

4) Wenn nicht, fügen Sie es gemäß den Schritten von Murtuza Kabul hinzu

5) Wenn ja, überprüfen Sie, ob die Adresse aktiviert ist (Kontrollkästchen links neben der Adresse).

Ich führe das Update aus, nachdem ich Eclipse als Administrator gestartet habe, um sicherzustellen, dass es keine Probleme beim Zugriff auf die Systemordner gibt

7
kingston

Ich habe die Eclipse ADT-Dokumentation gelesen und herausgefunden, wie man dieses Problem umgehen kann. Ich konnte mein SDK-Tool auf 22.0.4 (neueste Version) aktualisieren.

Lösung ist: Zuerst ADT auf 22.0.4 aktualisieren und dann SDK Tool auf 22.0.4 aktualisieren

Der obige Link sagt,

ADT 22.0.4 ist für die Verwendung mit SDK Tools r22.0.4 vorgesehen. Wenn Sie SDK Tools r22.0.4 noch nicht in Ihrem SDK installiert haben, verwenden Sie dazu den Android SDK Manager

Was ich tun musste, war mein ADT auf 22.0.4 (neueste Version) zu aktualisieren und dann konnte ich SDK-Tool auf 22.0.4 aktualisieren. Ich dachte, nur das SDK-Tool wurde aktualisiert, nicht ADT. Daher habe ich das SDK-Tool mit einer älteren ADT-Version (22.0.1) aktualisiert.

So aktualisieren Sie Ihr ADT auf die neueste Version

  1. In Eclipse gehe zu Help

  2. Install New Software ---> Add

  3. im Add Repository schreiben Sie den Namen: ADT (oder was auch immer Sie wollen)

  4. Standort: https://dl-ssl.google.com/Android/Eclipse/

  5. nach dem Laden sollten Sie Developer Tools und NDK Plugins erhalten

  6. aktivieren Sie beide Kontrollkästchen, wenn Sie zukünftig das Native Developer Kit (NDK) verwenden möchten, oder aktivieren Sie diese Option

  7. Nur für das Developer Tool

  8. weiter klicken

  9. Fertig

Als Administrator zu laufen und dann anderen Kommentaren zu folgen, hat das Problem für mich behoben :)

1
LeRoy

In meinem Fall hatte das Öffnen von "Hilfe" >> "Neue Software installieren" keine Einträge für URLs (vorherige URLs waren nicht vorhanden) - also habe ich sie manuell hinzugefügt. Und aktualisiert ... und Voilaaaa !! Die oben genannten Beiträge haben mir bei der Lösung dieses Problems sehr geholfen.

1
MahaKun

Der Grund dafür ist, dass mit dem neuen Update die URL für die Android Developer Tools-Aktualisierungssite so geändert wurde, dass HTTPS erforderlich ist. Wenn Sie ADT aktualisieren, stellen Sie sicher, dass Sie HTTPS in der URL für = verwenden Android Developer Tools-Update-Site.

1
fatihkaradag

Ich hatte das gleiche Problem, bei dem keine Dateien unter Generated Java files, BuildConfig und R.Java fehlten. Die automatische Build-Option wird nicht generiert.
Deaktivieren Sie in Eclipse unter Projekt die Option Automatisch erstellen. Wählen Sie dann unter Projekt die Option Projekt erstellen. Möglicherweise müssen Sie das Projekt reparieren

0
mcwong