webentwicklung-frage-antwort-db.com.de

So aktualisieren Sie Google Play Services auf 9.8.7

Ich versuche, firebase in ein Android-Projekt zu implementieren, bekomme aber immer:
Google Play-Dienste veraltet . Requires 9877000 but found 9683480
Meine Projekt-/App-Dateien sehen folgendermaßen aus:

...
compile 'com.google.firebase:firebase-core:9.8.0'
    compile 'com.google.firebase:firebase-database:9.8.0'
    compile 'com.google.firebase:firebase-auth:9.8.0'

}

apply plugin: 'com.google.gms.google-services'

und

dependencies {
        classpath 'com.Android.tools.build:gradle:2.2.2'
        classpath 'com.google.gms:google-services:3.0.0'

Ich habe Nexus S Emulator mit API 23 und Target: Android 6.0 (Google APIs) x86_64 erstellt.

Inside Emulator Google App Services Version ist 9.6.83

Was soll ich tun, um firebase ausführen zu können, da ich nicht mehr weiß, was ich installieren oder aktualisieren soll: /
Ich bin neu in Android und weiß nicht, ob mir etwas Kleines fehlt.

10
1110

Die aktualisierten Android-Tools (die das Android Emulator-System-Image enthalten) sind noch nicht verfügbar. Sobald dies nicht mehr möglich ist, verfügen Ihre Emulatoren über Google Play Services 9.8, eine Voraussetzung für Firebase SDK 9.8.

Wenn Sie auf einem Emulator testen möchten, müssen Sie Ihre App zunächst auf Firebase SDK 9.6 downgraden.

Wenn Sie auf einem physischen Gerät bereitstellen, ist wahrscheinlich bereits die neueste Version verfügbar.

16

Ein möglicher Lösungsweg wäre, die API-Version von den Emulator herunterstufen (z. B. von 23 auf 20) durch Erstellen eines neuen Emulators (Tools -> Android -> AVD Manager -> Neues virtuelles Gerät erstellen zu erstellen. Wählen Sie im zweiten Bildschirm Ihre bevorzugte (z. B. 20) API-Version aus.

0
george mano