webentwicklung-frage-antwort-db.com.de

Methode kapt () für Glide konnte nicht gefunden werden

apply plugin: 'com.google.gms.google-services'
apply plugin: 'kotlin-Android'
apply plugin: 'kotlin-Android-extensions'
apply plugin: 'kotlin-kapt'

classpath 'com.Android.tools.build:gradle:3.2.0'
classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:1.2.61"

Ich habe die obige gradle Konfiguration und bekomme immer noch

Could not find method kapt() for arguments [com.github.bumptech.glide:compiler:4.3.1] on object of type org.gradle.api.internal.artifacts.dsl.dependencies.DefaultDependencyHandler.

Kann mir jemand sagen, wo ich falsch liege? Vielen Dank für die Hilfe im Voraus

4
Rajas47Ashtikar

projektebene build.gradle:

buildscript {
    repositories {
        mavenCentral()
        jcenter()
        google()
    }
    dependencies {
        classpath "com.Android.tools.build:gradle:3.2.0"
        classpath "com.google.gms:google-services:4.1.0"
        classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:1.2.70"
    }
}

modulebene build.gradle:

apply plugin: "kotlin-Android"
apply plugin: "kotlin-Android-extensions"
apply plugin: "kotlin-kapt"
...
Android {

} 
dependencies {
    implementation "com.github.bumptech.glide:glide:4.8.0"
    // annotationProcessor "com.github.bumptech.glide:compiler:4.8.0"
    kapt "com.github.bumptech.glide:compiler:4.8.0"
}
...
apply plugin: "com.google.gms.google-services"
7
Martin Zeitler

Ich denke, kapt ist mit den neuen Versionen von Glide so verfügbar. Versuchen Sie Folgendes hinzuzufügen:

kapt 'com.github.bumptech.glide:compiler:4.8.0'

In Ihren Build.gradle Abhängigkeiten bei der Verwendung von Kotlin .

Beachten Sie, dass die Glide-Abhängigkeit dieselbe Version wie der Compiler haben sollte:

dependencies {
    implementation 'com.github.bumptech.glide:glide:4.8.0'
    kapt 'com.github.bumptech.glide:compiler:4.8.0'
}

Oder aktualisieren Sie Ihren Kotlin auf v1.2.71:

buildscript {

    ext.kotlin_version = '1.2.71'
}


 dependencies {
        classpath 'com.Android.tools.build:gradle:3.2.0'
        classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"
}

In der WurzelBuild.gradle. Das sollte funktionieren.

0
ʍѳђઽ૯ท