webentwicklung-frage-antwort-db.com.de

Firebase-Anzeigen können nicht verwendet werden: Keine statische Methode zzc (Landroid/os/Bundle;

Ich versuche, die Firebase-Anzeigenbibliothek meinem Projekt hinzuzufügen (das bereits aktiv ist). Der Build funktioniert, aber wenn ich versuche, es auszuführen, stürzt dieser Fehler ab:

11-16 10: 33: 13.535 540-540/com.dap E/AndroidRuntime: FATAL EXCEPTION: main Prozess: com.dap, PID: 540 Java.lang.NoSuchMethodError: Keine statische Methode zzc (Landroid/os/Bundle;) Lcom/google/Android/gms/Messung/intern/zzak; in der Klasse Lcom/google/Android/gms/measurement/internal/zzak; oder seine Superklassen (Deklaration von 'com.google.Android.gms.measurement.internal.zzak' erscheint in /data/app/com.dap-AZ0LDvxgjJKn7K-a-EQ0QQ==/split_lib_dependencies_apk.apk) at com .google.firebase.analytics.connector.AnalyticsConnectorImpl.getInstance (unbekannte Quelle: 20) unter com.google.firebase.analytics.connector.internal.zzb.create (unbekannte Quelle: 6) unter com.google.firebase.components.Lazy .lambda $ new $ 0 (com.google.firebase: firebase-common @@ 16.0.4: 43) bei com.google.firebase.components.Lazy $$ Lambda $ 1.get (unbekannte Quelle: 4) bei com.google. firebase.components.Lazy.get (com.google.firebase: firebase-common @@ 16.0.4: 54) unter com.google.firebase.components.AbstractComponentContainer.get (com.google.firebase: firebase-common @@ 16.0) .4: 26) unter com.google.firebase.components.ComponentRuntime.get (com.google.firebase: firebase-common @@ 16.0.4: 34) unter com.google.firebase.components.ComponentRuntime.initializeEagerComponents (com. google.firebase: firebase-common @@ 16.0.4: 82) unter com.google.firebase.FirebaseApp.initia lizeAllApis (com.google.firebase: firebase-common @@ 16.0.4: 761) bei com.google.firebase.FirebaseApp.initializeApp (com.google.firebase: firebase-common @@ 16.0.4: 359) bei com. google.firebase.FirebaseApp.initializeApp (com.google.firebase: firebase-common @@ 16.0.4: 324) unter com.google.firebase.FirebaseApp.initializeApp (com.google.firebase: firebase-common @@ 16.0.4) : 310) bei com.google.firebase.provider.FirebaseInitProvider.onCreate (com.google.firebase: firebase-common @@ 16.0.4: 53) bei Android.content.ContentProvider.attachInfo (ContentProvider.Java:1919) bei Android .content.ContentProvider.attachInfo (ContentProvider.Java:1894) unter com.google.firebase.provider.FirebaseInitProvider.attachInfo (com.google.firebase: firebase-common @@ 16.0.4: 47) unter Android.app.ActivityThread. installProvider (ActivityThread.Java:7107) bei Android.app.ActivityThread.installContentProviders (ActivityThread.Java:6594) bei Android.app.ActivityThread.handleBindApplication (ActivityThread.Java:6498) bei Android.app.ActivityThread.-wrap2 (Unknown So urce: 0) bei Android.app.ActivityThread $ H.handleMessage (ActivityThread.Java:1963) bei Android.os.Handler.dispatchMessage (Handler.Java:108) bei Android.os.Looper.loop (Looper.Java:166 ) bei Android.app.ActivityThread.main (ActivityThread.Java:7425) bei Java.lang.reflect.Method.invoke (Native Method) bei com.Android.internal.os.Zygote $ MethodAndArgsCaller.run (Zygote.Java:245 ) unter com.Android.internal.os.ZygoteInit.main (ZygoteInit.Java:921)

Alle meine Firebase/Google-Bibliotheken sind auf dem neuesten Stand Firebase neueste Version :

repositories {
mavenCentral()
maven { url 'https://maven.fabric.io/public' }
}
dependencies {

implementation fileTree(include: ['*.jar'], dir: 'libs')

// Facebook libraries
implementation 'com.facebook.Android:facebook-Android-sdk:4.32.0'

// Firebase/Google libraries
implementation('com.crashlytics.sdk.Android:crashlytics:[email protected]') {
    transitive = true;
}

implementation 'com.firebase:geofire-Android:2.1.0'

implementation 'com.google.firebase:firebase-core:16.0.4'
implementation 'com.google.firebase:firebase-messaging:17.3.4'
implementation 'com.google.firebase:firebase-storage:16.0.4'
implementation 'com.google.firebase:firebase-auth:16.0.5'
implementation 'com.google.firebase:firebase-database:16.0.4'
implementation 'com.firebaseui:firebase-ui-storage:2.0.1'
implementation 'com.google.firebase:firebase-dynamic-links:16.1.3'
implementation 'com.google.firebase:firebase-analytics:16.0.5'
implementation 'com.google.firebase:firebase-config:16.1.0'
implementation 'com.google.firebase:firebase-invites:16.0.5'
implementation 'com.google.firebase:firebase-functions:16.1.2'
implementation 'com.google.firebase:firebase-ads:17.1.1'

implementation 'com.google.Android.gms:play-services-location:16.0.0'
implementation 'com.Android.billingclient:billing:1.1'

// Support libraries (don't use the global support library)
implementation 'com.Android.support.constraint:constraint-layout:2.0.0-alpha2'
implementation 'com.Android.support:multidex:1.0.3'
implementation 'com.Android.support:percent:27.1.1'
implementation 'com.Android.support:recyclerview-v7:27.1.1'
implementation 'com.Android.support:support-fragment:27.1.1'
implementation 'com.Android.support:support-vector-drawable:27.1.1'
implementation 'com.Android.support:appcompat-v7:27.1.1'
implementation 'com.Android.support:design:27.1.1'
implementation 'com.Android.support:animated-vector-drawable:27.1.1'

// Other libraries
implementation 'com.baoyz.swipemenulistview:library:1.3.0'
implementation 'me.himanshusoni.chatmessageview:chat-message-view:1.0.3'
implementation 'com.github.bumptech.glide:glide:3.8.0'
implementation 'com.github.warkiz.widget:indicatorseekbar:1.1.2'
implementation 'com.github.guilhe:seekbar-ranged-view:1.0.1'
implementation 'com.crystal:crystalrangeseekbar:1.1.3'

testImplementation 'junit:junit:4.12'

}
apply plugin: 'com.google.gms.google-services'

So lange mein build.gradle:

dependencies {
    classpath 'com.Android.tools.build:gradle:3.1.4'
    classpath 'com.google.gms:google-services:4.2.0'

    dependencies {
        //classpath 'io.fabric.tools:gradle:1.25.0'
        classpath 'io.fabric.tools:gradle:1.25.1'
    }


    // NOTE: Do not place your application dependencies here; they belong
    // in the individual module build.gradle files
}

Ich habe versucht, einige Bibliotheken wie diese post Beratung zu downgraden. Kein Erfolg. Ich habe versucht, gms: play-services-location zu downgraden, aber kein Erfolg. Anstatt die Anzeigenbibliothek von Firebase hinzuzufügen, habe ich die von Google ausprobiert, aber ich erhalte den folgenden Fehler: "Error: Program type already present: com.google.Android.gms.internal.measurement.zzdz"

Ich habe auch versucht, das Projekt zu bereinigen und neu zu erstellen, die App auf meinem Telefon zu deinstallieren, den Cache zu ungültig zu machen und neu zu starten. Aber ich bekomme immer den gleichen Fehler.

Ich werde weiter graben, aber im Moment kann ich keine Möglichkeit finden, diese Firebase-Bibliotheken zusammenarbeiten zu lassen.

Endlich, wenn es jemandem helfen kann, hier meine gradlew App: Abhängigkeiten:

+--- com.facebook.Android:facebook-Android-sdk:4.32.0
|    +--- com.facebook.Android:facebook-core:4.32.0
|    |    +--- com.parse.bolts:bolts-Android:1.4.0
|    |    |    +--- com.parse.bolts:bolts-tasks:1.4.0
|    |    |    \--- com.parse.bolts:bolts-applinks:1.4.0
|    |    |         \--- com.parse.bolts:bolts-tasks:1.4.0
|    |    +--- com.Android.support:support-annotations:27.0.2 -> 27.1.1
|    |    \--- com.Android.support:support-core-utils:27.0.2 -> 27.1.1
|    |         +--- com.Android.support:support-annotations:27.1.1
|    |         \--- com.Android.support:support-compat:27.1.1
|    |              +--- com.Android.support:support-annotations:27.1.1
|    |              \--- Android.Arch.lifecycle:runtime:1.1.0
|    |                   +--- Android.Arch.lifecycle:common:1.1.0
|    |                   \--- Android.Arch.core:common:1.1.0
|    +--- com.facebook.Android:facebook-common:4.32.0
|    |    +--- com.facebook.Android:facebook-core:4.32.0 (*)
|    |    +--- com.Android.support:support-v4:27.0.2 -> 27.1.1
|    |    |    +--- com.Android.support:support-compat:27.1.1 (*)
|    |    |    +--- com.Android.support:support-media-compat:27.1.1
|    |    |    |    +--- com.Android.support:support-annotations:27.1.1
|    |    |    |    \--- com.Android.support:support-compat:27.1.1 (*)
|    |    |    +--- com.Android.support:support-core-utils:27.1.1 (*)
|    |    |    +--- com.Android.support:support-core-ui:27.1.1
|    |    |    |    +--- com.Android.support:support-annotations:27.1.1
|    |    |    |    +--- com.Android.support:support-compat:27.1.1 (*)
|    |    |    |    \--- com.Android.support:support-core-utils:27.1.1 (*)
|    |    |    \--- com.Android.support:support-fragment:27.1.1
|    |    |         +--- com.Android.support:support-compat:27.1.1 (*)
|    |    |         +--- com.Android.support:support-core-ui:27.1.1 (*)
|    |    |         +--- com.Android.support:support-core-utils:27.1.1 (*)
|    |    |         +--- com.Android.support:support-annotations:27.1.1
|    |    |         +--- Android.Arch.lifecycle:livedata-core:1.1.0
|    |    |         |    +--- Android.Arch.lifecycle:common:1.1.0
|    |    |         |    +--- Android.Arch.core:common:1.1.0
|    |    |         |    \--- Android.Arch.core:runtime:1.1.0
|    |    |         |         \--- Android.Arch.core:common:1.1.0
|    |    |         \--- Android.Arch.lifecycle:viewmodel:1.1.0
|    |    +--- com.Android.support:appcompat-v7:27.0.2 -> 27.1.1
|    |    |    +--- com.Android.support:support-annotations:27.1.1
|    |    |    +--- com.Android.support:support-core-utils:27.1.1 (*)
|    |    |    +--- com.Android.support:support-fragment:27.1.1 (*)
|    |    |    +--- com.Android.support:support-vector-drawable:27.1.1
|    |    |    |    +--- com.Android.support:support-annotations:27.1.1
|    |    |    |    \--- com.Android.support:support-compat:27.1.1 (*)
|    |    |    \--- com.Android.support:animated-vector-drawable:27.1.1
|    |    |         +--- com.Android.support:support-vector-drawable:27.1.1 (*)
|    |    |         \--- com.Android.support:support-core-ui:27.1.1 (*)
|    |    +--- com.Android.support:cardview-v7:27.0.2
|    |    |    \--- com.Android.support:support-annotations:27.0.2 -> 27.1.1
|    |    +--- com.Android.support:customtabs:27.0.2
|    |    |    +--- com.Android.support:support-compat:27.0.2 -> 27.1.1 (*)
|    |    |    \--- com.Android.support:support-annotations:27.0.2 -> 27.1.1
|    |    \--- com.google.zxing:core:3.3.0
|    +--- com.facebook.Android:facebook-login:4.32.0
|    |    +--- com.facebook.Android:facebook-core:4.32.0 (*)
|    |    +--- com.facebook.Android:facebook-common:4.32.0 (*)
|    |    \--- com.Android.support:appcompat-v7:27.0.2 -> 27.1.1 (*)
|    +--- com.facebook.Android:facebook-share:4.32.0
|    |    +--- com.facebook.Android:facebook-core:4.32.0 (*)
|    |    \--- com.facebook.Android:facebook-common:4.32.0 (*)
|    +--- com.facebook.Android:facebook-places:4.32.0
|    |    \--- com.facebook.Android:facebook-core:4.32.0 (*)
|    +--- com.facebook.Android:facebook-applinks:4.32.0
|    |    +--- com.facebook.Android:facebook-core:4.32.0 (*)
|    |    \--- com.parse.bolts:bolts-Android:1.4.0 (*)
|    \--- com.facebook.Android:facebook-messenger:4.32.0
|         +--- com.facebook.Android:facebook-core:4.32.0 (*)
|         \--- com.parse.bolts:bolts-Android:1.4.0 (*)
+--- com.crashlytics.sdk.Android:crashlytics:2.9.6
|    +--- com.crashlytics.sdk.Android:answers:1.4.4
|    |    \--- io.fabric.sdk.Android:fabric:1.4.5
|    +--- com.crashlytics.sdk.Android:beta:1.2.10
|    +--- io.fabric.sdk.Android:fabric:1.4.5
|    \--- com.crashlytics.sdk.Android:crashlytics-core:2.6.5
|         +--- com.crashlytics.sdk.Android:answers:1.4.4 (*)
|         \--- io.fabric.sdk.Android:fabric:1.4.5
+--- com.firebase:geofire-Android:2.1.0
+--- com.google.firebase:firebase-core:16.0.4
|    +--- com.google.firebase:firebase-analytics:16.0.4 -> 16.0.5
|    |    +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0
|    |    |    \--- com.Android.support:support-v4:26.1.0 -> 27.1.1 (*)
|    |    +--- com.google.Android.gms:play-services-measurement-api:[16.0.3] -> 16.0.3
|    |    |    +--- com.google.Android.gms:play-services-ads-identifier:16.0.0
|    |    |    |    \--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    |    +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    |    +--- com.google.Android.gms:play-services-measurement-base:[16.0.4] -> 16.0.4
|    |    |    |    \--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    |    +--- com.google.Android.gms:play-services-stats:16.0.1
|    |    |    |    \--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    |    +--- com.google.Android.gms:play-services-tasks:16.0.1
|    |    |    |    \--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    |    +--- com.google.firebase:firebase-analytics-impl:[16.2.3] -> 16.2.3
|    |    |    |    +--- com.google.Android.gms:play-services-ads-identifier:16.0.0 (*)
|    |    |    |    +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    |    |    +--- com.google.Android.gms:play-services-measurement-base:[16.0.4] -> 16.0.4 (*)
|    |    |    |    +--- com.google.Android.gms:play-services-stats:16.0.1 (*)
|    |    |    |    +--- com.google.Android.gms:play-services-tasks:16.0.1 (*)
|    |    |    |    +--- com.google.firebase:firebase-common:16.0.3 -> 16.0.4
|    |    |    |    |    +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    |    |    |    \--- com.google.Android.gms:play-services-tasks:16.0.1 (*)
|    |    |    |    \--- com.google.firebase:firebase-iid:17.0.3 -> 17.0.4
|    |    |    |         +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    |    |         +--- com.google.Android.gms:play-services-stats:16.0.1 (*)
|    |    |    |         +--- com.google.Android.gms:play-services-tasks:16.0.1 (*)
|    |    |    |         +--- com.google.firebase:firebase-common:16.0.3 -> 16.0.4 (*)
|    |    |    |         \--- com.google.firebase:firebase-iid-interop:16.0.1
|    |    |    |              +--- com.google.Android.gms:play-services-base:16.0.1
|    |    |    |              |    +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    |    |              |    \--- com.google.Android.gms:play-services-tasks:16.0.1 (*)
|    |    |    |              \--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    |    +--- com.google.firebase:firebase-common:16.0.3 -> 16.0.4 (*)
|    |    |    \--- com.google.firebase:firebase-iid:17.0.3 -> 17.0.4 (*)
|    |    +--- com.google.Android.gms:play-services-measurement-base:[16.0.4] -> 16.0.4 (*)
|    |    +--- com.google.Android.gms:play-services-stats:16.0.1 (*)
|    |    +--- com.google.firebase:firebase-analytics-impl:[16.2.3] -> 16.2.3 (*)
|    |    \--- com.google.firebase:firebase-common:16.0.3 -> 16.0.4 (*)
|    \--- com.google.firebase:firebase-measurement-connector-impl:17.0.2
|         +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|         +--- com.google.Android.gms:play-services-measurement-api:16.0.2 -> 16.0.3 (*)
|         +--- com.google.Android.gms:play-services-measurement-base:16.0.3 -> 16.0.4 (*)
|         +--- com.google.firebase:firebase-analytics:16.0.4 -> 16.0.5 (*)
|         +--- com.google.firebase:firebase-analytics-impl:16.2.2 -> 16.2.3 (*)
|         +--- com.google.firebase:firebase-common:16.0.3 -> 16.0.4 (*)
|         \--- com.google.firebase:firebase-measurement-connector:17.0.1
|              \--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
+--- com.google.firebase:firebase-messaging:17.3.4
|    +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    +--- com.google.Android.gms:play-services-tasks:16.0.1 (*)
|    +--- com.google.firebase:firebase-common:16.0.3 -> 16.0.4 (*)
|    +--- com.google.firebase:firebase-iid:[17.0.4] -> 17.0.4 (*)
|    \--- com.google.firebase:firebase-measurement-connector:17.0.1 (*)
+--- com.google.firebase:firebase-storage:16.0.4
|    +--- com.google.Android.gms:play-services-base:16.0.1 (*)
|    +--- com.google.Android.gms:play-services-tasks:16.0.1 (*)
|    \--- com.google.firebase:firebase-common:16.0.3 -> 16.0.4 (*)
+--- com.google.firebase:firebase-auth:16.0.5
|    +--- com.google.Android.gms:play-services-base:16.0.1 (*)
|    +--- com.google.Android.gms:play-services-basement:16.1.0 (*)
|    +--- com.google.Android.gms:play-services-flags:16.0.1
|    |    +--- com.google.Android.gms:play-services-base:16.0.1 (*)
|    |    \--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    +--- com.google.Android.gms:play-services-tasks:16.0.1 (*)
|    +--- com.google.firebase:firebase-auth-interop:16.0.1
|    |    +--- com.google.Android.gms:play-services-base:16.0.1 (*)
|    |    +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    +--- com.google.Android.gms:play-services-tasks:16.0.1 (*)
|    |    \--- com.google.firebase:firebase-common:16.0.3 -> 16.0.4 (*)
|    \--- com.google.firebase:firebase-common:16.0.3 -> 16.0.4 (*)
+--- com.google.firebase:firebase-database:16.0.4
|    +--- com.google.Android.gms:play-services-base:16.0.1 (*)
|    +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    +--- com.google.Android.gms:play-services-tasks:16.0.1 (*)
|    +--- com.google.firebase:firebase-common:16.0.3 -> 16.0.4 (*)
|    \--- com.google.firebase:firebase-database-collection:16.0.0
|         \--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
+--- com.firebaseui:firebase-ui-storage:2.0.1
|    +--- com.Android.support:appcompat-v7:25.3.1 -> 27.1.1 (*)
|    +--- com.Android.support:palette-v7:25.3.1
|    |    +--- com.Android.support:support-compat:25.3.1 -> 27.1.1 (*)
|    |    \--- com.Android.support:support-core-utils:25.3.1 -> 27.1.1 (*)
|    +--- com.github.bumptech.glide:glide:3.7.0 -> 3.8.0
|    \--- com.google.firebase:firebase-storage:11.0.1 -> 16.0.4 (*)
+--- com.google.firebase:firebase-dynamic-links:16.1.3
|    +--- com.google.Android.gms:play-services-base:16.0.1 (*)
|    +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    +--- com.google.Android.gms:play-services-measurement-base:[16.0.4] -> 16.0.4 (*)
|    +--- com.google.Android.gms:play-services-tasks:16.0.1 (*)
|    +--- com.google.firebase:firebase-analytics-impl:[16.2.3] -> 16.2.3 (*)
|    \--- com.google.firebase:firebase-common:16.0.3 -> 16.0.4 (*)
+--- com.google.firebase:firebase-analytics:16.0.5 (*)
+--- com.google.firebase:firebase-config:16.1.0
|    +--- com.google.Android.gms:play-services-base:16.0.1 (*)
|    +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    +--- com.google.Android.gms:play-services-phenotype:16.0.0
|    |    +--- com.google.Android.gms:play-services-base:16.0.1 (*)
|    |    +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    \--- com.google.Android.gms:play-services-tasks:16.0.1 (*)
|    +--- com.google.Android.gms:play-services-tasks:16.0.1 (*)
|    +--- com.google.firebase:firebase-abt:16.0.1
|    |    +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    +--- com.google.firebase:firebase-analytics-impl:16.2.2 -> 16.2.3 (*)
|    |    \--- com.google.firebase:firebase-common:16.0.3 -> 16.0.4 (*)
|    +--- com.google.firebase:firebase-analytics:16.0.4 -> 16.0.5 (*)
|    +--- com.google.firebase:firebase-analytics-impl:16.2.2 -> 16.2.3 (*)
|    +--- com.google.firebase:firebase-common:16.0.3 -> 16.0.4 (*)
|    \--- com.google.firebase:firebase-iid:17.0.3 -> 17.0.4 (*)
+--- com.google.firebase:firebase-invites:16.0.5
|    +--- com.google.Android.gms:play-services-appinvite:16.0.5
|    |    +--- com.google.Android.gms:play-services-base:16.0.1 (*)
|    |    +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    +--- com.google.Android.gms:play-services-measurement-base:[16.0.4] -> 16.0.4 (*)
|    |    +--- com.google.Android.gms:play-services-tasks:16.0.1 (*)
|    |    \--- com.google.firebase:firebase-dynamic-links:[16.1.3] -> 16.1.3 (*)
|    \--- com.google.firebase:firebase-analytics:16.0.5 (*)
+--- com.google.firebase:firebase-functions:16.1.2
|    +--- com.google.Android.gms:play-services-base:16.0.1 (*)
|    +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    +--- com.google.Android.gms:play-services-tasks:16.0.1 (*)
|    +--- com.google.firebase:firebase-auth-interop:16.0.1 (*)
|    +--- com.google.firebase:firebase-common:16.0.4 (*)
|    +--- com.google.firebase:firebase-iid:17.0.3 -> 17.0.4 (*)
|    +--- com.google.firebase:firebase-iid-interop:16.0.1 (*)
|    \--- com.squareup.okhttp:okhttp:2.7.2
|         \--- com.squareup.okio:okio:1.6.0
+--- com.google.firebase:firebase-ads:17.1.1
|    +--- com.google.Android.gms:play-services-ads:17.1.1
|    |    +--- com.Android.support:customtabs:26.1.0 -> 27.0.2 (*)
|    |    +--- com.google.Android.gms:play-services-ads-base:[17.1.1] -> 17.1.1
|    |    +--- com.google.Android.gms:play-services-ads-identifier:16.0.0 (*)
|    |    +--- com.google.Android.gms:play-services-ads-lite:[17.1.1] -> 17.1.1
|    |    |    +--- com.google.Android.gms:play-services-ads-base:[17.1.1] -> 17.1.1
|    |    |    +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    |    \--- com.google.Android.gms:play-services-measurement-sdk-api:16.0.3
|    |    |         +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    |         \--- com.google.Android.gms:play-services-measurement-base:[16.0.4] -> 16.0.4 (*)
|    |    +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    \--- com.google.Android.gms:play-services-gass:[17.1.1] -> 17.1.1
|    |         +--- com.google.Android.gms:play-services-ads-base:[17.1.1] -> 17.1.1
|    |         \--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    \--- com.google.firebase:firebase-analytics:16.0.5 (*)
+--- com.google.Android.gms:play-services-location:16.0.0
|    +--- com.google.Android.gms:play-services-base:16.0.1 (*)
|    +--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    +--- com.google.Android.gms:play-services-places-placereport:16.0.0
|    |    \--- com.google.Android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    \--- com.google.Android.gms:play-services-tasks:16.0.1 (*)
+--- com.Android.billingclient:billing:1.1
|    \--- com.Android.support:support-annotations:25.0.0 -> 27.1.1
+--- com.Android.support.constraint:constraint-layout:2.0.0-alpha2
|    +--- com.Android.support:appcompat-v7:27.1.1 (*)
|    +--- com.Android.support:recyclerview-v7:27.1.1
|    |    +--- com.Android.support:support-annotations:27.1.1
|    |    +--- com.Android.support:support-compat:27.1.1 (*)
|    |    \--- com.Android.support:support-core-ui:27.1.1 (*)
|    \--- com.Android.support.constraint:constraint-layout-solver:2.0.0-alpha2
+--- com.Android.support:multidex:1.0.3
+--- com.Android.support:percent:27.1.1
|    \--- com.Android.support:support-compat:27.1.1 (*)
+--- com.Android.support:recyclerview-v7:27.1.1 (*)
+--- com.Android.support:support-fragment:27.1.1 (*)
+--- com.Android.support:support-vector-drawable:27.1.1 (*)
+--- com.Android.support:appcompat-v7:27.1.1 (*)
+--- com.Android.support:design:27.1.1
|    +--- com.Android.support:support-v4:27.1.1 (*)
|    +--- com.Android.support:appcompat-v7:27.1.1 (*)
|    +--- com.Android.support:recyclerview-v7:27.1.1 (*)
|    \--- com.Android.support:transition:27.1.1
|         +--- com.Android.support:support-annotations:27.1.1
|         \--- com.Android.support:support-compat:27.1.1 (*)
+--- com.Android.support:animated-vector-drawable:27.1.1 (*)
+--- com.baoyz.swipemenulistview:library:1.3.0
|    \--- com.Android.support:support-v4:22.1.1 -> 27.1.1 (*)
+--- me.himanshusoni.chatmessageview:chat-message-view:1.0.3
+--- com.github.bumptech.glide:glide:3.8.0
+--- com.github.warkiz.widget:indicatorseekbar:1.1.2
+--- com.github.guilhe:seekbar-ranged-view:1.0.1
|    \--- com.Android.support:appcompat-v7:26.0.1 -> 27.1.1 (*)
+--- com.crystal:crystalrangeseekbar:1.1.3
|    \--- com.Android.support:appcompat-v7:23.4.0 -> 27.1.1 (*)
\--- com.Android.support:multidex:1.0.2 -> 1.0.3

(*) - dependencies omitted (listed previously)
(n) - Not resolved (configuration is not meant to be resolved)

Entschuldigung für alle Codeblöcke, aber ich dachte, es wäre einfacher zu verstehen.

Vielen Dank für Ihre Zeit.

3
Pierre

Ich habe also eine Lösung für mein Problem gefunden, aber das ist meiner Meinung nach nicht der beste Weg.

Ich musste mehrere Firebase-Libs downgraden, bis es funktioniert, wie Sie auf meinem Sattel sehen können.

implementation 'com.google.firebase:firebase-core:16.0.3'
implementation 'com.google.firebase:firebase-messaging:17.3.2'
implementation 'com.google.firebase:firebase-storage:16.0.2'
implementation 'com.google.firebase:firebase-auth:16.0.3'
implementation 'com.google.firebase:firebase-database:16.0.2'
implementation 'com.firebaseui:firebase-ui-storage:2.0.1'
implementation 'com.google.firebase:firebase-dynamic-links:16.1.1'
implementation 'com.google.firebase:firebase-analytics:16.0.3'
implementation 'com.google.firebase:firebase-config:16.0.0'
implementation 'com.google.firebase:firebase-invites:16.0.3'
implementation 'com.google.firebase:firebase-functions:16.1.0'
implementation 'com.google.firebase:firebase-ads:15.0.1'

implementation 'com.google.Android.gms:play-services-location:15.0.1'
implementation 'com.Android.billingclient:billing:1.1'

Anscheinend hängen einige Bibliotheken voneinander ab. Im Moment werde ich sie nicht auf die neueste Version aktualisieren ... Es würde mich sehr freuen, wenn ich mehr Informationen dazu hätte.

2
Pierre

bitte com.google.firebase:firebase-ads:17.1.1 durch com.google.firebase:firebase-ads:17.1.0 ersetzen

1

Stellen Sie sicher, dass Firebase-Core und Firebase-Adsaktuell sind, indem Sie die letzte Version angeben.

Zum Zeitpunkt meiner Antwort sind sie:

implementation 'com.google.firebase:firebase-core:16.0.6'
implementation 'com.google.firebase:firebase-ads:17.1.2'
0
Mahmoud Shahoud

Implementierung "com.google.firebase: Firebase-Core: 16.0.4" ändern in Implementierung "Com.google.firebase: Firebase-Core: +"

0
PBR

nun, ich habe 2 Tage auf genau die gleichen Pbs verbracht. Also habe ich zuerst die -Implementierung "com.google.firebase: firebase-core: 16.0.4" geändert -> die Implementierung "com.google.firebase: firebase-core: 16.0.5", konnte sie jedoch ausführen Die genaue Version 16.0.5 kann nicht gefunden werden. Was für mich am Ende seltsam funktioniert, ist zu ändern 'com.google.firebase: firebase-core: 16.0.4' -> Implementierung 'com.google.firebase: firebase-core: +'

Hier sind meine Abhängigkeiten für die Build-Ebene auf App-Ebene, falls dies hilfreich sein könnte: Abhängigkeiten {

implementation fileTree(include: ['*.jar'], dir: 'libs')


configurations.androidTestImplementation.dependencies.each { androidTestImplementationDependency ->
    androidTestImplementationDependency.exclude group: 'com.Android.support'
}

implementation ("com.Android.support:support-v4:28.0.0") {
    force = true //<-- force dependency resolution to 28.0.0 in my case
}
implementation project(':slyce-messaging')
implementation 'com.Android.support:multidex:1.0.3'
implementation 'com.google.firebase:firebase-auth:16.0.5'
implementation 'com.Android.support:support-media-compat:28.0.0'
implementation 'com.Android.support:customtabs:28.0.0'
implementation 'com.Android.support:support-core-utils:28.0.0'
implementation 'com.Android.support:design:28.0.0'
implementation 'com.github.bumptech.glide:glide:3.7.0'
implementation 'de.hdodenhof:circleimageview:2.1.0'
implementation 'com.Android.support:appcompat-v7:28.0.0'
implementation 'com.google.Android.gms:play-services-auth:16.0.1'
implementation 'com.google.firebase:firebase-core:+'
implementation 'com.crashlytics.sdk.Android:crashlytics:2.9.6'
implementation 'com.google.firebase:firebase-database:16.0.5'
implementation 'com.google.firebase:firebase-storage:16.0.5'
implementation 'com.google.firebase:firebase-crash:16.2.1'
implementation 'com.google.firebase:firebase-messaging:17.3.4'
implementation 'com.google.firebase:firebase-config:16.1.0'
implementation 'com.google.firebase:firebase-invites:16.0.4'
implementation 'com.firebaseui:firebase-ui:2.0.1'
implementation 'com.google.Android.gms:play-services-appinvite:16.0.5'
implementation 'com.amulyakhare:com.amulyakhare.textdrawable:1.0.1'
implementation 'com.Android.support:recyclerview-v7:28.0.0'
implementation 'com.Android.support:cardview-v7:28.0.0'
implementation 'com.firebase:firebase-jobdispatcher:0.5.2'
implementation 'net.rimoto:intlphoneinput:1.0.1'
implementation 'com.github.marlonlom:timeago:3.0.1'
implementation 'com.Android.support.constraint:constraint-layout:1.1.3'
testImplementation 'junit:junit:4.12'
androidTestImplementation 'junit:junit:4.12'
androidTestImplementation 'com.Android.support.test.espresso:espresso-core:3.0.2'
androidTestImplementation 'com.Android.support.test:runner:1.0.2'
androidTestImplementation 'com.Android.support:support-annotations:28.0.0'
implementation 'com.google.firebase:firebase-ads:17.1.1'

}

plugin anwenden: "com.google.gms.google-services"

Unten ist die Fehlermeldung, ich habe dieselbe Sache: Java.lang.NoSuchMethodError: Keine statische Methode zzc (Landroid/os/Bundle;) Lcom/google/Android/gms/Messung/intern/zzak; in der Klasse Lcom/google/Android/gms/Messung/intern/zzak; oder ihre Superklassen (Deklaration von "com.google.Android.gms.measurement.internal.zzak" wird in ... angezeigt.) unter com.google.firebase.analytics.connector.AnalyticsConnectorImpl.getInstance (unbekannte Quelle) unter com.google.firebase.analytics.connector.internal.zzb.create (unbekannte Quelle)

0
kchan27

Folge diese Antwort Ich hoffe, das wird dein Problem lösen, lass mich wissen, ob es funktioniert.

0