webentwicklung-frage-antwort-db.com.de

Fehler: Die minimale unterstützte Gradle-Version ist 4.6 in Android studio 3.0.1

Ich möchte kraftvoll 4.4 gradle version verwenden

Gibt es dafür eine Lösung? Ich suche seit langem nach einer Lösung, konnte sie aber nicht finden

Die minimal unterstützte Gradle-Version ist 4.6. Die aktuelle Version ist 4.4. Bitte korrigieren Sie die Gradle-Einstellungen des Projekts. Korrigieren Sie den Gradle-Wrapper und importieren Sie die Projekt-Gradle-Einstellungen erneut

gradle-wrapper.properties

#Mon Sep 03 10:52:24 IST 2018
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-4.4-all.Zip

build.gradle

 dependencies {
          classpath "com.Android.tools.build:gradle:3.2.0-beta05"
        classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"
        classpath 'io.fabric.tools:gradle:1.+'
        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }

Projektstrukturdialog

enter image description here

10
Kishore Jethava

Die mindestens unterstützte Version des Android Plugins für Gradle 3.2.0+ Erfordert die Gradle-Version 4.6 Oder höher. Wenn Sie die Gradle-Version 4.4 Verwenden möchten, Sie müssen Ihr Android Plugin auf 3.1.0 downgraden.

Ausführliche Informationen zur Kompatibilität von Plugins und Gradle-Versionen finden Sie hier https://developer.Android.com/studio/releases/gradle-plugin

28
Qasim