webentwicklung-frage-antwort-db.com.de

Fehler beim Auflösen: com.google.Android.gms: play-services-basement: 12.0.1

Hier sind meine Abhängigkeiten

dependencies {

        compile project(':react-native-fcm')
        // compile 'com.google.firebase:firebase-core:11.2.0' //FCM - this decides your firebase SDK version
        compile(project(':react-native-maps')){
            exclude group: 'com.google.Android.gms', module: 'play-services-base'
            exclude group: 'com.google.Android.gms', module: 'play-services-maps'
        }
        compile(project(":react-native-google-place-picker")){
            exclude group: "com.google.Android.gms"
        }
        compile (project(':RNAdMob')){
            exclude group: "com.google.Android.gms"
        }
        //compile project(':react-native-device-info')
        compile project(':react-native-fbsdk')
        compile (project(':react-native-mauron85-background-geolocation')){
            exclude group: "com.google.Android.gms"
        }
        compile project(':react-native-Android-location-enabler')
        compile project(':react-native-wheel-picker')
        compile project(':react-native-sound')

        compile project(':react-native-vector-icons')
        compile (project(':react-native-google-analytics-bridge')){
            exclude group: "com.google.Android.gms"
        }
        //compile project(':react-native-device-info')
        compile(project(":react-native-device-info")){
            exclude group: "com.google.Android.gms"
        }
        compile fileTree(dir: "libs", include: ["*.jar"])
        compile "com.Android.support:appcompat-v7:23.0.1"
        //compile "com.facebook.react:react-native:+"  // From node_modules
        compile "com.facebook.react:react-native:0.44.3"

        compile(project(":react-native-google-signin")){
            exclude group: "com.google.Android.gms"
        }
        compile (project(':tipsi-stripe')){
            exclude group: "com.google.firebase"
            exclude group: "com.Android.support"
            exclude group: "com.google.Android.gms"
        }
        compile 'com.google.Android.gms:play-services-auth:11.0.2' // should be at least 9.0.0
        compile 'com.google.Android.gms:play-services-places:11.0.2'
        compile 'com.google.Android.gms:play-services-maps:11.0.2'
        //compile 'com.google.Android.gms:play-services-location:11.0.2'

        compile 'com.google.Android.gms:play-services-wallet:11.0.2'
        compile 'com.google.Android.gms:play-services-gcm:11.0.2'

        compile 'com.google.Android.gms:play-services-analytics:11.0.2'
        compile 'com.google.Android.gms:play-services-ads:11.0.2'

    }

Fehler beim Abrufen vom RNAdMob-Projekt. aber ich habe das gms-paket ausgeschlossen. Ich habe keine Änderungen am Code vorgenommen. Gestern hat es funktioniert und kompiliert. Ich frage mich, warum es heute nicht kompiliert wird. Ich habe nirgends das Modul "Play-Services-Basement: 12.0.1" hinzugefügt.

In Android/app/build.gradle füge dies hinzu:

def _ext = rootProject.ext
def _googlePlayServicesVersion = _ext.has('googlePlayServicesVersion') ? _ext.googlePlayServicesVersion : '+'

In Android/build.gradle füge dies hinzu:

ext { 
    // dependency versions
    googlePlayServicesVersion = "+"     
}

Im Allgemeinen empfehle ich in der nächsten Zukunft, Gradle und SDK in Ihrem Projekt zu aktualisieren

Im Moment können Sie versuchen, maven in Android/build.gradle hinzuzufügen:

buildscript { 
 repositories { 
    maven { url "https://maven.google.com" }
    jcenter()
    ...
 ...
 allprojects { 
   repositories { 
     mavenLocal() 
     maven { url "https://maven.google.com" } 
     jcenter()
     ...
 ...
5

Verschieben Sie google() nach vor jcenter() in Ihrem Build.gradle, z.

allprojects {
    repositories {
        mavenLocal()
        google()
        jcenter()
        maven { url "https://jitpack.io" }
        maven {
            url "https://maven.google.com" // Google's Maven repository
        }
    }
}
24
Martin Lockett