webentwicklung-frage-antwort-db.com.de

Fehler: Analyse des Pakets während der Installation von APK

Ich versuche, meine App zu installieren, indem ich Package Installer über den E-Mail-Anhang in Yahoo ausführe. Mein Telefon ist in der Version 4.1 (Jellybean), das sollte also funktionieren, oder?

Ich erhalte jedoch die Fehlermeldung, dass beim Parsen des Pakets ein Problem aufgetreten ist, obwohl mein AndroidManifest den Wert minSdkVersion 1 angibt und der Wert meines Telefons höher ist.

Ich habe die Installation von apk aus Quellen aktiviert, die nicht aus dem Playstore auf meinem Telefon stammen. Was vermisse ich?

18
u3l

Ich erhalte die Fehlermeldung, dass beim Parsen des Pakets ein Problem aufgetreten ist.

Dies liegt daran, dass Ihre App nicht mit Ihrem Gerät kompatibel ist. Möglicherweise hat Ihr Entwickler den Wert für minSDKVersion auf hoch gesetzt. Wenn Ihre Geräte-API-Stufe niedriger als minSDKVersion ist, führt dies zu einem Parsing-Paketfehler, oder Ihr Entwickler hat die maxSDKVersion auf niedriger als Ihre Geräte-API-Stufe gesetzt.

Zum Beispiel: Wenn Ihr Gerät Android 2.2 ist, dann hat Ihr Entwickler, der das APK erstellt hat, das minSDKVersion auf 10 gesetzt, dann funktioniert es im Android) nicht = 2.2 und gibt den Parsing-Paketfehler aus oder Wenn Ihr Entwickler maxSDKVersion auf 8 gesetzt hat, wird die App nicht über Android OS 2.2) installiert, und wenn Sie versuchen, sie zu installieren, dann Sie wird den Parsing-Paketfehler erhalten.

23
Ajay S