webentwicklung-frage-antwort-db.com.de

Android "Sie müssen ein Theme.AppCompat-Design (oder einen Nachkommen) mit der Designbibliothek verwenden"

Ok, ich bekomme diesen Fehler (Titel) . Viele Post schlug mir (sogar Android Studio) vor, das Thema zu App.Appcompat zu ändern, ich habe es getan.

Manifest-Datei:

 <uses-permission Android:name="Android.permission.INTERNET" />

<application
    Android:allowBackup="true"
    Android:icon="@mipmap/ic_launcher"
    Android:label="@string/app_name"
    Android:supportsRtl="true"
    Android:theme="@style/Theme.AppCompat">
    <activity
        Android:name=".activity.MainActivity"
        Android:label="@string/app_name"
        Android:theme="@style/AppTheme.NoActionBar">
        <intent-filter>
            <action Android:name="Android.intent.action.MAIN" />

            <category Android:name="Android.intent.category.LAUNCHER" />
        </intent-filter>
    </activity>

    <activity
        Android:name=".activity.ContactAcitivty"
        Android:label="@string/activity_title_contact" />
    <activity
        Android:name=".activity.CopyrightActivity"
        Android:label="@string/activity_title_copyright" />
    <activity Android:name=".activity.FormActivity">
            <intent-filter>
                <action Android:name="info.androidhive.navigationdrawer.activity.FormActivity" />

                <category Android:name="Android.intent.category.DEFAULT" />
            </intent-filter>
        </activity>

</application>

Style.xml

    <style name="AppTheme" parent="Theme.AppCompat.Light.DarkActionBar">
    <!-- Customize your theme here. -->
    <item name="colorPrimary">@color/colorPrimary</item>
    <item name="colorPrimaryDark">@color/colorPrimaryDark</item>
    <item name="colorAccent">@color/colorAccent</item>
    </style>
    <style name="AppTheme.NoActionBar">
    <item name="windowActionBar">false</item>
    <item name="windowNoTitle">true</item>
</style>
<style name="AppTheme.AppBarOverlay"  parent="ThemeOverlay.AppCompat.Dark.ActionBar" />
<style name="AppTheme.PopupOverlay" parent="ThemeOverlay.AppCompat.Light" />

Aber trotzdem hat sich nichts geändert.

Ich weiß nicht, was passiert ist, seit ich dieses Problem zuvor nicht hatte (ich habe App.compat nicht in die Manifest-Datei eingefügt).

Gradle:

compile 'com.Android.support:appcompat-v7:24.0.0-beta1'
compile 'com.Android.support:design:24.0.0-beta1'
compile 'com.Android.support:support-v4:24.0.0-beta1'
compile 'com.github.bumptech.glide:glide:3.7.0'
compile 'com.Android.support.constraint:constraint-layout:+'
testCompile 'junit:junit:4.12'

Das Fehlerprotokoll:

Java.lang.IllegalArgumentException: You need to use a Theme.AppCompat theme     (or descendant) with the design library.    
at Android.support.design.widget.ThemeUtils.checkAppCompatTheme(ThemeUtils.Java:36)     
at Android.support.design.widget.NavigationView.<init> (NavigationView.Java:102)   
at Android.support.design.widget.NavigationView.<init>(NavigationView.Java:96)   
at Java.lang.reflect.Constructor.newInstance(Constructor.Java:423)  
at Android.view.LayoutInflater.createViewFromTag(LayoutInflater.Java:727)         at Android.view.LayoutInflater.rInflate_Original(LayoutInflater.Java:858)           

at Android.view.LayoutInflater_Delegate.rInflate(LayoutInflater_Delegate.Java:70)  
at Android.view.LayoutInflater.rInflate(LayoutInflater.Java:834)      
at Android.view.LayoutInflater.rInflateChildren(LayoutInflater.Java:821)
at Android.view.LayoutInflater.inflate(LayoutInflater.Java:518)  
at Android.view.LayoutInflater.inflate(LayoutInflater.Java:397)

 

Danke für Ihre Hilfe

6
Kane Samba

probieren Sie diese Änderungen aus:

in gradle:

compile 'com.Android.support:appcompat-v7:25.2.0'
compile 'com.Android.support:support-v4:25.2.0'
compile 'com.Android.support:design:25.2.0'

Fügen Sie im Manifest auch das Thema appcompat zu Ihrer Aktivität 'Navaigation drawer' hinzu

<activity Android:name=".activity.FormActivity"
           Android:theme="@style/Theme.AppCompat">
            <intent-filter>
                <action Android:name="info.androidhive.navigationdrawer.activity.FormActivity" />

                <category Android:name="Android.intent.category.DEFAULT" />
            </intent-filter>
        </activity>
14
rafsanahmad007

Ihre MainActivity verwendet das @style/AppTheme.NoActionBar-Design und ist kein Nachkomme von Theme.AppCompat

Veränderung 

<style name="AppTheme.NoActionBar">

zu

<style name="AppTheme.NoActionBar" parent="AppTheme">

3

Wenn Sie das Constraint-Layout verwenden, stellen Sie sicher, dass Sie die Version größer oder gleich 1.1.3 verwenden. Ich habe diese Fehlermeldung erhalten, als ich die Version 1.0.2 verwendete

0
Ezio