webentwicklung-frage-antwort-db.com.de

Android SDK - aapt-Fehler: libstdc ++. So.6 kann gemeinsam genutzte Objektdatei nicht öffnen

Ich habe zu Testzwecken ein neues Projekt aus dem Nichts erstellt und alle Parameter auf einer neuen ADT-Installation (Ubuntu Gnome 14.04 LTS, x86_64-CPU) auf den Standard zurückgesetzt (ich habe keine Codeänderungen vorgenommen), aber ich habe Folgendes Fehler in der Eclipse-Konsole:

[2014-06-11 09:03:10 - Kronos] /home/erwan/Applications/ADT/adt-bundle-linux-x86_64-20140321/sdk/build-tools/19.1.0/aapt: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

Folgendes habe ich bereits versucht:

-> Ich habe versucht, ia32-libs, libstdc ++ und libstdc ++ 6 über das Ubuntu-Software-Repository (neu) zu installieren: Keine Änderung

-> Auf Aktualisierung überprüft (für Eclipse und das SDK): Keine Änderung

-> Alle neu installiert Android Build tools: Keine Änderung

-> Neuinstallation von ADB: Keine Änderung

36
Dremor
Sudo apt-get install lib32stdc++6 lib32z1
69
Jayesh Bhoi

Auf meinem 64-Bit-Ubuntu 14.04-Desktop war dies alles, was ich brauchte:

Sudo apt-get install lib32stdc++6
22
weiyin

Ich habe auch einen 64-Bit-Ubuntu 14.04-Desktop, und die richtige Antwort für dieses Setup lautet in der Tat:

Sudo apt-get install lib32stdc++6
7
Jeff Martin

In meinem Ubuntu 16.04 kann ich nicht "alle" Libs installieren (Sudo apt-get install lib32stdc ++ 6) mit der Meldung:

$ Sudo apt-get install libgl1-mesa-dev:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-dev:i386 : Depends: libgl1-mesa-glx:i386 (= 11.2.0-1ubuntu2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Nach einigem Graben stellte ich fest, dass ich das aapt mit SDK 19 verwendete. (Android-sdk-linux/build-tools/19.x.y/aapt)

schalte die appt von sdk 19 auf sdk 24 hat bei mir funktioniert.

ändern Sie durch Bearbeiten der entsprechenden Gradle-Datei das buildToolsVersion von 19 auf 24.0.1:

Android {
    buildToolsVersion "24.0.1"
}

ich benutze Ubuntu 15.04 Version. Ich hatte das gleiche Problem. Ich hatte bereits das ia32-libs -Paket installiert (das jetzt in lib32z1 lib32ncurses5-Paket geändert wurde), als ich versuchte, den Befehl zu verwenden

Sudo apt-get installiert lib32stdc ++ 6 lib32z1 lib32z1-dev

ich habe eine Liste mit lib32stdc ++ 6-Paketen erhalten, die das Problem möglicherweise lösen, aber dieser Befehl konnte das Problem nicht beheben. Also habe ich gerade das Paket lib32stdc ++ 6 mit dem Befehl installiert

Sudo apt-get installiert lib32stdc ++ 6

das hat bei mir perfekt geklappt

0
kingdynastyk