webentwicklung-frage-antwort-db.com.de

Wie bekomme ich einen USB-WLAN-D-Link DWA-125 rev D1 rtl8188etv zum Laufen?

jungs. DWA-125 rev.D1, RTL8188ETV. Ubuntu 12.04 LTS. lsusb, iwconfig, ifconfig, ip addr, lshw-C Netzwerk:

[email protected]:~# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 058f:6362 Alcor Micro Corp. Flash Card Reader/Writer
Bus 001 Device 004: ID 2001:330f D-Link Corp. 
Bus 002 Device 002: ID 09da:000a A4 Tech Co., Ltd Optical Mouse Opto 510D
[email protected]:~# iwconfig 
lo        no wireless extensions.

eth0      no wireless extensions.

[email protected]:~# ifconfig 
eth0      Link encap:Ethernet  HWaddr 6c:62:6d:a7:a3:99  
          inet addr:192.168.137.109  Bcast:192.168.137.255  Mask:255.255.255.0
          inet6 addr: fe80::6e62:6dff:fea7:a399/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3791 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2394 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3715856 (3.7 MB)  TX bytes:354575 (354.5 KB)
          Interrupt:43 Base address:0x6000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:170 errors:0 dropped:0 overruns:0 frame:0
          TX packets:170 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:20868 (20.8 KB)  TX bytes:20868 (20.8 KB)

[email protected]:~# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope Host lo
    inet6 ::1/128 scope Host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 6c:62:6d:a7:a3:99 brd ff:ff:ff:ff:ff:ff
    inet 192.168.137.109/24 brd 192.168.137.255 scope global eth0
    inet6 fe80::6e62:6dff:fea7:a399/64 scope link 
       valid_lft forever preferred_lft forever
[email protected]:~# lshw -C network
  *-network               
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: [email protected]:04:00.0
       logical name: eth0
       version: 06
       serial: 6c:62:6d:a7:a3:99
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl_nic/rtl8168e-2.fw ip=192.168.137.109 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       resources: irq:43 ioport:e800(size=256) memory:dcfff000-dcffffff memory:dcff8000-dcffbfff

RTL8188C_8192C_USB_linux_v4.0.2_9000.20130911 ist fehlerfrei installiert.

modprobe -r rtl8192cu
modprobe rtl8192cu swenc=1
echo "2001 330f" > /sys/bus/usb/drivers/rtl8192cu/new_id
iwconfig

dmesg | Schwanz -20:

<pre><code>[email protected]:~# dmesg | tail -20
[  116.464842] type=1400 audit(1383584988.604:28): apparmor="DENIED" operation="open" parent=1 profile="/usr/lib/telepathy/mission-control-5" name="/usr/share/gvfs/remote-volume-monitors/" pid=1894 comm="mission-control" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
[  406.018811] type=1400 audit(1383585279.029:29): apparmor="DENIED" operation="capable" parent=1 profile="/usr/sbin/cupsd" pid=900 comm="cupsd" pid=900 comm="cupsd" capability=36  capname="block_suspend"
[  944.530863] type=1400 audit(1383585819.155:30): apparmor="DENIED" operation="capable" parent=1 profile="/usr/sbin/cupsd" pid=900 comm="cupsd" pid=900 comm="cupsd" capability=36  capname="block_suspend"
[ 1487.813757] cfg80211: Calling CRDA to update world regulatory domain
[ 1487.845269] usbcore: registered new interface driver rtl8192cu
[ 1507.324866] rtl8192cu: Chip version 0x10
[ 1507.453467] rtl8192cu: MAC address: 00:00:**:**:**:**
[ 1507.453480] rtl8192cu: Board Type 7
[ 1507.453780] rtlwifi: rx_max_size 15360, rx_urb_num 8, in_ep 1</code></pre>

Bedeutet dies, dass der Treiber erfolgreich installiert wurde? Aber iwconfig gibt wieder nichts für wlan0. Bitte helfen Sie mir, nicht zu Windows zurückzukehren ...

2
Sergey

Ich habe den gleichen D-Link DWA-125 rev.D1, aber

lsusb

druckt

...
Bus 001 Device 005: ID 2001:3310 D-Link Corp. 
...

(ID beachten)

Und damit es funktioniert, ändere ich die Datei rtl8188eu/os_dep/usb_intf.c

-       {USB_DEVICE(0x2001, 0x330F)}, /* DLink DWA-125 REV D1 */

zum:

+       {USB_DEVICE(0x2001, 0x3310)}, /* DLink DWA-125 REV D1 */

speichern Sie es

Sudo make
Sudo make install
Sudo modprobe -r 8188eu
Sudo modprobe 8188eu

und jetzt arbeitet Treiber für mich :)

Sie haben den rtl8192cu-Treiber korrekt installiert, es wurde jedoch keine drahtlose Schnittstelle erstellt, da rtl8192cu für Ihr Gerät nicht korrekt ist. Bitte besorgen Sie sich eine temporäre kabelgebundene Ethernet-Verbindung und führen Sie folgende Schritte aus:

Sudo apt-get install git
git clone https://github.com/purchae/rtl8188eu.git
cd rtl8188eu
make
Sudo make install
Sudo modprobe -r rtl8192cu
Sudo modprobe 8188eu

Wenn eine neuere Kernelversion von Update Manager installiert wird, kompilieren Sie nach dem erforderlichen Neustart Folgendes neu:

cd rtl8188eu
make clean
make
Sudo make install
Sudo modprobe 8188eu
1
chili555

Das größte Dankeschön an Sie. Schließlich wird der Treiber installiert. Das einzige Problem ist, dass der Dongle nicht richtig funktioniert: Nach 7 bis 10 Sekunden Download-nichts-oder-nichts-tun-im-Internet zeigt das Symbol in der Taskleiste "kein Signal" an, Ping ist unbegrenzt.

[email protected]:~$ iwconfig 
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"Home2"  Nickname:"<[email protected]>"
          Mode:Managed  Frequency:2.452 GHz  Access Point: **:**:**:**:**:**   
          Bit Rate:72.2 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=100/100  Signal level=97/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Nur für den Fall, dass ich erwähnte, dass wenn ich anfange, etwas wirklich Großes herunterzuladen, mein gutes Internet existiert, solange der Downloadprozess dauert. Was habe ich falsch gemacht? Übrigens, in Windows funktioniert es perfekt.

0
user211722